new package: html-xml-utils
Closes https://github.com/termux/termux-packages/issues/4873.
This commit is contained in:
parent
6d610aba8d
commit
022f58b77b
20
packages/html-xml-utils/Makefile.am.patch
Normal file
20
packages/html-xml-utils/Makefile.am.patch
Normal file
@ -0,0 +1,20 @@
|
||||
diff -uNr html-xml-utils-7.9/Makefile.am html-xml-utils-7.9.mod/Makefile.am
|
||||
--- html-xml-utils-7.9/Makefile.am 2020-08-04 20:34:12.000000000 +0000
|
||||
+++ html-xml-utils-7.9.mod/Makefile.am 2020-11-05 23:34:14.389537863 +0000
|
||||
@@ -51,7 +51,7 @@
|
||||
fopencookie.h\
|
||||
class.c hash.c headers.c dict.c fopencookie.c
|
||||
cexport_SOURCES = cexport.c
|
||||
-hxcite_SOURCES = heap.c errexit.c hxcite.c
|
||||
+hxcite_SOURCES = heap.c errexit.c hxcite.c hash.c
|
||||
hxcount_SOURCES = hxcount.c html.y scan.l types.c errexit.c heap.c\
|
||||
openurl.c url.c connectsock.c headers.c dict.c\
|
||||
fopencookie.h fopencookie.c
|
||||
@@ -132,6 +132,7 @@
|
||||
SUFFIXES = .1 .e .html
|
||||
|
||||
$(EXPORTS): $(cexport_SOURCES)
|
||||
+ gcc -I. $(cexport_SOURCES) -o cexport
|
||||
|
||||
.c.e:
|
||||
$(MAKE) cexport
|
13
packages/html-xml-utils/build.sh
Normal file
13
packages/html-xml-utils/build.sh
Normal file
@ -0,0 +1,13 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://www.w3.org/Tools/HTML-XML-utils/
|
||||
TERMUX_PKG_DESCRIPTION="A number of simple utilities for manipulating HTML and XML files"
|
||||
TERMUX_PKG_LICENSE="custom"
|
||||
TERMUX_PKG_LICENSE_FILE="COPYING"
|
||||
TERMUX_PKG_VERSION=7.9
|
||||
TERMUX_PKG_SRCURL=https://www.w3.org/Tools/HTML-XML-utils/html-xml-utils-${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=d86ac96ea660316bef814c17b2a96d54cdf91c69e59614459865c2bfdaee433f
|
||||
TERMUX_PKG_DEPENDS="libcurl, libidn2"
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
|
||||
termux_step_pre_configure() {
|
||||
automake
|
||||
}
|
54
packages/html-xml-utils/hsearch.patch
Normal file
54
packages/html-xml-utils/hsearch.patch
Normal file
@ -0,0 +1,54 @@
|
||||
diff -uNr html-xml-utils-7.9/hash.c html-xml-utils-7.9.mod/hash.c
|
||||
--- html-xml-utils-7.9/hash.c 2018-02-23 14:29:48.000000000 +0000
|
||||
+++ html-xml-utils-7.9.mod/hash.c 2020-11-05 23:28:18.967247150 +0000
|
||||
@@ -1,4 +1,4 @@
|
||||
-#ifndef HAVE_SEARCH_H
|
||||
+#ifndef DONTHAVE_SEARCH_H
|
||||
/*
|
||||
* hsearch() on Mac OS X 10.1.2 appears to be broken: there is no
|
||||
* search.h; there is a search() in the C library, but it doesn't work
|
||||
diff -uNr html-xml-utils-7.9/hxcite.c html-xml-utils-7.9.mod/hxcite.c
|
||||
--- html-xml-utils-7.9/hxcite.c 2018-02-23 14:29:48.000000000 +0000
|
||||
+++ html-xml-utils-7.9.mod/hxcite.c 2020-11-05 23:29:09.671568513 +0000
|
||||
@@ -89,11 +89,7 @@
|
||||
# endif
|
||||
#endif
|
||||
|
||||
-#ifdef HAVE_SEARCH_H
|
||||
-# include <search.h>
|
||||
-#else
|
||||
# include "hash.e"
|
||||
-#endif
|
||||
|
||||
#include <ctype.h>
|
||||
#include <stdbool.h>
|
||||
diff -uNr html-xml-utils-7.9/hxmkbib.c html-xml-utils-7.9.mod/hxmkbib.c
|
||||
--- html-xml-utils-7.9/hxmkbib.c 2018-02-23 14:29:48.000000000 +0000
|
||||
+++ html-xml-utils-7.9.mod/hxmkbib.c 2020-11-05 23:29:04.327113033 +0000
|
||||
@@ -88,11 +88,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <assert.h>
|
||||
|
||||
-#ifdef HAVE_SEARCH_H
|
||||
-# include <search.h>
|
||||
-#else
|
||||
# include "hash.e" /* Use our own implementation */
|
||||
-#endif
|
||||
|
||||
#include <ctype.h>
|
||||
#include <stdbool.h>
|
||||
diff -uNr html-xml-utils-7.9/hxref.c html-xml-utils-7.9.mod/hxref.c
|
||||
--- html-xml-utils-7.9/hxref.c 2018-02-23 14:29:48.000000000 +0000
|
||||
+++ html-xml-utils-7.9.mod/hxref.c 2020-11-05 23:29:15.588072744 +0000
|
||||
@@ -35,11 +35,7 @@
|
||||
#ifdef HAVE_ERRNO_H
|
||||
# include <errno.h>
|
||||
#endif
|
||||
-#ifdef HAVE_SEARCH_H
|
||||
-# include <search.h>
|
||||
-#else
|
||||
# include "hash.e"
|
||||
-#endif
|
||||
|
||||
#if STDC_HEADERS
|
||||
# include <string.h>
|
12
packages/html-xml-utils/include-getopt-h.patch
Normal file
12
packages/html-xml-utils/include-getopt-h.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -uNr html-xml-utils-7.9/hxnum.c html-xml-utils-7.9.mod/hxnum.c
|
||||
--- html-xml-utils-7.9/hxnum.c 2018-08-02 01:21:37.000000000 +0000
|
||||
+++ html-xml-utils-7.9.mod/hxnum.c 2020-11-05 23:15:40.166574007 +0000
|
||||
@@ -38,6 +38,8 @@
|
||||
#include "openurl.e"
|
||||
#include "errexit.e"
|
||||
|
||||
+#include <getopt.h>
|
||||
+
|
||||
#define SECNO "secno" /* class attribute */
|
||||
#define NO_NUM "no-num" /* class-attribute */
|
||||
#define OPTS ":l:h:n:1:2:3:4:5:6:?" /* Command line options */
|
11
packages/html-xml-utils/no-type-redef.patch
Normal file
11
packages/html-xml-utils/no-type-redef.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -uNr html-xml-utils-7.9/fopencookie.h html-xml-utils-7.9.mod/fopencookie.h
|
||||
--- html-xml-utils-7.9/fopencookie.h 2018-02-23 14:29:48.000000000 +0000
|
||||
+++ html-xml-utils-7.9.mod/fopencookie.h 2020-11-05 23:14:30.324621328 +0000
|
||||
@@ -1,6 +1,6 @@
|
||||
#ifndef _FOPENCOOKIE_H_
|
||||
#define _FOPENCOOKIE_H_
|
||||
-typedef signed long long int off64_t;
|
||||
+//typedef signed long long int off64_t;
|
||||
typedef ssize_t cookie_read_function_t (void *, char *, size_t);
|
||||
typedef ssize_t cookie_write_function_t (void *, const char *, size_t);
|
||||
typedef int cookie_seek_function_t (void *, off64_t, int);
|
Loading…
x
Reference in New Issue
Block a user