libvpx: Build with clang
This commit is contained in:
parent
95e6f9429a
commit
03d448338b
@ -10,17 +10,18 @@ termux_step_configure () {
|
||||
# Force fresh install of header files:
|
||||
rm -Rf $TERMUX_PREFIX/include/vpx
|
||||
|
||||
export LD=$CC
|
||||
|
||||
if [ $TERMUX_ARCH = "arm" ]; then
|
||||
export AS=$TERMUX_HOST_PLATFORM-as
|
||||
_CONFIGURE_TARGET="--target=armv7-android-gcc"
|
||||
elif [ $TERMUX_ARCH = "i686" ]; then
|
||||
export AS=yasm
|
||||
export LD=$CC
|
||||
_CONFIGURE_TARGET="--target=x86-android-gcc"
|
||||
elif [ $TERMUX_ARCH = "aarch64" ]; then
|
||||
_CONFIGURE_TARGET="--force-target=arm64-v8a-android-gcc"
|
||||
elif [ $TERMUX_ARCH = "x86_64" ]; then
|
||||
export AS=yasm
|
||||
export LD=$CC
|
||||
_CONFIGURE_TARGET="--target=x86_64-android-gcc"
|
||||
else
|
||||
termux_error_exit "Unsupported arch: $TERMUX_ARCH"
|
||||
@ -31,12 +32,14 @@ termux_step_configure () {
|
||||
# "The issue is that on android we soft enable realtime only.
|
||||
# [..] You can enable non-realtime by setting --disable-realtime-only"
|
||||
# Discovered in https://github.com/termux/termux-packages/issues/554
|
||||
#CROSS=${TERMUX_HOST_PLATFORM}- CC=clang CXX=clang++ $TERMUX_PKG_SRCDIR/configure \
|
||||
$TERMUX_PKG_SRCDIR/configure \
|
||||
--sdk-path=$NDK \
|
||||
$_CONFIGURE_TARGET \
|
||||
--prefix=$TERMUX_PREFIX \
|
||||
--disable-examples \
|
||||
--disable-realtime-only \
|
||||
--disable-unit-tests \
|
||||
--enable-pic \
|
||||
--enable-vp8 \
|
||||
--enable-shared \
|
||||
--enable-small
|
||||
|
@ -1,7 +1,26 @@
|
||||
diff -u -r ../libvpx-1.6.0/configure ./configure
|
||||
--- ../libvpx-1.6.0/configure 2016-07-20 21:15:41.000000000 -0400
|
||||
+++ ./configure 2016-08-10 19:36:59.873847660 -0400
|
||||
@@ -509,7 +509,7 @@
|
||||
diff -u -r ../libvpx-1.6.1/build/make/configure.sh ./build/make/configure.sh
|
||||
--- ../libvpx-1.6.1/build/make/configure.sh 2017-01-12 20:27:27.000000000 +0000
|
||||
+++ ./build/make/configure.sh 2017-07-27 01:11:03.641678047 +0000
|
||||
@@ -891,7 +891,6 @@
|
||||
setup_gnu_toolchain
|
||||
arch_int=${tgt_isa##armv}
|
||||
arch_int=${arch_int%%te}
|
||||
- check_add_asflags --defsym ARCHITECTURE=${arch_int}
|
||||
tune_cflags="-mtune="
|
||||
if [ ${tgt_isa} = "armv7" ] || [ ${tgt_isa} = "armv7s" ]; then
|
||||
if [ -z "${float_abi}" ]; then
|
||||
@@ -1021,7 +1020,6 @@
|
||||
else
|
||||
echo "Assuming standalone build with NDK toolchain."
|
||||
echo "See build/make/Android.mk for details."
|
||||
- check_add_ldflags -static
|
||||
soft_enable unit_tests
|
||||
fi
|
||||
;;
|
||||
diff -u -r ../libvpx-1.6.1/configure ./configure
|
||||
--- ../libvpx-1.6.1/configure 2017-01-12 20:27:27.000000000 +0000
|
||||
+++ ./configure 2017-07-27 01:09:43.590546540 +0000
|
||||
@@ -500,7 +500,7 @@
|
||||
# Supported platforms
|
||||
;;
|
||||
*)
|
||||
|
@ -1,12 +1,16 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://mpv.io/
|
||||
TERMUX_PKG_DESCRIPTION="Command-line media player"
|
||||
TERMUX_PKG_VERSION=0.25.0
|
||||
TERMUX_PKG_VERSION=0.26.0
|
||||
TERMUX_PKG_SHA256=daf3ef358d5f260f2269f7caabce27f446c291457ec330077152127133b71b46
|
||||
TERMUX_PKG_SRCURL=https://github.com/mpv-player/mpv/archive/v${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=07423ffad6921ec4da32f703cd7fbfb27012301dcb736ac8542ac8e6083b0bce
|
||||
TERMUX_PKG_FOLDERNAME=mpv-${TERMUX_PKG_VERSION}
|
||||
TERMUX_PKG_DEPENDS="ffmpeg, openal-soft"
|
||||
TERMUX_PKG_DEPENDS="ffmpeg, openal-soft, libandroid-glob"
|
||||
TERMUX_PKG_RM_AFTER_INSTALL="share/icons share/applications"
|
||||
|
||||
termux_step_pre_configure() {
|
||||
LDFLAGS+=" -landroid-glob"
|
||||
}
|
||||
|
||||
termux_step_make_install () {
|
||||
cd $TERMUX_PKG_SRCDIR
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user