libical: update to 3.0.7
This commit is contained in:
parent
b3e3311c8c
commit
0669f5b8c2
@ -1,53 +0,0 @@
|
||||
Avoid opportunistic linkage against libdb and libicu.
|
||||
|
||||
diff -u -r ../libical-3.0.1/CMakeLists.txt ./CMakeLists.txt
|
||||
--- ../libical-3.0.1/CMakeLists.txt 2017-11-19 14:32:53.000000000 +0000
|
||||
+++ ./CMakeLists.txt 2017-12-08 23:54:59.745527096 +0000
|
||||
@@ -154,47 +154,6 @@
|
||||
set_property(GLOBAL PROPERTY FIND_LIBRARY_USE_LIB64_PATHS True)
|
||||
endif()
|
||||
|
||||
-# libicu is highly recommended for RSCALE support
|
||||
-# libicu can be found at http://www.icu-project.org
|
||||
-# RSCALE info at http://tools.ietf.org/html/rfc7529
|
||||
-find_package(ICU)
|
||||
-set_package_properties(ICU PROPERTIES
|
||||
- TYPE RECOMMENDED
|
||||
- PURPOSE "For RSCALE (RFC7529) support"
|
||||
-)
|
||||
-add_feature_info(
|
||||
- "RSCALE support (RFC7529)"
|
||||
- ICU_FOUND
|
||||
- "build in RSCALE support"
|
||||
-)
|
||||
-if(ICU_FOUND)
|
||||
- set(REQUIRES_PRIVATE_ICU "Requires.private: icu-i18n") #for libical.pc
|
||||
- set(HAVE_LIBICU 1)
|
||||
- if(ICU_MAJOR_VERSION VERSION_GREATER 50)
|
||||
- set(HAVE_ICU_DANGI TRUE)
|
||||
- else()
|
||||
- set(HAVE_ICU_DANGI FALSE)
|
||||
- endif()
|
||||
-endif()
|
||||
-if(ICU_I18N_FOUND)
|
||||
- set(HAVE_LIBICU_I18N 1)
|
||||
-endif()
|
||||
-
|
||||
-# compile in Berkeley DB support
|
||||
-find_package(BDB)
|
||||
-set_package_properties(BDB PROPERTIES
|
||||
- TYPE OPTIONAL
|
||||
- PURPOSE "For Berkeley DB storage support"
|
||||
-)
|
||||
-add_feature_info(
|
||||
- "Berkeley DB storage support"
|
||||
- BDB_FOUND
|
||||
- "build in support for Berkeley DB storage"
|
||||
-)
|
||||
-if(BDB_FOUND)
|
||||
- set(HAVE_BDB True)
|
||||
-endif()
|
||||
-
|
||||
# MSVC specific definitions
|
||||
if(WIN32)
|
||||
if(MSVC)
|
@ -1,9 +1,9 @@
|
||||
TERMUX_PKG_HOMEPAGE=http://libical.github.io/libical/
|
||||
TERMUX_PKG_DESCRIPTION="Libical is an Open Source implementation of the iCalendar protocols and protocol data units"
|
||||
TERMUX_PKG_LICENSE="LGPL-2.0"
|
||||
TERMUX_PKG_VERSION=3.0.6
|
||||
TERMUX_PKG_VERSION=3.0.7
|
||||
TERMUX_PKG_SRCURL=https://github.com/libical/libical/releases/download/v$TERMUX_PKG_VERSION/libical-$TERMUX_PKG_VERSION.tar.gz
|
||||
TERMUX_PKG_SHA256=5c8a21c2b732ece4a33e5c862970b4f35a8548bbcda50de5695f6fc211ac4d97
|
||||
TERMUX_PKG_SHA256=0abe66df1ea826e57db7f281c704ede834c84139012e6c686ea7adafd4e763fc
|
||||
TERMUX_PKG_DEPENDS="libc++, libxml2"
|
||||
TERMUX_PKG_BREAKS="libical-dev"
|
||||
TERMUX_PKG_REPLACES="libical-dev"
|
||||
|
Loading…
Reference in New Issue
Block a user