rinetd: fix patches

This commit is contained in:
Lucy Phipps 2021-10-22 17:07:36 +01:00
parent 46992c2993
commit 08c057ac51
No known key found for this signature in database
GPG Key ID: 8F688A3DB7869BFE
2 changed files with 0 additions and 31 deletions

View File

@ -1,19 +0,0 @@
diff -uNr rinetd-0973bd2d1c187da9706fd83c8aa68fabc1775a31/Makefile rinetd-0973bd2d1c187da9706fd83c8aa68fabc1775a31.mod/Makefile
--- rinetd-0973bd2d1c187da9706fd83c8aa68fabc1775a31/Makefile 2019-10-22 14:45:57.000000000 +0300
+++ rinetd-0973bd2d1c187da9706fd83c8aa68fabc1775a31.mod/Makefile 2020-02-29 14:02:04.947085665 +0200
@@ -1,9 +1,10 @@
-CFLAGS=-DLINUX -g
+CC?=gcc
+CFLAGS+=-DLINUX -g
+PREFIX?=/usr/local
rinetd: rinetd.o match.o
- gcc rinetd.o match.o -o rinetd
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) rinetd.o match.o -o rinetd
install: rinetd
- install -m 700 rinetd /usr/sbin
- install -m 644 rinetd.8 /usr/man/man8
-
+ install -Dm 755 rinetd $(PREFIX)/bin/rinetd
+ install -Dm 644 rinetd.8 $(PREFIX)/share/man/man8/rinetd.8

View File

@ -1,12 +0,0 @@
diff -uNr rinetd-0973bd2d1c187da9706fd83c8aa68fabc1775a31/rinetd.c rinetd-0973bd2d1c187da9706fd83c8aa68fabc1775a31.mod/rinetd.c
--- rinetd-0973bd2d1c187da9706fd83c8aa68fabc1775a31/rinetd.c 2019-10-22 14:45:57.000000000 +0300
+++ rinetd-0973bd2d1c187da9706fd83c8aa68fabc1775a31.mod/rinetd.c 2020-02-29 14:05:14.328184024 +0200
@@ -214,7 +214,7 @@
};
RinetdOptions options = {
- "/etc/rinetd.conf"
+ "@TERMUX_PREFIX@/etc/rinetd.conf"
};
int readArgs (int argc,