new package: toxic

This commit is contained in:
Leonid Pliushch 2018-08-15 13:54:29 +03:00 committed by Fredrik Fornwall
parent 450bd48490
commit 08dd05be8b
2 changed files with 31 additions and 0 deletions

22
packages/toxic/build.sh Normal file
View File

@ -0,0 +1,22 @@
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com> @xeffyr"
TERMUX_PKG_HOMEPAGE=https://github.com/JFreegman/toxic
TERMUX_PKG_DESCRIPTION="A command line client for Tox"
TERMUX_PKG_VERSION=0.8.2
TERMUX_PKG_SRCURL=https://github.com/JFreegman/toxic/archive/v${TERMUX_PKG_VERSION}/toxic-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=53bdbed3d72d000f9e43b8823523c589540b811bc237ed6f3b4ddf0fe6f9a6b7
TERMUX_PKG_DEPENDS="c-toxcore, libconfig, libcurl, libqrencode, ncurses"
TERMUX_PKG_BUILD_IN_SRC=true
termux_step_make() {
make \
PREFIX="${TERMUX_PREFIX}" \
CC="${CC}" \
PKG_CONFIG="${PKG_CONFIG}" \
USER_CFLAGS="${CFLAGS}" \
USER_LDFLAGS="${LDFLAGS}"
}
termux_step_make_install() {
make PREFIX="${TERMUX_PREFIX}" install
}

View File

@ -0,0 +1,9 @@
diff -uNr toxic-0.8.2/cfg/systems/Linux.mk toxic-0.8.2.mod/cfg/systems/Linux.mk
--- toxic-0.8.2/cfg/systems/Linux.mk 2018-02-28 01:46:56.000000000 +0200
+++ toxic-0.8.2.mod/cfg/systems/Linux.mk 2018-08-15 13:43:59.718436398 +0300
@@ -1,4 +1,4 @@
# Specials options for linux systems
CFLAGS +=
-LDFLAGS += -ldl -lrt -lcurl
+LDFLAGS += -ldl -lcurl
MANDIR = $(PREFIX)/share/man