poppler: revert commit efabca9
Possible thanks to new texlive-bin patches from upstream. Valgrind no longer gives errors and pdflatex is about twice as fast when including (some?) pdf images.
This commit is contained in:
parent
ac1f056de0
commit
0a2568a871
@ -1,19 +0,0 @@
|
||||
--- ./CMakeLists.txt 2017-11-12 18:14:32.000000000 +0000
|
||||
+++ ../CMakeLists.txt 2017-11-18 19:48:53.494691943 +0000
|
||||
@@ -60,6 +60,7 @@
|
||||
option(USE_FIXEDPOINT "Use fixed point arithmetic in the Splash backend" OFF)
|
||||
option(USE_FLOAT "Use single precision arithmetic in the Splash backend" OFF)
|
||||
option(BUILD_SHARED_LIBS "Build poppler as a shared library" ON)
|
||||
+option(ENABLE_MULTITHREAD "Build with multithread support" ON)
|
||||
if(WIN32)
|
||||
option(ENABLE_RELOCATABLE "Do not hardcode the poppler library location (on Windows)." ON)
|
||||
else()
|
||||
@@ -105,7 +106,7 @@
|
||||
message(FATAL_ERROR "Invalid font configuration setting: ${FONT_CONFIGURATION}")
|
||||
endif()
|
||||
|
||||
-if(CMAKE_USE_PTHREADS_INIT OR WIN32)
|
||||
+if((CMAKE_USE_PTHREADS_INIT OR WIN32) AND ENABLE_MULTITHREAD)
|
||||
set(MULTITHREADED ON)
|
||||
endif()
|
||||
|
@ -1,6 +1,7 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://poppler.freedesktop.org/
|
||||
TERMUX_PKG_DESCRIPTION="PDF rendering library"
|
||||
TERMUX_PKG_VERSION=0.62.0
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_SHA256=5b9a73dfd4d6f61d165ada1e4f0abd2d420494bf9d0b1c15d0db3f7b83a729c6
|
||||
TERMUX_PKG_SRCURL=https://poppler.freedesktop.org/poppler-${TERMUX_PKG_VERSION}.tar.xz
|
||||
# libcairo and littlecms is used by pdftocairo:
|
||||
@ -9,5 +10,4 @@ TERMUX_PKG_DEPENDS="fontconfig, libcairo, libpng, libjpeg-turbo, libtiff, little
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||
-DENABLE_GLIB=OFF
|
||||
-DENABLE_XPDF_HEADERS=ON
|
||||
-DENABLE_MULTITHREAD=OFF
|
||||
"
|
||||
|
Loading…
Reference in New Issue
Block a user