disabled-packages: remove openvpn

Package is already in root-repo.
This commit is contained in:
Leonid Pliushch 2020-05-13 12:03:43 +03:00
parent 1e5f56c7cf
commit 0af10d0f13
6 changed files with 0 additions and 176 deletions

View File

@ -1,36 +0,0 @@
TERMUX_PKG_HOMEPAGE=https://openvpn.net
TERMUX_PKG_DESCRIPTION="An easy-to-use, robust, and highly configurable VPN (Virtual Private Network)"
TERMUX_PKG_VERSION=2.4.2
TERMUX_PKG_DEPENDS="openssl, liblzo, net-tools"
TERMUX_PKG_SRCURL=https://swupdate.openvpn.net/community/releases/openvpn-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=df5c4f384b7df6b08a2f6fa8a84b9fd382baf59c2cef1836f82e2a7f62f1bff9
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
--disable-plugin-auth-pam
--disable-systemd
--disable-debug
--enable-iproute2
--enable-small
--enable-x509-alt-username
ac_cv_func_getpwnam=yes
ac_cv_func_getpass=yes
IFCONFIG=$TERMUX_PREFIX/bin/ifconfig
ROUTE=$TERMUX_PREFIX/bin/route
IPROUTE=$TERMUX_PREFIX/bin/ip
NETSTAT=$TERMUX_PREFIX/bin/netstat"
TERMUX_PKG_MAINTAINER="Vishal Biswas @vishalbiswas"
termux_step_pre_configure() {
# need to provide getpass, else you "can't get console input"
cp "$TERMUX_PKG_BUILDER_DIR/netbsd_getpass.c" "$TERMUX_PKG_SRCDIR/src/openvpn/"
# CFLAGS="$CFLAGS -DTARGET_ANDROID"
LDFLAGS="$LDFLAGS -llog "
}
termux_step_post_make_install() {
# helper script
install -m700 "$TERMUX_PKG_BUILDER_DIR/termux-openvpn" "$TERMUX_PREFIX/bin/"
# Install examples
install -d -m755 "$TERMUX_PREFIX/share/openvpn/examples"
cp "$TERMUX_PKG_SRCDIR"/sample/sample-config-files/* "$TERMUX_PREFIX/share/openvpn/examples"
}

View File

@ -1,13 +0,0 @@
--- ./configure.ac 2016-12-26 11:51:00.000000000 +0000
+++ ../configure.ac 2016-12-28 04:59:50.936948102 +0000
@@ -311,6 +311,10 @@
AC_DEFINE_UNQUOTED([TARGET_ALIAS], ["${host}"], [A string representing our host])
case "$host" in
+ *-*-android*)
+ AC_DEFINE([TARGET_ANDROID], [1], [Are we running on Android?])
+ AC_DEFINE_UNQUOTED([TARGET_PREFIX], ["G"], [Target prefix])
+ ;;
*-*-linux*)
AC_DEFINE([TARGET_LINUX], [1], [Are we running on Linux?])
AC_DEFINE_UNQUOTED([TARGET_PREFIX], ["L"], [Target prefix])

View File

@ -1,104 +0,0 @@
/* $NetBSD: getpass.c,v 1.15 2003/08/07 16:42:50 agc Exp $ */
/*
* Copyright (c) 1988, 1993
* The Regents of the University of California. All rights reserved.
*
* Redistribution and use in source and binary forms, with or without
* modification, are permitted provided that the following conditions
* are met:
* 1. Redistributions of source code must retain the above copyright
* notice, this list of conditions and the following disclaimer.
* 2. Redistributions in binary form must reproduce the above copyright
* notice, this list of conditions and the following disclaimer in the
* documentation and/or other materials provided with the distribution.
* 3. Neither the name of the University nor the names of its contributors
* may be used to endorse or promote products derived from this software
* without specific prior written permission.
*
* THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
* ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
* IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
* ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
* FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
* DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
* OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
* HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
* OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
* SUCH DAMAGE.
*/
#if 0
#include <sys/cdefs.h>
#if defined(LIBC_SCCS) && !defined(lint)
#if 0
static char sccsid[] = "@(#)getpass.c 8.1 (Berkeley) 6/4/93";
#else
__RCSID("$NetBSD: getpass.c,v 1.15 2003/08/07 16:42:50 agc Exp $");
#endif
#endif /* LIBC_SCCS and not lint */
#include "namespace.h"
#endif
#include <assert.h>
#include <paths.h>
#include <pwd.h>
#include <signal.h>
#include <stdio.h>
#include <termios.h>
#include <unistd.h>
#if 0
#ifdef __weak_alias
__weak_alias(getpass,_getpass)
#endif
#endif
char *
getpass(prompt)
const char *prompt;
{
struct termios term;
int ch;
char *p;
FILE *fp, *outfp;
int echo;
static char buf[_PASSWORD_LEN + 1];
sigset_t oset, nset;
#if 0
_DIAGASSERT(prompt != NULL);
#endif
/*
* read and write to /dev/tty if possible; else read from
* stdin and write to stderr.
*/
if ((outfp = fp = fopen(_PATH_TTY, "w+")) == NULL) {
outfp = stderr;
fp = stdin;
}
/*
* note - blocking signals isn't necessarily the
* right thing, but we leave it for now.
*/
sigemptyset(&nset);
sigaddset(&nset, SIGINT);
sigaddset(&nset, SIGTSTP);
(void)sigprocmask(SIG_BLOCK, &nset, &oset);
(void)tcgetattr(fileno(fp), &term);
if ((echo = (term.c_lflag & ECHO)) != 0) {
term.c_lflag &= ~ECHO;
(void)tcsetattr(fileno(fp), TCSAFLUSH /*|TCSASOFT*/, &term);
}
if (prompt != NULL)
(void)fputs(prompt, outfp);
rewind(outfp); /* implied flush */
for (p = buf; (ch = getc(fp)) != EOF && ch != '\n';)
if (p < buf + _PASSWORD_LEN)
*p++ = ch;
*p = '\0';
(void)write(fileno(outfp), "\n", 1);
if (echo) {
term.c_lflag |= ECHO;
(void)tcsetattr(fileno(fp), TCSAFLUSH/*|TCSASOFT*/, &term);
}
(void)sigprocmask(SIG_SETMASK, &oset, NULL);
if (fp != stdin)
(void)fclose(fp);
return(buf);
}

View File

@ -1,10 +0,0 @@
--- ./src/openvpn/console_builtin.c 2016-12-26 11:51:00.000000000 +0000
+++ ../console_builtin.c 2016-12-28 04:05:41.310830107 +0000
@@ -140,6 +140,7 @@
#ifdef HAVE_GETPASS
+#include "netbsd_getpass.c"
/**
* Open the current console TTY for read/write operations

View File

@ -1,11 +0,0 @@
--- ./src/openvpn/tun.c 2016-12-26 11:51:00.000000000 +0000
+++ ../tun.c 2016-12-28 04:11:52.786734486 +0000
@@ -1939,7 +1939,7 @@
const char *node = dev_node;
if (!node)
{
- node = "/dev/net/tun";
+ node = "/dev/tun";
}
/*

View File

@ -1,2 +0,0 @@
#!/data/data/com.termux/files/usr/bin/sh
su -c "export LD_LIBRARY_PATH=$PREFIX/lib; export TMPDIR=$PREFIX/tmp; $PREFIX/bin/openvpn $@"