imgflo with lib soup. Needs gegl installed (#1026)

This commit is contained in:
its-pointless 2017-08-11 22:46:45 +10:00 committed by Fredrik Fornwall
parent b32c60ff20
commit 0cfa7c331a
5 changed files with 150 additions and 0 deletions

8
packages/imgflo/build.sh Normal file
View File

@ -0,0 +1,8 @@
TERMUX_PKG_HOMEPAGE="http://www.imgflo.org/"
TERMUX_PKG_DESCRIPTION="HTTP image processing server & Flowhub.io compatible runtime"
TERMUX_PKG_VERSION=0.4.2
TERMUX_PKG_SRCURL=https://github.com/imgflo/imgflo/archive/0.4.2.tar.gz
TERMUX_PKG_FOLDERNAME=imgflo-$TERMUX_PKG_VERSION
TERMUX_PKG_SHA256=4dd5fc9d34f3cfc294fd69a14d50ed5401abeb829132f1b1ac316e28223fc393
TERMUX_PKG_DEPENDS="gegl, libsoup"
TERMUX_PKG_BUILD_IN_SRC=yes

View File

@ -0,0 +1,20 @@
--- ../cache/imgflo-0.4.2/env.sh.in 2016-08-21 08:46:27.000000000 +0000
+++ ./env.sh.in 2017-05-11 02:54:53.849611941 +0000
@@ -1,17 +1,3 @@
#!/bin/bash
-
-PREFIX="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"
-
-export PKG_CONFIG_PATH=${PREFIX}/lib/pkgconfig:$PKG_CONFIG_PATH
-export LD_LIBRARY_PATH=${PREFIX}/lib:$LD_LIBRARY_PATH
-export DYLD_LIBRARY_PATH=${PREFIX}/lib:$DYLD_LIBRARY_PATH
-export ACLOCAL_PATH=${PREFIX}/share/aclocal:$ACLOCAL_PATH
-export PATH=${PREFIX}/bin:$PATH
-export GEGL_PATH=${PREFIX}/lib/imgflo/operations:${PREFIX}/lib/gegl-0.3:${GEGL_PATH}
-export BABL_PATH=${PREFIX}/lib/babl-0.1
-
# If not sourcing the script, execute the command that follows
-if [[ "${BASH_SOURCE[0]}" = "${0}" ]];
-then
exec "$@"
-fi

View File

@ -0,0 +1,27 @@
--- ../cache/imgflo-0.4.2/lib/library.c 2016-08-21 08:46:27.000000000 +0000
+++ ./lib/library.c 2017-05-11 02:57:06.259072817 +0000
@@ -342,12 +342,12 @@
GFile* dir = g_file_get_parent(file);
gchar* dir_name = g_file_get_path(dir);
- gchar *stdout = NULL;
- gchar *stderr = NULL;
+ //gchar *stdout = NULL;
+ //gchar *stderr = NULL;
gint exitcode = 1;
GError *err = NULL;
gchar **argv = g_new0(gchar *, 10);
- argv[0] = g_strdup("/usr/bin/env");
+ argv[0] = g_strdup("/data/data/com.termux/files/usr/bin/env");
argv[1] = g_strdup("make");
argv[2] = g_strdup("component");
argv[3] = g_strdup_printf("COMPONENT=%s", component);
@@ -358,7 +358,7 @@
const gboolean success = g_spawn_sync(NULL, argv, NULL,
G_SPAWN_DEFAULT, NULL, NULL,
- &stdout, &stderr, &exitcode, &err);
+ NULL, NULL, &exitcode, &err);
try_print_error(err);
if (!success || stderr) {
imgflo_message("%s", stderr);

View File

@ -0,0 +1,88 @@
--- ../cache/imgflo-0.4.2/Makefile 2016-08-21 08:46:27.000000000 +0000
+++ ./Makefile 2017-05-07 11:34:05.803206274 +0000
@@ -1,7 +1,5 @@
VERSION=$(shell echo `git describe --tags`)
-#PREFIX=/opt/imgflo
-PREFIX=$(shell echo `pwd`/install)
FLAGS=-Wall -Werror -std=c99 -g
DEBUGPROG=
PORT=3569
@@ -23,8 +21,8 @@
LIBS=gegl-0.3 libsoup-2.4
SYSTEM_LIBS=gio-unix-2.0 json-glib-1.0 libpng
-DEPS=$(shell $(PREFIX)/env.sh pkg-config $(PKGCONFIG_ARGS) --libs --cflags $(LIBS))
-DEPS+=$(shell $(PREFIX)/env.sh pkg-config --libs --cflags $(SYSTEM_LIBS))
+DEPS=$(shell pkg-config $(PKGCONFIG_ARGS) --libs --cflags $(LIBS))
+DEPS+=$(shell pkg-config --libs --cflags $(SYSTEM_LIBS))
TRAVIS_DEPENDENCIES=$(shell echo `cat .vendor_urls | sed -e "s/heroku/travis-${TRAVIS_OS_NAME}/" | tr -d '\n'`)
RUN_ARGUMENTS:=--port $(PORT) --external-port=$(EXTPORT)
@@ -53,31 +51,31 @@
all: install
run-noinstall:
- $(PREFIX)/env.sh $(DEBUGPROG) ./bin/imgflo-runtime $(RUN_ARGUMENTS)
+ $(DEBUGPROG) ./bin/imgflo-runtime $(RUN_ARGUMENTS)
run: install run-noinstall
process: install
- $(PREFIX)/env.sh $(DEBUGPROG) ./bin/imgflo $(PROCESS_ARGUMENTS)
+ $(DEBUGPROG) ./bin/imgflo $(PROCESS_ARGUMENTS)
-install: env imgflo imgflo-runtime imgflo-graphinfo
+install: imgflo imgflo-runtime imgflo-graphinfo
cp ./bin/imgflo $(PREFIX)/bin/
cp ./bin/imgflo-runtime $(PREFIX)/bin/
cp ./bin/imgflo-graphinfo $(PREFIX)/bin/
imgflo:
- $(PREFIX)/env.sh $(CC) -o ./bin/imgflo bin/imgflo.c -I. $(FLAGS) $(DEPS)
+ $(CC) -o ./bin/imgflo bin/imgflo.c -I. $(FLAGS) $(DEPS)
imgflo-graphinfo:
- $(PREFIX)/env.sh $(CC) -o ./bin/imgflo-graphinfo bin/imgflo-graphinfo.c -I. $(FLAGS) $(DEPS)
+ $(CC) -o ./bin/imgflo-graphinfo bin/imgflo-graphinfo.c -I. $(FLAGS) $(DEPS)
imgflo-runtime:
- $(PREFIX)/env.sh $(CC) -o ./bin/imgflo-runtime bin/imgflo-runtime.c -I. $(FLAGS) $(DEPS)
+ $(CC) -o ./bin/imgflo-runtime bin/imgflo-runtime.c -I. $(FLAGS) $(DEPS)
env:
- mkdir -p $(PREFIX) || true
- sed -e 's|@PREFIX@|$(PREFIX)|' env.sh.in > $(PREFIX)/env.sh
- chmod +x $(PREFIX)/env.sh
+# mkdir -p $(PREFIX) || true
+# sed -e 's|@PREFIX@|$(PREFIX)|' env.sh.in > $(PREFIX)/env.sh
+# chmod +x $(PREFIX)/env.sh
travis-deps:
wget -O imgflo-dependencies.tgz $(TRAVIS_DEPENDENCIES)
@@ -93,14 +91,14 @@
COMPONENT_FLAGS += -DIMGFLO_OP_NAME\(orig\)=\"$(COMPONENT_NAME_PREFIX)\"orig\"$(COMPONENT_NAME_SUFFIX)\"
endif
-component-install-dir: env
+component-install-dir:
rm -rf $(COMPONENTINSTALLDIR)
mkdir -p $(COMPONENTINSTALLDIR) || true
components: component-install-dir $(COMPONENT_PLUGINS)
component: component-install-dir $(COMPONENT_OUT)
$(COMPONENTINSTALLDIR)/%.$(SHAREDLIB_SUFFIX): $(COMPONENTDIR)/%.c
- $(PREFIX)/env.sh $(CC) -o $@ $< -DGEGL_OP_C_FILE=\"`basename $<`\" $(COMPONENT_FLAGS) $(DEPS)
+ $(CC) -o $@ $< -DGEGL_OP_C_FILE=\"`basename $<`\" $(COMPONENT_FLAGS) $(DEPS)
dependencies:
cd dependencies && make PREFIX=$(PREFIX) dependencies
@@ -115,7 +113,7 @@
cd dependencies && make PREFIX=$(PREFIX) glib
check: install
- $(PREFIX)/env.sh ./node_modules/.bin/mocha --reporter spec --compilers .coffee:coffee-script/register ./spec/*.coffee $(TEST_ARGUMENTS)
+ ./node_modules/.bin/mocha --reporter spec --compilers .coffee:coffee-script/register ./spec/*.coffee $(TEST_ARGUMENTS)
clean:
git clean -dfx --exclude node_modules --exclude install

View File

@ -0,0 +1,7 @@
TERMUX_PKG_HOMEPAGE="https://wiki.gnome.org/action/show/Projects/libsoup"
TERMUX_PKG_DESCRIPTION="libsoup is an HTTP client/server library for GNOME"
TERMUX_PKG_VERSION=2.58.0
TERMUX_PKG_SRCURL=http://ftp.gnome.org/pub/GNOME/sources/libsoup/2.58/libsoup-2.58.0.tar.xz
TERMUX_PKG_SHA256=b61567e25ed61f4b89bb23a36713c807df6b76a8451beb786d8cc362e8f097f5
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--disable-vala"
TERMUX_PKG_DEPENDS="glib, krb5, libffi, libsqlite"