dnsmasq: add package

This commit is contained in:
Henrik Grimler 2018-05-08 15:24:07 +02:00 committed by Yaksh Bariya
parent bdd300d9da
commit 0d487224aa
No known key found for this signature in database
GPG Key ID: F7486BA7D3D27581
3 changed files with 38 additions and 0 deletions

View File

@ -0,0 +1,21 @@
--- ../Makefile.orig 2018-05-08 13:11:40.707974108 +0000
+++ ./Makefile 2018-05-08 13:17:01.037389651 +0000
@@ -18,14 +18,14 @@
# Variables you may well want to override.
-PREFIX = /usr/local
-BINDIR = $(PREFIX)/sbin
+PREFIX ?= /usr/local
+BINDIR = $(PREFIX)/bin
MANDIR = $(PREFIX)/share/man
LOCALEDIR = $(PREFIX)/share/locale
BUILDDIR = $(SRC)
DESTDIR =
-CFLAGS = -Wall -W -O2
-LDFLAGS =
+CFLAGS ?= -Wall -W -O2
+LDFLAGS = -llog
COPTS =
RPM_OPT_FLAGS =
LIBS =

View File

@ -0,0 +1,6 @@
TERMUX_PKG_HOMEPAGE=http://www.thekelleys.org.uk/dnsmasq/doc.html
TERMUX_PKG_DESCRIPTION="Dnsmasq provides network infrastructure for small networks: DNS, DHCP, router advertisement and network boot"
TERMUX_PKG_VERSION=2.79
TERMUX_PKG_SHA256=78ad74f5ca14fd85a8bac93f764cd9d60b27579e90eabd3687ca7b030e67861f
TERMUX_PKG_SRCURL=http://www.thekelleys.org.uk/dnsmasq/dnsmasq-$TERMUX_PKG_VERSION.tar.xz
TERMUX_PKG_BUILD_IN_SRC=YES

View File

@ -0,0 +1,11 @@
--- ../dnsmasq.h.orig 2018-05-08 13:06:37.979102506 +0000
+++ ./src/dnsmasq.h 2018-05-08 13:07:40.820943857 +0000
@@ -111,7 +111,7 @@
#include <pwd.h>
#include <grp.h>
#include <stdarg.h>
-#if defined(__OpenBSD__) || defined(__NetBSD__) || defined(__sun__) || defined (__sun) || defined (__ANDROID__)
+#if defined(__OpenBSD__) || defined(__NetBSD__) || defined(__sun__) || defined (__sun)
# include <netinet/if_ether.h>
#else
# include <net/ethernet.h>