frida-python: patch selinux policy in PyDeviceManager_init
This commit is contained in:
parent
106c4e67ac
commit
0db663ac0d
12
root-packages/frida-server/frida-python-src-_frida.c.patch
Normal file
12
root-packages/frida-server/frida-python-src-_frida.c.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- ../frida-python-src-_frida.c.orig 2020-03-25 09:09:39.556304220 +0100
|
||||
+++ ./frida-python/src/_frida.c 2020-03-25 09:27:46.744314351 +0100
|
||||
@@ -1879,6 +1879,9 @@
|
||||
static int
|
||||
PyDeviceManager_init (PyDeviceManager * self, PyObject * args, PyObject * kw)
|
||||
{
|
||||
+ printf ("patching selinux policy\n");
|
||||
+ frida_selinux_apply_policy_patch ();
|
||||
+
|
||||
if (PyGObjectType.tp_init ((PyObject *) self, args, kw) < 0)
|
||||
return -1;
|
||||
|
@ -1,17 +1,19 @@
|
||||
--- ../frida-python-src-meson.build.orig 2020-02-23 12:56:01.181265200 +0100
|
||||
+++ ./frida-python/src/meson.build 2020-02-23 16:08:00.390756673 +0100
|
||||
--- ../frida-python-src-meson.build.orig 2020-03-25 07:54:47.948054199 +0100
|
||||
+++ ./frida-python/src/meson.build 2020-03-25 08:44:34.189059770 +0100
|
||||
@@ -1,4 +1,4 @@
|
||||
-extra_link_args = []
|
||||
+extra_link_args = ['-L@TERMUX_PREFIX@/lib', '-lpython3.8']
|
||||
if host_os_family == 'darwin'
|
||||
extra_link_args += ['-Wl,-exported_symbol,_' + python_plugin_export_name]
|
||||
elif host_os_family != 'windows'
|
||||
@@ -9,7 +9,7 @@
|
||||
@@ -9,8 +9,8 @@
|
||||
name_prefix: '',
|
||||
name_suffix: 'so',
|
||||
c_args: frida_component_cflags,
|
||||
- include_directories: include_directories(python_incdir),
|
||||
- link_args: extra_link_args,
|
||||
+ include_directories: include_directories('@TERMUX_PREFIX@/include', python_incdir),
|
||||
link_args: extra_link_args,
|
||||
+ link_args: extra_link_args + ['../frida-core/lib/selinux/libfrida-selinux.a'],
|
||||
dependencies: [frida_core_dep],
|
||||
install: true,
|
||||
install_dir: python_site_packages,
|
||||
|
Loading…
Reference in New Issue
Block a user