tigervnc: use TCSANOW in vncpasswd

Now password won't be echoed when using tool 'vncpasswd'.
This commit is contained in:
Leonid Pliushch 2018-09-12 11:16:53 +03:00 committed by Yaksh Bariya
parent 08ed27315c
commit 0e280f4735
No known key found for this signature in database
GPG Key ID: F7486BA7D3D27581
10 changed files with 59 additions and 47 deletions

View File

@ -1,11 +0,0 @@
diff -uNr tigervnc-1.8.0/CMakeLists.txt tigervnc-1.8.0.mod/CMakeLists.txt
--- tigervnc-1.8.0/CMakeLists.txt 2017-05-16 16:53:28.000000000 +0300
+++ tigervnc-1.8.0.mod/CMakeLists.txt 2018-06-15 23:44:13.088607661 +0300
@@ -300,7 +300,6 @@
add_subdirectory(media)
endif()
-add_subdirectory(tests)
include(cmake/BuildPackages.cmake)

View File

@ -1,12 +0,0 @@
diff -uNr tigervnc-1.8.0/common/os/CMakeLists.txt tigervnc-1.8.0.mod/common/os/CMakeLists.txt
--- tigervnc-1.8.0/common/os/CMakeLists.txt 2017-05-16 16:53:28.000000000 +0300
+++ tigervnc-1.8.0.mod/common/os/CMakeLists.txt 2018-06-15 23:44:13.091940995 +0300
@@ -6,7 +6,7 @@
w32tiger.c
os.cxx)
-if(UNIX)
+if(UNIX AND NOT ${CMAKE_SYSTEM_NAME} MATCHES "Android")
target_link_libraries(os pthread)
endif()

View File

@ -1,14 +0,0 @@
diff -uNr tigervnc-1.8.0/unix/tx/TXDialog.h tigervnc-1.8.0.mod/unix/tx/TXDialog.h
--- tigervnc-1.8.0/unix/tx/TXDialog.h 2017-05-16 16:53:28.000000000 +0300
+++ tigervnc-1.8.0.mod/unix/tx/TXDialog.h 2018-06-15 23:44:13.101940995 +0300
@@ -36,6 +36,10 @@
#include <sys/proto.h>
#endif
+#ifdef __ANDROID__
+#include <sys/select.h>
+#endif
+
class TXDialog : public TXWindow, public TXDeleteWindowCallback {
public:
TXDialog(Display* dpy, int width, int height, const char* name,

View File

@ -0,0 +1,11 @@
diff -uNr tigervnc-1.9.0/CMakeLists.txt tigervnc-1.9.0.mod/CMakeLists.txt
--- tigervnc-1.9.0/CMakeLists.txt 2018-07-16 17:08:55.000000000 +0300
+++ tigervnc-1.9.0.mod/CMakeLists.txt 2018-09-12 11:14:21.772989769 +0300
@@ -303,7 +303,6 @@
add_subdirectory(media)
endif()
-add_subdirectory(tests)
include(cmake/BuildPackages.cmake)

View File

@ -0,0 +1,12 @@
diff -uNr tigervnc-1.9.0/common/os/CMakeLists.txt tigervnc-1.9.0.mod/common/os/CMakeLists.txt
--- tigervnc-1.9.0/common/os/CMakeLists.txt 2018-07-16 17:08:55.000000000 +0300
+++ tigervnc-1.9.0.mod/common/os/CMakeLists.txt 2018-09-12 11:14:21.776323226 +0300
@@ -6,7 +6,7 @@
w32tiger.c
os.cxx)
-if(UNIX)
+if(UNIX AND NOT ${CMAKE_SYSTEM_NAME} MATCHES "Android")
target_link_libraries(os pthread)
endif()

View File

@ -1,6 +1,6 @@
diff -uNr tigervnc-1.8.0/common/os/Thread.cxx tigervnc-1.8.0.mod/common/os/Thread.cxx
--- tigervnc-1.8.0/common/os/Thread.cxx 2017-05-16 16:53:28.000000000 +0300
+++ tigervnc-1.8.0.mod/common/os/Thread.cxx 2018-06-15 23:44:13.091940995 +0300
diff -uNr tigervnc-1.9.0/common/os/Thread.cxx tigervnc-1.9.0.mod/common/os/Thread.cxx
--- tigervnc-1.9.0/common/os/Thread.cxx 2018-07-16 17:08:55.000000000 +0300
+++ tigervnc-1.9.0.mod/common/os/Thread.cxx 2018-09-12 11:14:21.776323226 +0300
@@ -48,7 +48,7 @@
delete (HANDLE*)threadId;
#else

View File

@ -0,0 +1,14 @@
diff -uNr tigervnc-1.9.0/unix/tx/TXDialog.h tigervnc-1.9.0.mod/unix/tx/TXDialog.h
--- tigervnc-1.9.0/unix/tx/TXDialog.h 2018-07-16 17:08:55.000000000 +0300
+++ tigervnc-1.9.0.mod/unix/tx/TXDialog.h 2018-09-12 11:14:21.779656681 +0300
@@ -31,6 +31,10 @@
#include "TXWindow.h"
#include <errno.h>
+#ifdef __ANDROID__
+#include <sys/select.h>
+#endif
+
class TXDialog : public TXWindow, public TXDeleteWindowCallback {
public:
TXDialog(Display* dpy, int width, int height, const char* name,

View File

@ -0,0 +1,12 @@
diff -uNr tigervnc-1.9.0/unix/vncpasswd/vncpasswd.cxx tigervnc-1.9.0.mod/unix/vncpasswd/vncpasswd.cxx
--- tigervnc-1.9.0/unix/vncpasswd/vncpasswd.cxx 2018-07-16 17:08:55.000000000 +0300
+++ tigervnc-1.9.0.mod/unix/vncpasswd/vncpasswd.cxx 2018-09-12 11:15:13.158490703 +0300
@@ -50,7 +50,7 @@
else
attrs.c_lflag &= ~ECHO;
attrs.c_lflag |= ECHONL;
- tcsetattr(fileno(stdin), TCSAFLUSH, &attrs);
+ tcsetattr(fileno(stdin), TCSANOW, &attrs);
}
static char* getpassword(const char* prompt) {

View File

@ -1,6 +1,6 @@
diff -uNr tigervnc-1.8.0/unix/vncserver tigervnc-1.8.0.mod/unix/vncserver
--- tigervnc-1.8.0/unix/vncserver 2017-05-16 16:53:28.000000000 +0300
+++ tigervnc-1.8.0.mod/unix/vncserver 2018-06-15 23:44:13.098607661 +0300
diff -uNr tigervnc-1.9.0/unix/vncserver tigervnc-1.9.0.mod/unix/vncserver
--- tigervnc-1.9.0/unix/vncserver 2018-07-16 17:08:55.000000000 +0300
+++ tigervnc-1.9.0.mod/unix/vncserver 2018-09-12 11:14:21.786323593 +0300
@@ -51,7 +51,7 @@
$vncUserDir = "$ENV{HOME}/.vnc";
$vncUserConfig = "$vncUserDir/config";

View File

@ -1,7 +1,7 @@
diff -uNr tigervnc-1.8.0/unix/xserver/hw/vnc/xvnc.c tigervnc-1.8.0.mod/unix/xserver/hw/vnc/xvnc.c
--- tigervnc-1.8.0/unix/xserver/hw/vnc/xvnc.c 2017-05-16 16:53:28.000000000 +0300
+++ tigervnc-1.8.0.mod/unix/xserver/hw/vnc/xvnc.c 2018-06-15 23:44:13.095274328 +0300
@@ -335,13 +335,13 @@
diff -uNr tigervnc-1.9.0/unix/xserver/hw/vnc/xvnc.c tigervnc-1.9.0.mod/unix/xserver/hw/vnc/xvnc.c
--- tigervnc-1.9.0/unix/xserver/hw/vnc/xvnc.c 2018-07-16 17:08:55.000000000 +0300
+++ tigervnc-1.9.0.mod/unix/xserver/hw/vnc/xvnc.c 2018-09-12 11:14:21.789657049 +0300
@@ -339,13 +339,13 @@
char file[256];
if (vncIsTCPPortUsed(6000+num))
return FALSE;