new package: abiword
This commit is contained in:
parent
1299e5ab73
commit
147c06946b
54
x11-packages/abiword/abiword-3.0.4-enchant-2.patch
Normal file
54
x11-packages/abiword/abiword-3.0.4-enchant-2.patch
Normal file
@ -0,0 +1,54 @@
|
||||
From ae05e92df5a5d6151641622c83d35a6fdba47b1f Mon Sep 17 00:00:00 2001
|
||||
From: Hubert Figuiere <hub@figuiere.net>
|
||||
Date: Fri, 22 Nov 2019 20:02:52 -0500
|
||||
Subject: [PATCH] Require enchant 2 now
|
||||
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
src/af/xap/xp/enchant_checker.cpp | 6 +++---
|
||||
2 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index f2e392f04..3e1697ced 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -94,7 +94,7 @@
|
||||
"
|
||||
|
||||
# optional deps
|
||||
-enchant_req='enchant >= 1.2.0'
|
||||
+enchant_req='enchant-2'
|
||||
gio_req='gio-2.0'
|
||||
goffice_req='libgoffice-0.10 >= 0.10.0'
|
||||
|
||||
--- a/src/af/xap/xp/enchant_checker.cpp
|
||||
+++ b/src/af/xap/xp/enchant_checker.cpp
|
||||
@@ -127,7 +127,7 @@
|
||||
pvSugg->addItem (ucszSugg);
|
||||
}
|
||||
|
||||
- enchant_dict_free_suggestions (m_dict, suggestions);
|
||||
+ enchant_dict_free_string_list(m_dict, suggestions);
|
||||
}
|
||||
|
||||
return pvSugg;
|
||||
@@ -139,7 +139,7 @@
|
||||
|
||||
if (word && len) {
|
||||
UT_UTF8String utf8 (word, len);
|
||||
- enchant_dict_add_to_personal (m_dict, utf8.utf8_str(), utf8.byteLength());
|
||||
+ enchant_dict_add(m_dict, utf8.utf8_str(), utf8.byteLength());
|
||||
return true;
|
||||
}
|
||||
return false;
|
||||
@@ -150,7 +150,7 @@
|
||||
UT_return_val_if_fail (m_dict, false);
|
||||
|
||||
UT_UTF8String ignore (toCorrect, toCorrectLen);
|
||||
- return enchant_dict_is_in_session (m_dict, ignore.utf8_str(), ignore.byteLength()) != 0;
|
||||
+ return enchant_dict_is_added(m_dict, ignore.utf8_str(), ignore.byteLength()) != 0;
|
||||
}
|
||||
|
||||
void EnchantChecker::ignoreWord (const UT_UCSChar *toCorrect, size_t toCorrectLen)
|
||||
--
|
||||
2.24.1
|
38
x11-packages/abiword/build.sh
Normal file
38
x11-packages/abiword/build.sh
Normal file
@ -0,0 +1,38 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://www.abisource.com/
|
||||
TERMUX_PKG_DESCRIPTION="A free word processing program"
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=3.0.5
|
||||
TERMUX_PKG_SRCURL=https://www.abisource.com/downloads/abiword/${TERMUX_PKG_VERSION}/source/abiword-${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=1257247e9970508d6d1456d3e330cd1909c4b42b25e0f0a1bc32526d6f3a21b4
|
||||
TERMUX_PKG_DEPENDS="enchant, fribidi, glib, goffice, gtk3, libc++, libcairo, libgcrypt, libgsf, libical, libjpeg-turbo, libpng, librsvg, libwv, libxml2, libxslt, readline"
|
||||
TERMUX_PKG_BUILD_DEPENDS="boost, boost-headers"
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||
--disable-default-plugins
|
||||
--enable-plugins=applix,babelfish,bmp,clarisworks,command,docbook,eml,epub,freetranslation,garble,gdict,gimp,goffice,google,hancom,hrtext,iscii,kword,latex,loadbindings,mif,mswrite,openwriter,openxml,opml,passepartout,pdb,pdf,presentation,s5,sdw,t602,urldict,wikipedia,wml,xslfo
|
||||
--disable-builtin-plugins
|
||||
--disable-print
|
||||
--enable-spell
|
||||
--enable-statusbar
|
||||
--enable-clipart
|
||||
--enable-templates
|
||||
--disable-collab-backend-telepathy
|
||||
--disable-collab-backend-xmpp
|
||||
--disable-collab-backend-tcp
|
||||
--disable-collab-backend-sugar
|
||||
--disable-collab-backend-service
|
||||
--disable-introspection
|
||||
--without-gtk2
|
||||
--with-goffice
|
||||
--without-redland
|
||||
--without-evolution-data-server
|
||||
--without-champlain
|
||||
--without-inter7eps
|
||||
--without-libtidy
|
||||
"
|
||||
|
||||
termux_step_pre_configure() {
|
||||
autoreconf -fi
|
||||
|
||||
LDFLAGS+=" $($CC -print-libgcc-file-name)"
|
||||
}
|
21
x11-packages/abiword/configure.ac.patch
Normal file
21
x11-packages/abiword/configure.ac.patch
Normal file
@ -0,0 +1,21 @@
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -644,7 +644,6 @@
|
||||
if test "$GCC" = "yes"; then
|
||||
for option in -Wall -Wextra -Wsign-compare -Wpointer-arith \
|
||||
-Wchar-subscripts -Wwrite-strings -Wmissing-noreturn \
|
||||
- -Wformat-overflow=2 \
|
||||
-Wunused -Wpointer-arith -Wshadow; do
|
||||
SAVE_CPPFLAGS="$CPPFLAGS"
|
||||
CPPFLAGS="$CPPFLAGS $option"
|
||||
@@ -1030,8 +1029,8 @@
|
||||
if test "$abi_cv_disable_default_plugins" != "yes"; then
|
||||
PLUGINS="$default_plugins"
|
||||
fi
|
||||
- for i in $abi_cv_plugins; do
|
||||
- if test -d "plugins/$i"; then
|
||||
+ for i in ${abi_cv_plugins//,/ }; do
|
||||
+ if test -d "$srcdir/plugins/$i"; then
|
||||
PLUGINS="$PLUGINS $i"
|
||||
else
|
||||
AC_MSG_WARN([Plugin $i does not exist.])
|
11
x11-packages/abiword/plugins-command-xp-AbiCommand.cpp.patch
Normal file
11
x11-packages/abiword/plugins-command-xp-AbiCommand.cpp.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/plugins/command/xp/AbiCommand.cpp
|
||||
+++ b/plugins/command/xp/AbiCommand.cpp
|
||||
@@ -1188,7 +1188,7 @@
|
||||
{
|
||||
const UT_UTF8String *pCom1 = pToks->getNthItem (1);
|
||||
printf(" Filename %s \n",pCom1->utf8_str());
|
||||
- const char *suffix = rindex (pCom1->utf8_str (), '.');
|
||||
+ const char *suffix = strrchr (pCom1->utf8_str (), '.');
|
||||
|
||||
if (suffix != NULL)
|
||||
{
|
11
x11-packages/abiword/src-wp-ap-gtk-ap_UnixApp.cpp.patch
Normal file
11
x11-packages/abiword/src-wp-ap-gtk-ap_UnixApp.cpp.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/src/wp/ap/gtk/ap_UnixApp.cpp
|
||||
+++ b/src/wp/ap/gtk/ap_UnixApp.cpp
|
||||
@@ -863,7 +863,7 @@
|
||||
if (len < (strlen(G_MODULE_SUFFIX) + 2)) // this is ".so" and at least one char for the filename
|
||||
return false;
|
||||
const char *suffix = file+(len-3);
|
||||
- if(0 == strcmp (suffix, "."G_MODULE_SUFFIX))
|
||||
+ if(0 == strcmp (suffix, "." G_MODULE_SUFFIX))
|
||||
return true;
|
||||
return false;
|
||||
}
|
Loading…
Reference in New Issue
Block a user