man: Update from 1.13.3 to 1.13.4

This commit is contained in:
Fredrik Fornwall 2016-07-16 19:26:07 -04:00
parent 61b72e39c5
commit 163a880862
7 changed files with 86 additions and 32 deletions

View File

@ -1,14 +1,29 @@
Use a symlink instead of hardlink for mandoc -> man link.
diff -u -r ../mdocml-1.13.3/Makefile ./Makefile
--- ../mdocml-1.13.3/Makefile 2015-03-13 08:38:38.000000000 -0400
+++ ./Makefile 2015-07-08 20:48:47.384902670 -0400
@@ -313,7 +313,7 @@
mkdir -p $(DESTDIR)$(MANDIR)/man3
diff -u -r ../mdocml-1.13.4/Makefile ./Makefile
--- ../mdocml-1.13.4/Makefile 2016-07-14 07:13:40.000000000 -0400
+++ ./Makefile 2016-07-16 17:53:29.423956403 -0400
@@ -359,7 +359,7 @@
mkdir -p $(DESTDIR)$(MANDIR)/man7
$(INSTALL_PROGRAM) mandoc demandoc $(DESTDIR)$(BINDIR)
$(INSTALL_PROGRAM) soelim $(DESTDIR)$(BINDIR)/$(BINM_SOELIM)
- ln -f $(DESTDIR)$(BINDIR)/mandoc $(DESTDIR)$(BINDIR)/$(BINM_MAN)
+ ln -s -f $(DESTDIR)$(BINDIR)/mandoc $(DESTDIR)$(BINDIR)/$(BINM_MAN)
$(INSTALL_LIB) libmandoc.a $(DESTDIR)$(LIBDIR)
$(INSTALL_LIB) man.h mandoc.h mandoc_aux.h mdoc.h \
$(INSTALL_LIB) man.h mandoc.h mandoc_aux.h mdoc.h roff.h \
$(DESTDIR)$(INCLUDEDIR)
@@ -383,12 +383,12 @@
mkdir -p $(DESTDIR)$(MANDIR)/man3
mkdir -p $(DESTDIR)$(MANDIR)/man5
mkdir -p $(DESTDIR)$(MANDIR)/man8
- ln -f $(DESTDIR)$(BINDIR)/mandoc $(DESTDIR)$(BINDIR)/$(BINM_APROPOS)
- ln -f $(DESTDIR)$(BINDIR)/mandoc $(DESTDIR)$(BINDIR)/$(BINM_WHATIS)
- ln -f $(DESTDIR)$(BINDIR)/mandoc \
+ ln -s -f $(DESTDIR)$(BINDIR)/mandoc $(DESTDIR)$(BINDIR)/$(BINM_APROPOS)
+ ln -s -f $(DESTDIR)$(BINDIR)/mandoc $(DESTDIR)$(BINDIR)/$(BINM_WHATIS)
+ ln -s -f $(DESTDIR)$(BINDIR)/mandoc \
$(DESTDIR)$(SBINDIR)/$(BINM_MAKEWHATIS)
$(INSTALL_MAN) apropos.1 $(DESTDIR)$(MANDIR)/man1/$(BINM_APROPOS).1
- ln -f $(DESTDIR)$(MANDIR)/man1/$(BINM_APROPOS).1 \
+ ln -s -f $(DESTDIR)$(MANDIR)/man1/$(BINM_APROPOS).1 \
$(DESTDIR)$(MANDIR)/man1/$(BINM_WHATIS).1
$(INSTALL_MAN) mansearch.3 $(DESTDIR)$(MANDIR)/man3
$(INSTALL_MAN) mandoc.db.5 $(DESTDIR)$(MANDIR)/man5

View File

@ -1,6 +1,6 @@
TERMUX_PKG_HOMEPAGE=http://mdocml.bsd.lv/
TERMUX_PKG_DESCRIPTION="Man page viewer from the mandoc toolset"
TERMUX_PKG_VERSION=1.13.3
TERMUX_PKG_VERSION=1.13.4
TERMUX_PKG_SRCURL=http://mdocml.bsd.lv/snapshots/mdocml-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="less,libandroid-glob"
TERMUX_PKG_BUILD_IN_SRC=yes
@ -11,7 +11,8 @@ termux_step_post_extract_package () {
LDFLAGS+=" -landroid-glob"
echo "PREFIX=\"$TERMUX_PREFIX\"" > configure.local
echo "MANDIR=\"$TERMUX_PREFIX/share/man\"" >> configure.local
echo "CFLAGS=\"$CFLAGS -DNULL=0 $CPPFLAGS $LDFLAGS\"" >> configure.local
echo "CFLAGS=\"$CFLAGS -DNULL=0 $CPPFLAGS\"" >> configure.local
echo "LDFLAGS=\"$LDFLAGS\"" >> configure.local
for HAVING in HAVE_FGETLN HAVE_MMAP HAVE_STRLCAT HAVE_STRLCPY; do
echo "$HAVING=1" >> configure.local
done
@ -19,7 +20,7 @@ termux_step_post_extract_package () {
echo "HAVE_SQLITE3=0" >> configure.local
}
termux_step_make_install () {
make -j 1 install
echo "_whatdb $TERMUX_PREFIX/share/man/mandoc.db" > $TERMUX_PREFIX/etc/man.conf
}
#termux_step_make_install () {
#make -j 1 install
#echo "_whatdb $TERMUX_PREFIX/share/man/mandoc.db" > $TERMUX_PREFIX/etc/man.conf
#}

View File

@ -0,0 +1,21 @@
diff -u -r ../mdocml-1.13.4/configure ./configure
--- ../mdocml-1.13.4/configure 2016-07-14 07:13:40.000000000 -0400
+++ ./configure 2016-07-16 17:59:13.906589870 -0400
@@ -31,7 +31,7 @@
# Initialize all variables here,
# such that nothing can leak in from the environment.
-MANPATH_DEFAULT="/usr/share/man:/usr/X11R6/man:/usr/local/man"
+MANPATH_DEFAULT="@TERMUX_PREFIX@/share/man"
OSNAME=
CC=`printf "all:\\n\\t@echo \\\$(CC)\\n" | make -f -`
@@ -300,7 +300,7 @@
[ ${HAVE_GETLINE} -eq 0 ] && echo "#include <stdio.h>"
echo
-echo "#define MAN_CONF_FILE \"/etc/${MANM_MANCONF}\""
+echo "#define MAN_CONF_FILE \"@TERMUX_PREFIX@/etc/${MANM_MANCONF}\""
echo "#define MANPATH_DEFAULT \"${MANPATH_DEFAULT}\""
[ -n "${OSNAME}" ] && echo "#define OSNAME \"${OSNAME}\""
[ -n "${HOMEBREWDIR}" ] && echo "#define HOMEBREWDIR \"${HOMEBREWDIR}\""

View File

@ -1,12 +1,12 @@
diff -u -r ../mdocml-1.13.2/main.c ./main.c
--- ../mdocml-1.13.2/main.c 2014-12-13 09:06:35.000000000 -0500
+++ ./main.c 2014-12-29 10:02:14.200125906 -0500
@@ -866,7 +866,7 @@
diff -u -r ../mdocml-1.13.4/main.c ./main.c
--- ../mdocml-1.13.4/main.c 2016-07-14 07:13:40.000000000 -0400
+++ ./main.c 2016-07-16 19:02:14.979817917 -0400
@@ -1042,7 +1044,7 @@
if (pager == NULL || *pager == '\0')
pager = getenv("PAGER");
if (pager == NULL || *pager == '\0')
- pager = "/usr/bin/more -s";
+ pager = "@TERMUX_PREFIX@/bin/less -s";
- pager = "more -s";
+ pager = "less -s";
cp = mandoc_strdup(pager);
/*

View File

@ -1,12 +0,0 @@
diff -u -r ../mdocml-1.13.2/manpath.c ./manpath.c
--- ../mdocml-1.13.2/manpath.c 2014-12-13 09:06:35.000000000 -0500
+++ ./manpath.c 2014-12-29 09:32:55.168124689 -0500
@@ -30,7 +30,7 @@
#include "mandoc_aux.h"
#include "manpath.h"
-#define MAN_CONF_FILE "/etc/man.conf"
+#define MAN_CONF_FILE "@TERMUX_PREFIX@/etc/man.conf"
#define MAN_CONF_KEY "_whatdb"
static void manpath_add(struct manpaths *, const char *, int);

15
packages/man/tag.c.patch Normal file
View File

@ -0,0 +1,15 @@
diff -u -r ../mdocml-1.13.4/tag.c ./tag.c
--- ../mdocml-1.13.4/tag.c 2016-07-14 07:13:40.000000000 -0400
+++ ./tag.c 2016-07-16 19:03:04.023051008 -0400
@@ -82,9 +82,9 @@
/* Create both temporary output files. */
- (void)strlcpy(tag_files.ofn, "/tmp/man.XXXXXXXXXX",
+ (void)strlcpy(tag_files.ofn, "@TERMUX_PREFIX@/tmp/man.XXXXXXXXXX",
sizeof(tag_files.ofn));
- (void)strlcpy(tag_files.tfn, "/tmp/man.XXXXXXXXXX",
+ (void)strlcpy(tag_files.tfn, "@TERMUX_PREFIX@/tmp/man.XXXXXXXXXX",
sizeof(tag_files.tfn));
if ((ofd = mkstemp(tag_files.ofn)) == -1)
goto fail;

14
packages/man/tag.h.patch Normal file
View File

@ -0,0 +1,14 @@
diff -u -r ../mdocml-1.13.4/tag.h ./tag.h
--- ../mdocml-1.13.4/tag.h 2016-07-14 07:13:40.000000000 -0400
+++ ./tag.h 2016-07-16 19:06:53.419465442 -0400
@@ -16,8 +16,8 @@
*/
struct tag_files {
- char ofn[20];
- char tfn[20];
+ char ofn[127];
+ char tfn[127];
int ofd;
int tfd;
pid_t tcpgid;