add: cc65
This commit is contained in:
parent
838044f931
commit
18cf581fc2
13
packages/cc65/Makefile.patch
Normal file
13
packages/cc65/Makefile.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- ./src/Makefile.orig 2020-05-31 00:33:15.000000000 +0530
|
||||
+++ ./src/Makefile 2021-08-26 20:22:30.920000000 +0530
|
||||
@@ -40,8 +40,8 @@
|
||||
RMDIR = $(RM) -r $1
|
||||
endif
|
||||
|
||||
-CC = $(CROSS_COMPILE)gcc
|
||||
-AR = $(CROSS_COMPILE)ar
|
||||
+CC ?= $(CROSS_COMPILE)gcc
|
||||
+AR ?= $(CROSS_COMPILE)ar
|
||||
|
||||
ifdef CROSS_COMPILE
|
||||
$(info CC: $(CC))
|
20
packages/cc65/build.sh
Normal file
20
packages/cc65/build.sh
Normal file
@ -0,0 +1,20 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://cc65.github.io/
|
||||
TERMUX_PKG_DESCRIPTION="A free compiler for 6502 based system."
|
||||
TERMUX_PKG_LICENSE="ZLIB"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=2.19
|
||||
TERMUX_PKG_SRCURL=https://github.com/cc65/cc65/archive/refs/tags/V${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=157b8051aed7f534e5093471e734e7a95e509c577324099c3c81324ed9d0de77
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
TERMUX_PKG_HOSTBUILD=true
|
||||
|
||||
termux_step_host_build() {
|
||||
cd $TERMUX_PKG_SRCDIR
|
||||
make clean
|
||||
make
|
||||
}
|
||||
|
||||
termux_step_make() {
|
||||
make clean -C src
|
||||
make bin
|
||||
}
|
Loading…
Reference in New Issue
Block a user