liblz4: fix build & installation steps

* Run only `make install` to avoid compiling libs & tools 2 times.

* Always use `ln -sf` when creating symlinks.
This commit is contained in:
Leonid Pliushch 2019-09-09 03:43:35 +03:00
parent fa50702452
commit 1955cc086f
2 changed files with 18 additions and 0 deletions

View File

@ -0,0 +1,12 @@
diff -uNr lz4-1.9.2/Makefile.inc lz4-1.9.2.mod/Makefile.inc
--- lz4-1.9.2/Makefile.inc 2019-08-15 14:59:59.000000000 +0300
+++ lz4-1.9.2.mod/Makefile.inc 2019-09-09 03:40:49.761918035 +0300
@@ -70,7 +70,7 @@
LN_S = cp -p
LN_SF = cp -p
else
-LN_S = ln -s
+LN_S = ln -sf
LN_SF = ln -sf
endif
endif

View File

@ -11,3 +11,9 @@ TERMUX_PKG_BUILD_IN_SRC=true
termux_step_pre_configure() {
TERMUX_PKG_SRCDIR+=lib
}
# Do not execute this step since on `make install` it will
# recompile libraries & tools again.
termux_step_make() {
:
}