radare2: update to 5.2.1
This commit is contained in:
parent
892b5e461c
commit
1a9b24d547
@ -2,9 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://rada.re
|
||||
TERMUX_PKG_DESCRIPTION="Advanced Hexadecimal Editor"
|
||||
TERMUX_PKG_LICENSE="GPL-3.0"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=5.1.1
|
||||
TERMUX_PKG_VERSION=5.2.1
|
||||
TERMUX_PKG_SRCURL=https://github.com/radare/radare2/archive/$TERMUX_PKG_VERSION.tar.gz
|
||||
TERMUX_PKG_SHA256=34c22680ee55addd942392725c79d2457dfcadf32bbaf10d144d338368f86f2f
|
||||
TERMUX_PKG_SHA256=1f0a85fd53ebe003ceb94735ecb4c2f7966f6270526bf1461faaf301658c57e9
|
||||
TERMUX_PKG_DEPENDS="libuv"
|
||||
TERMUX_PKG_BREAKS="radare2-dev"
|
||||
TERMUX_PKG_REPLACES="radare2-dev"
|
||||
|
24
packages/radare2/fix-bin-sh-path.patch
Normal file
24
packages/radare2/fix-bin-sh-path.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -uNr radare2-5.2.1/libr/socket/run.c radare2-5.2.1.mod/libr/socket/run.c
|
||||
--- radare2-5.2.1/libr/socket/run.c 2021-04-21 18:25:58.000000000 +0000
|
||||
+++ radare2-5.2.1.mod/libr/socket/run.c 2021-05-06 13:55:30.146405233 +0000
|
||||
@@ -1198,7 +1198,7 @@
|
||||
#if __UNIX__
|
||||
close(0);
|
||||
close(1);
|
||||
- exit (execl ("/bin/sh","/bin/sh", "-c", p->_system, NULL));
|
||||
+ exit (execl ("@TERMUX_PREFIX@/bin/sh","@TERMUX_PREFIX@/bin/sh", "-c", p->_system, NULL));
|
||||
#else
|
||||
exit (r_sys_cmd (p->_system));
|
||||
#endif
|
||||
diff -uNr radare2-5.2.1/libr/util/file.c radare2-5.2.1.mod/libr/util/file.c
|
||||
--- radare2-5.2.1/libr/util/file.c 2021-04-21 18:25:58.000000000 +0000
|
||||
+++ radare2-5.2.1.mod/libr/util/file.c 2021-05-06 13:55:11.138404943 +0000
|
||||
@@ -281,7 +281,7 @@
|
||||
bin_sh = r_file_path("sh");
|
||||
if (R_STR_ISEMPTY (bin_sh)) {
|
||||
free (bin_sh);
|
||||
- bin_sh = strdup ("/bin/sh");
|
||||
+ bin_sh = strdup ("@TERMUX_PREFIX@/bin/sh");
|
||||
}
|
||||
}
|
||||
return bin_sh;
|
@ -1,12 +0,0 @@
|
||||
diff -uNr radare2-2.0.0/libr/include/r_magic.h radare2-2.0.0.mod/libr/include/r_magic.h
|
||||
--- radare2-2.0.0/libr/include/r_magic.h 2017-10-09 18:05:53.000000000 +0300
|
||||
+++ radare2-2.0.0.mod/libr/include/r_magic.h 2017-10-11 16:23:00.721073712 +0300
|
||||
@@ -12,7 +12,7 @@
|
||||
R_LIB_VERSION_HEADER(r_magic);
|
||||
|
||||
#ifndef MAGICFILE
|
||||
-#define MAGICFILE "/etc/magic"
|
||||
+#define MAGICFILE "@TERMUX_PREFIX@/etc/magic"
|
||||
#endif
|
||||
|
||||
#define R_MAGIC_PATH R2_PREFIX "/share/radare2/" R2_VERSION "/magic"
|
@ -1,12 +0,0 @@
|
||||
diff -uNr radare2-3.2.1/libr/util/sandbox.c radare2-3.2.1.mod/libr/util/sandbox.c
|
||||
--- radare2-3.2.1/libr/util/sandbox.c 2019-01-08 18:14:43.000000000 +0200
|
||||
+++ radare2-3.2.1.mod/libr/util/sandbox.c 2019-03-02 02:42:52.796061199 +0200
|
||||
@@ -154,7 +154,7 @@
|
||||
return system (x);
|
||||
#endif
|
||||
}
|
||||
- return execl ("/bin/sh", "sh", "-c", x, (const char*)NULL);
|
||||
+ return execl ("@TERMUX_PREFIX@/bin/sh", "sh", "-c", x, (const char*)NULL);
|
||||
#else
|
||||
#include <spawn.h>
|
||||
if (n && !strchr (x, '|')) {
|
@ -1,11 +0,0 @@
|
||||
diff -u -r ../radare2-2.4.0/mk/termux-host.mk ./mk/termux-host.mk
|
||||
--- ../radare2-2.4.0/mk/termux-host.mk 2018-03-05 17:12:35.000000000 +0000
|
||||
+++ ./mk/termux-host.mk 2018-03-07 10:00:57.076202764 +0000
|
||||
@@ -3,6 +3,7 @@
|
||||
#RANLIB=ndk-ranlib
|
||||
USERCC=gcc -fPIC -fPIE
|
||||
CC_AR=${AR} -r ${LIBAR}
|
||||
+PARTIALLD=${LD} -r --whole-archive
|
||||
|
||||
ONELIB=0
|
||||
OSTYPE=android
|
@ -1,9 +0,0 @@
|
||||
diff -uNr radare2-3.9.0/sys/ldconfig.sh radare2-3.9.0.mod/sys/ldconfig.sh
|
||||
--- radare2-3.9.0/sys/ldconfig.sh 2019-09-17 16:31:23.000000000 +0300
|
||||
+++ radare2-3.9.0.mod/sys/ldconfig.sh 2019-09-18 16:13:09.246804787 +0300
|
||||
@@ -1,4 +1,5 @@
|
||||
#!/bin/sh
|
||||
+exit 0
|
||||
LD=/etc/ld.so.conf.d
|
||||
if test -w $LD ; then
|
||||
if type ldconfig > /dev/null 2>&1 ; then
|
Loading…
Reference in New Issue
Block a user