glew: disable package
Compilation failure on at least arm. llvm-ar rv lib/libGLEW.a tmp/linux/default/static/glew.o llvm-ar: warning: creating lib/libGLEW.a llvm-strip -x lib/libGLEW.a llvm-strip: error: 'lib/libGLEW.a': not stripping symbol '_glewExtensionLookup' because it is named in a relocation make: *** [Makefile:115: lib/libGLEW.a] Error 1 make: *** Waiting for unfinished jobs.... 2 warnings generated. mesa-demos has been disabled as well because dependent on glew. Someone need to look into this. %ci:no-build
This commit is contained in:
parent
e6ce53e703
commit
1b018250e8
@ -1,70 +0,0 @@
|
||||
diff -uNr glew-2.2.0/Makefile glew-2.2.0.mod/Makefile
|
||||
--- glew-2.2.0/Makefile 2020-03-15 13:53:59.000000000 +0200
|
||||
+++ glew-2.2.0.mod/Makefile 2021-07-23 23:03:17.535567124 +0300
|
||||
@@ -40,12 +40,12 @@
|
||||
$(error "Platform '$(SYSTEM)' not supported")
|
||||
endif
|
||||
|
||||
-GLEW_PREFIX ?= /usr
|
||||
-GLEW_DEST ?= /usr
|
||||
-BINDIR ?= $(GLEW_DEST)/bin
|
||||
-LIBDIR ?= $(GLEW_DEST)/lib
|
||||
-INCDIR ?= $(GLEW_DEST)/include/GL
|
||||
-PKGDIR ?= $(GLEW_DEST)/lib/pkgconfig
|
||||
+GLEW_PREFIX = @TERMUX_PREFIX@
|
||||
+GLEW_DEST = @TERMUX_PREFIX@
|
||||
+BINDIR = $(GLEW_DEST)/bin
|
||||
+LIBDIR = $(GLEW_DEST)/lib
|
||||
+INCDIR = $(GLEW_DEST)/include/GL
|
||||
+PKGDIR = $(GLEW_DEST)/lib/pkgconfig
|
||||
|
||||
ifneq ($(GLEW_NO_GLU), -DGLEW_NO_GLU)
|
||||
LIBGLU = glu
|
||||
diff -uNr glew-2.2.0/config/Makefile.linux glew-2.2.0.mod/config/Makefile.linux
|
||||
--- glew-2.2.0/config/Makefile.linux 2020-03-15 13:53:59.000000000 +0200
|
||||
+++ glew-2.2.0.mod/config/Makefile.linux 2021-07-23 23:11:42.151780238 +0300
|
||||
@@ -1,32 +1,17 @@
|
||||
NAME = $(GLEW_NAME)
|
||||
-CC = cc
|
||||
-LD = cc
|
||||
-M_ARCH ?= $(shell uname -m)
|
||||
-ARCH64 = false
|
||||
-ifeq (x86_64,${M_ARCH})
|
||||
- ARCH64 = true
|
||||
-endif
|
||||
-ifeq (ppc64,${M_ARCH})
|
||||
- ARCH64 = true
|
||||
-endif
|
||||
-ifeq (e2k,${M_ARCH})
|
||||
- ARCH64 = true
|
||||
-endif
|
||||
-ifeq (${ARCH64},true)
|
||||
- LDFLAGS.EXTRA = -L/usr/X11R6/lib64 -L/usr/lib64
|
||||
- LIBDIR = $(GLEW_DEST)/lib64
|
||||
-else
|
||||
- LDFLAGS.EXTRA = -L/usr/X11R6/lib -L/usr/lib
|
||||
- LIBDIR = $(GLEW_DEST)/lib
|
||||
-endif
|
||||
+CC ?= cc
|
||||
+LD ?= cc
|
||||
+LIBDIR = $(GLEW_DEST)/lib
|
||||
+LDFLAGS.EXTRA = -L@TERMUX_PREFIX@/lib
|
||||
LDFLAGS.GL = -lGL -lX11
|
||||
LDFLAGS.STATIC = -Wl,-Bstatic
|
||||
-LDFLAGS.DYNAMIC = -Wl,-Bdynamic
|
||||
+LDFLAGS.DYNAMIC = -Wl,-Bdynamic -Wl,-rpath=@TERMUX_PREFIX@/lib -Wl,--enable-new-dtags
|
||||
NAME = GLEW
|
||||
WARN += -Wall -W
|
||||
WARN += -Wshadow
|
||||
WARN += -pedantic
|
||||
POPT = -O2
|
||||
+CFLAGS.EXTRA += -I@TERMUX_PREFIX@/include
|
||||
CFLAGS.EXTRA += -fPIC
|
||||
CFLAGS.EXTRA += -Wcast-qual
|
||||
CFLAGS.EXTRA += -ansi -pedantic
|
||||
@@ -36,4 +21,4 @@
|
||||
LIB.DEVLNK = lib$(NAME).so
|
||||
LIB.SHARED = lib$(NAME).so.$(SO_VERSION)
|
||||
LIB.STATIC = lib$(NAME).a
|
||||
-LDFLAGS.SO = -shared -Wl,-soname=$(LIB.SONAME)
|
||||
+LDFLAGS.SO = -shared -Wl,-soname=$(LIB.SONAME) -Wl,-rpath=@TERMUX_PREFIX@/lib -Wl,--enable-new-dtags
|
@ -1,14 +0,0 @@
|
||||
TERMUX_PKG_HOMEPAGE=http://glew.sourceforge.net/
|
||||
TERMUX_PKG_DESCRIPTION="The OpenGL Extension Wrangler Library"
|
||||
TERMUX_PKG_LICENSE="BSD, GPL-2.0, MIT"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=2.2.0
|
||||
TERMUX_PKG_REVISION=11
|
||||
TERMUX_PKG_SRCURL=https://downloads.sourceforge.net/glew/glew-${TERMUX_PKG_VERSION}.tgz
|
||||
TERMUX_PKG_SHA256=d4fc82893cfb00109578d0a1a2337fb8ca335b3ceccf97b97e5cc7f08e4353e1
|
||||
TERMUX_PKG_DEPENDS="glu, libxi, libxmu"
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
|
||||
termux_step_pre_configure() {
|
||||
LD=$CC
|
||||
}
|
@ -1,123 +0,0 @@
|
||||
diff -uNr glew-2.1.0/auto/Makefile glew-2.1.0.mod/auto/Makefile
|
||||
--- glew-2.1.0/auto/Makefile 2017-07-31 14:25:39.000000000 +0300
|
||||
+++ glew-2.1.0.mod/auto/Makefile 2019-10-15 15:43:41.598890328 +0300
|
||||
@@ -240,7 +240,7 @@
|
||||
cat $(SRC)/glew_init_wgl.c >> $@
|
||||
$(BIN)/make_list.pl $(WGL_EXT_SPEC) >> $@
|
||||
echo -e "\n return GLEW_OK;\n}" >> $@;
|
||||
- echo -e "\n#elif !defined(__ANDROID__) && !defined(__native_client__) && !defined(__HAIKU__) && (!defined(__APPLE__) || defined(GLEW_APPLE_GLX))" >> $@
|
||||
+ echo -e "\n#elif !defined(__NOANDROID__) && !defined(__native_client__) && !defined(__HAIKU__) && (!defined(__APPLE__) || defined(GLEW_APPLE_GLX))" >> $@
|
||||
$(BIN)/make_def_fun.pl GLX $(GLX_CORE_SPEC) >> $@
|
||||
$(BIN)/make_def_fun.pl GLX $(GLX_EXT_SPEC) >> $@
|
||||
echo -e "\nGLboolean __GLXEW_VERSION_1_0 = GL_FALSE;" >> $@
|
||||
@@ -253,7 +253,7 @@
|
||||
$(BIN)/make_list.pl $(CORE)/GLX_VERSION_1_3 | grep -v '\"GLX_VERSION' >> $@
|
||||
$(BIN)/make_list.pl $(GLX_EXT_SPEC) >> $@
|
||||
echo -e "\n return GLEW_OK;\n}" >> $@
|
||||
- echo -e "\n#endif /* !defined(__ANDROID__) && !defined(__native_client__) && !defined(__HAIKU__) && (!defined(__APPLE__) || defined(GLEW_APPLE_GLX)) */\n" >> $@;
|
||||
+ echo -e "\n#endif /* !defined(__NOANDROID__) && !defined(__native_client__) && !defined(__HAIKU__) && (!defined(__APPLE__) || defined(GLEW_APPLE_GLX)) */\n" >> $@;
|
||||
cat $(SRC)/glew_init_tail.c >> $@
|
||||
cat $(SRC)/glew_str_head.c >> $@
|
||||
$(BIN)/make_str.pl $(GL_CORE_SPEC) $(GL_EXT_SPEC) >> $@
|
||||
diff -uNr glew-2.1.0/auto/src/glew_head.c glew-2.1.0.mod/auto/src/glew_head.c
|
||||
--- glew-2.1.0/auto/src/glew_head.c 2017-07-31 14:25:39.000000000 +0300
|
||||
+++ glew-2.1.0.mod/auto/src/glew_head.c 2019-10-15 15:44:04.328890312 +0300
|
||||
@@ -19,7 +19,7 @@
|
||||
# undef NOGDI
|
||||
# endif
|
||||
# include <GL/wglew.h>
|
||||
-#elif !defined(__ANDROID__) && !defined(__native_client__) && !defined(__HAIKU__) && (!defined(__APPLE__) || defined(GLEW_APPLE_GLX))
|
||||
+#elif !defined(__NOANDROID__) && !defined(__native_client__) && !defined(__HAIKU__) && (!defined(__APPLE__) || defined(GLEW_APPLE_GLX))
|
||||
# include <GL/glxew.h>
|
||||
#endif
|
||||
|
||||
@@ -138,7 +138,7 @@
|
||||
# define glewGetProcAddress(name) NSGLGetProcAddress(name)
|
||||
#elif defined(__sgi) || defined(__sun) || defined(__HAIKU__)
|
||||
# define glewGetProcAddress(name) dlGetProcAddress(name)
|
||||
-#elif defined(__ANDROID__)
|
||||
+#elif defined(__NOANDROID__)
|
||||
# define glewGetProcAddress(name) NULL /* TODO */
|
||||
#elif defined(__native_client__)
|
||||
# define glewGetProcAddress(name) NULL /* TODO */
|
||||
diff -uNr glew-2.1.0/auto/src/glew_init_tail.c glew-2.1.0.mod/auto/src/glew_init_tail.c
|
||||
--- glew-2.1.0/auto/src/glew_init_tail.c 2017-07-31 14:25:39.000000000 +0300
|
||||
+++ glew-2.1.0.mod/auto/src/glew_init_tail.c 2019-10-15 15:43:48.048890323 +0300
|
||||
@@ -43,7 +43,7 @@
|
||||
#if defined(GLEW_EGL)
|
||||
getCurrentDisplay = (PFNEGLGETCURRENTDISPLAYPROC) glewGetProcAddress("eglGetCurrentDisplay");
|
||||
return eglewInit(getCurrentDisplay());
|
||||
-#elif defined(GLEW_OSMESA) || defined(__ANDROID__) || defined(__native_client__) || defined(__HAIKU__)
|
||||
+#elif defined(GLEW_OSMESA) || defined(__NOANDROID__) || defined(__native_client__) || defined(__HAIKU__)
|
||||
return r;
|
||||
#elif defined(_WIN32)
|
||||
return wglewInit();
|
||||
diff -uNr glew-2.1.0/auto/src/glew_str_glx.c glew-2.1.0.mod/auto/src/glew_str_glx.c
|
||||
--- glew-2.1.0/auto/src/glew_str_glx.c 2017-07-31 14:25:39.000000000 +0300
|
||||
+++ glew-2.1.0.mod/auto/src/glew_str_glx.c 2019-10-15 15:43:59.418890315 +0300
|
||||
@@ -4,7 +4,7 @@
|
||||
return ret;
|
||||
}
|
||||
|
||||
-#elif !defined(GLEW_OSMESA) && !defined(GLEW_EGL) && !defined(__ANDROID__) && !defined(__native_client__) && !defined(__HAIKU__) && !defined(__APPLE__) || defined(GLEW_APPLE_GLX)
|
||||
+#elif !defined(GLEW_OSMESA) && !defined(GLEW_EGL) && !defined(__NOANDROID__) && !defined(__native_client__) && !defined(__HAIKU__) && !defined(__APPLE__) || defined(GLEW_APPLE_GLX)
|
||||
|
||||
GLboolean glxewIsSupported (const char* name)
|
||||
{
|
||||
diff -uNr glew-2.1.0/src/glew.c glew-2.1.0.mod/src/glew.c
|
||||
--- glew-2.1.0/src/glew.c 2017-07-31 14:25:39.000000000 +0300
|
||||
+++ glew-2.1.0.mod/src/glew.c 2019-10-15 15:43:53.658890319 +0300
|
||||
@@ -51,7 +51,7 @@
|
||||
# undef NOGDI
|
||||
# endif
|
||||
# include <GL/wglew.h>
|
||||
-#elif !defined(__ANDROID__) && !defined(__native_client__) && !defined(__HAIKU__) && (!defined(__APPLE__) || defined(GLEW_APPLE_GLX))
|
||||
+#elif !defined(__NOANDROID__) && !defined(__native_client__) && !defined(__HAIKU__) && (!defined(__APPLE__) || defined(GLEW_APPLE_GLX))
|
||||
# include <GL/glxew.h>
|
||||
#endif
|
||||
|
||||
@@ -170,7 +170,7 @@
|
||||
# define glewGetProcAddress(name) NSGLGetProcAddress(name)
|
||||
#elif defined(__sgi) || defined(__sun) || defined(__HAIKU__)
|
||||
# define glewGetProcAddress(name) dlGetProcAddress(name)
|
||||
-#elif defined(__ANDROID__)
|
||||
+#elif defined(__NOANDROID__)
|
||||
# define glewGetProcAddress(name) NULL /* TODO */
|
||||
#elif defined(__native_client__)
|
||||
# define glewGetProcAddress(name) NULL /* TODO */
|
||||
@@ -19746,7 +19746,7 @@
|
||||
return GLEW_OK;
|
||||
}
|
||||
|
||||
-#elif !defined(__ANDROID__) && !defined(__native_client__) && !defined(__HAIKU__) && (!defined(__APPLE__) || defined(GLEW_APPLE_GLX))
|
||||
+#elif !defined(__NOANDROID__) && !defined(__native_client__) && !defined(__HAIKU__) && (!defined(__APPLE__) || defined(GLEW_APPLE_GLX))
|
||||
|
||||
PFNGLXGETCURRENTDISPLAYPROC __glewXGetCurrentDisplay = NULL;
|
||||
|
||||
@@ -20821,7 +20821,7 @@
|
||||
return GLEW_OK;
|
||||
}
|
||||
|
||||
-#endif /* !defined(__ANDROID__) && !defined(__native_client__) && !defined(__HAIKU__) && (!defined(__APPLE__) || defined(GLEW_APPLE_GLX)) */
|
||||
+#endif /* !defined(__NOANDROID__) && !defined(__native_client__) && !defined(__HAIKU__) && (!defined(__APPLE__) || defined(GLEW_APPLE_GLX)) */
|
||||
|
||||
/* ------------------------------------------------------------------------ */
|
||||
|
||||
@@ -20868,7 +20868,7 @@
|
||||
#if defined(GLEW_EGL)
|
||||
getCurrentDisplay = (PFNEGLGETCURRENTDISPLAYPROC) glewGetProcAddress("eglGetCurrentDisplay");
|
||||
return eglewInit(getCurrentDisplay());
|
||||
-#elif defined(GLEW_OSMESA) || defined(__ANDROID__) || defined(__native_client__) || defined(__HAIKU__)
|
||||
+#elif defined(GLEW_OSMESA) || defined(__NOANDROID__) || defined(__native_client__) || defined(__HAIKU__)
|
||||
return r;
|
||||
#elif defined(_WIN32)
|
||||
return wglewInit();
|
||||
@@ -27059,7 +27059,7 @@
|
||||
return ret;
|
||||
}
|
||||
|
||||
-#elif !defined(GLEW_OSMESA) && !defined(GLEW_EGL) && !defined(__ANDROID__) && !defined(__native_client__) && !defined(__HAIKU__) && !defined(__APPLE__) || defined(GLEW_APPLE_GLX)
|
||||
+#elif !defined(GLEW_OSMESA) && !defined(GLEW_EGL) && !defined(__NOANDROID__) && !defined(__native_client__) && !defined(__HAIKU__) && !defined(__APPLE__) || defined(GLEW_APPLE_GLX)
|
||||
|
||||
GLboolean glxewIsSupported (const char* name)
|
||||
{
|
@ -1,83 +0,0 @@
|
||||
The Mesa 3D Graphics Library
|
||||
|
||||
Disclaimer
|
||||
|
||||
Mesa is a 3-D graphics library with an API which is very similar to
|
||||
that of [1]OpenGL.* To the extent that Mesa utilizes the OpenGL command
|
||||
syntax or state machine, it is being used with authorization from
|
||||
[2]Silicon Graphics, Inc.(SGI). However, the author does not possess an
|
||||
OpenGL license from SGI, and makes no claim that Mesa is in any way a
|
||||
compatible replacement for OpenGL or associated with SGI. Those who
|
||||
want a licensed implementation of OpenGL should contact a licensed
|
||||
vendor.
|
||||
|
||||
Please do not refer to the library as MesaGL (for legal reasons). It's
|
||||
just Mesa or The Mesa 3-D graphics library.
|
||||
|
||||
* OpenGL is a trademark of [3]Silicon Graphics Incorporated.
|
||||
|
||||
License / Copyright Information
|
||||
|
||||
The Mesa distribution consists of several components. Different
|
||||
copyrights and licenses apply to different components. For example, the
|
||||
GLX client code uses the SGI Free Software License B, and some of the
|
||||
Mesa device drivers are copyrighted by their authors. See below for a
|
||||
list of Mesa's main components and the license for each.
|
||||
|
||||
The core Mesa library is licensed according to the terms of the MIT
|
||||
license. This allows integration with the XFree86, Xorg and DRI
|
||||
projects.
|
||||
|
||||
The default Mesa license is as follows:
|
||||
|
||||
Copyright (C) 1999-2007 Brian Paul All Rights Reserved.
|
||||
|
||||
Permission is hereby granted, free of charge, to any person obtaining a
|
||||
copy of this software and associated documentation files (the "Software"),
|
||||
to deal in the Software without restriction, including without limitation
|
||||
the rights to use, copy, modify, merge, publish, distribute, sublicense,
|
||||
and/or sell copies of the Software, and to permit persons to whom the
|
||||
Software is furnished to do so, subject to the following conditions:
|
||||
|
||||
The above copyright notice and this permission notice shall be included
|
||||
in all copies or substantial portions of the Software.
|
||||
|
||||
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
|
||||
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
|
||||
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
|
||||
THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
|
||||
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
|
||||
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
|
||||
SOFTWARE.
|
||||
|
||||
Attention, Contributors
|
||||
|
||||
When contributing to the Mesa project you must agree to the licensing
|
||||
terms of the component to which you're contributing. The following
|
||||
section lists the primary components of the Mesa distribution and their
|
||||
respective licenses.
|
||||
|
||||
Mesa Component Licenses
|
||||
|
||||
Component Location License
|
||||
------------------------------------------------------------------
|
||||
Main Mesa code src/mesa/ MIT
|
||||
|
||||
Device drivers src/mesa/drivers/* MIT, generally
|
||||
|
||||
Gallium code src/gallium/ MIT
|
||||
|
||||
Ext headers include/GL/glext.h Khronos
|
||||
include/GL/glxext.h
|
||||
|
||||
GLX client code src/glx/ SGI Free Software License B
|
||||
|
||||
C11 thread include/c11/threads*.h Boost (permissive) emulation
|
||||
|
||||
In general, consult the source files for license terms.
|
||||
|
||||
References
|
||||
|
||||
1. https://www.opengl.org/
|
||||
2. https://www.sgi.com/
|
||||
3. https://www.sgi.com/
|
@ -1,19 +0,0 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://www.mesa3d.org
|
||||
TERMUX_PKG_DESCRIPTION="OpenGL demonstration and test programs"
|
||||
TERMUX_PKG_LICENSE="MIT"
|
||||
TERMUX_PKG_MAINTAINER="Rafael Kitover <rkitover@gmail.com>"
|
||||
TERMUX_PKG_VERSION=8.4.0
|
||||
TERMUX_PKG_REVISION=2
|
||||
TERMUX_PKG_SRCURL=https://archive.mesa3d.org//demos/mesa-demos-${TERMUX_PKG_VERSION}.tar.bz2
|
||||
TERMUX_PKG_SHA256=01e99c94a0184e63e796728af89bfac559795fb2a0d6f506fa900455ca5fff7d
|
||||
TERMUX_PKG_DEPENDS="libx11, mesa, libdrm, freetype, libxext, glew, freeglut"
|
||||
|
||||
termux_step_pre_configure() {
|
||||
sed -i '/tests /d' src/Makefile.am
|
||||
sed -i 's/ -lpthread//' src/xdemos/Makefile.am
|
||||
autoreconf -fi
|
||||
}
|
||||
|
||||
termux_step_install_license() {
|
||||
install -Dm600 -t $TERMUX_PREFIX/share/doc/mesa-demos $TERMUX_PKG_BUILDER_DIR/LICENSE
|
||||
}
|
Loading…
Reference in New Issue
Block a user