picolisp: Update from 16.3.1 to 16.4.1

This commit is contained in:
Fredrik Fornwall 2016-04-13 05:58:09 -04:00
parent 6a4a91455d
commit 1bc99fb009
2 changed files with 7 additions and 5 deletions

View File

@ -1,13 +1,13 @@
TERMUX_PKG_HOMEPAGE=http://picolisp.com
TERMUX_PKG_DESCRIPTION="Lisp interpreter and application server framework"
TERMUX_PKG_VERSION=16.3.1
TERMUX_PKG_VERSION=16.4.1
TERMUX_PKG_SRCURL=http://software-lab.de/picoLisp.tgz
TERMUX_PKG_FOLDERNAME=picoLisp
TERMUX_PKG_BUILD_IN_SRC=true
termux_step_pre_configure() {
# Validate that we have the right version:
grep -q '16 3 1' src64/version.l
grep -q '16 4 1' src64/version.l
TERMUX_PKG_SRCDIR=$TERMUX_PKG_SRCDIR/src
if [ $TERMUX_ARCH_BITS = 64 ]; then

View File

@ -1,7 +1,7 @@
diff -u -r ../picoLisp/src/Makefile ./src/Makefile
--- ../picoLisp/src/Makefile 2016-02-02 10:52:49.000000000 -0500
+++ ./src/Makefile 2016-02-08 06:15:50.293964319 -0500
@@ -6,118 +6,13 @@
+++ ./src/Makefile 2016-04-12 05:55:14.050621923 -0400
@@ -6,119 +6,14 @@
picoFiles = main.c gc.c apply.c flow.c sym.c subr.c big.c io.c net.c tab.c
@ -116,12 +116,14 @@ diff -u -r ../picoLisp/src/Makefile ./src/Makefile
-endif
-endif
-endif
-
+CCLD = $(CC)
+LCRYPT =
+OS = Android
+PICOLISP-FLAGS = -rdynamic -lm $(LDFLAGS)
+DYNAMIC-LIB-FLAGS = -shared -export-dynamic $(LDFLAGS) -lm
+
picolisp: $(bin)/picolisp $(lib)/ext$(dll) $(lib)/ht$(dll)
tools: $(bin)/lat1 $(bin)/utf2 $(bin)/balance
gate: $(bin)/ssl $(bin)/httpGate