fish: update to 3.3.0 (#7099)

This commit is contained in:
YAKSH BARIYA 2021-07-04 16:21:34 +05:30 committed by GitHub
parent 24f36a5fea
commit 1fa9c8ac52
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 17 additions and 5 deletions

View File

@ -1,6 +1,18 @@
--- ../CMakeLists.txt.orig 2021-03-18 00:06:20.429297758 +0530
+++ ./CMakeLists.txt 2021-03-18 00:12:26.125297619 +0530
@@ -179,7 +179,7 @@
--- ./CMakeLists.txt 2021-07-04 13:00:34.583855568 +0530
+++ ./CMakeLists.txt.mod 2021-07-04 13:01:48.993855539 +0530
@@ -30,11 +30,6 @@
set(CMAKE_BUILD_TYPE "${DEFAULT_BUILD_TYPE}")
endif()
-# Error out when linking statically, it doesn't work.
-if (CMAKE_EXE_LINKER_FLAGS MATCHES ".*-static.*")
- message(FATAL_ERROR "Fish does not support static linking")
-endif()
-
# Force colored warnings in Ninja's output, if the compiler has -fdiagnostics-color support.
# Rationale in https://github.com/ninja-build/ninja/issues/814
if (CMAKE_GENERATOR STREQUAL "Ninja" AND
@@ -185,7 +180,7 @@
target_sources(fishlib PRIVATE ${FISH_HEADERS})
target_link_libraries(fishlib
${CURSES_LIBRARY} ${CURSES_EXTRA_LIBRARY} Threads::Threads ${CMAKE_DL_LIBS}

View File

@ -2,9 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://fishshell.com/
TERMUX_PKG_DESCRIPTION="Shell geared towards interactive use"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=3.2.2
TERMUX_PKG_VERSION=3.3.0
TERMUX_PKG_SRCURL=https://github.com/fish-shell/fish-shell/releases/download/$TERMUX_PKG_VERSION/fish-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=5944da1a8893d11b0828a4fd9136ee174549daffb3d0adfdd8917856fe6b4009
TERMUX_PKG_SHA256=a4215e4cab2a5b101b0b8843720bda3c7eb98e8a14dca0950b8ef17e94282faa
# fish calls 'tput' from ncurses-utils, at least when cancelling (Ctrl+C) a command line.
# man is needed since fish calls apropos during command completion.
TERMUX_PKG_DEPENDS="libc++, ncurses, libandroid-support, ncurses-utils, man, bc, pcre2, libandroid-spawn"