new package: scheme48

This commit is contained in:
Tee KOBAYASHI 2022-01-09 08:57:31 +09:00 committed by Leonid Pliushch
parent a5d1fcb3d5
commit 216046f902
2 changed files with 64 additions and 0 deletions

View File

@ -0,0 +1,38 @@
--- a/Makefile.in
+++ b/Makefile.in
@@ -437,7 +437,7 @@
scheme/posix/packages.scm scheme/srfi/packages.scm \
$(usual-files) build/initial.debug build/build-usual-image
$(srcdir)/build/build-usual-image $(srcdir) \
- "`(cd $(srcdir) && pwd)`/scheme" "`pwd`/c" '$(IMAGE)' './$(VM)' \
+ "`(cd $(srcdir) && pwd)`/scheme" "`pwd`/c" '$(IMAGE)' '$(VM)' \
'$(INITIAL)-$(BIT_SUFFIX)'
# --------------------
@@ -479,7 +479,7 @@
# build and install the image
rm -f '/tmp/$(IMAGE)'
$(srcdir)/build/build-usual-image $(srcdir) "$(SHARE)" "$(LIB)" \
- "/tmp/$(IMAGE)" "./$(VM)" "$(INITIAL)-$(BIT_SUFFIX)"
+ "/tmp/$(IMAGE)" "$(VM)" "$(INITIAL)-$(BIT_SUFFIX)"
$(INSTALL_DATA) /tmp/$(IMAGE) $(DESTDIR)$(LIB)
rm /tmp/$(IMAGE)
# install the man pages
@@ -628,7 +628,7 @@
echo ',open test-suites'; \
echo '(define-test-suite all-tests (compiler-tests base-tests big-tests tcp-sockets-tests tconc-queue-tests transport-link-cell-tests tlc-table-tests tlc-table-weak-tests tlc-table-string-tests os-time-tests sort-tests misc-tests env-tests r6rs-tests cml-tests srfi-tests posix-tests ffi-tests))'; \
echo '(run-test-suite all-tests)' \
- ) | ./$(VM) -i $(IMAGE) $(BIG_HEAP)
+ ) | $(VM) -i $(IMAGE) $(BIG_HEAP)
# --------------------
# Rules from here on down are not essential for the basic installation
@@ -885,7 +885,7 @@
(usual-resumer (lambda (args) \
(command-processor #f args))) \
\"foo\")" \
- | ./$(VM) -i scheme/debug/mini.image -a batch
+ | $(VM) -i scheme/debug/mini.image -a batch
# --------------------

View File

@ -0,0 +1,26 @@
TERMUX_PKG_HOMEPAGE=https://www.s48.org/
TERMUX_PKG_DESCRIPTION="An implementation of the Scheme programming language"
TERMUX_PKG_LICENSE="BSD 3-Clause"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.9.2
TERMUX_PKG_SRCURL=https://www.s48.org/${TERMUX_PKG_VERSION}/scheme48-${TERMUX_PKG_VERSION}.tgz
TERMUX_PKG_SHA256=9c4921a90e95daee067cd2e9cc0ffe09e118f4da01c0c0198e577c4f47759df4
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
ac_cv_bits_per_byte=8
ac_cv_header_pthread_h=no
"
TERMUX_PKG_HOSTBUILD=true
termux_step_host_build() {
$TERMUX_PKG_SRCDIR/configure \
CFLAGS=-m${TERMUX_ARCH_BITS} LDFLAGS=-m${TERMUX_ARCH_BITS}
make -j $TERMUX_MAKE_PROCESSES scheme48vm
}
termux_step_pre_configure() {
TERMUX_PKG_EXTRA_CONFIGURE_ARGS+=" ac_cv_sizeof_void_p=$(( $TERMUX_ARCH_BITS / 8 ))"
}
termux_step_post_configure() {
export PATH=$TERMUX_PKG_HOSTBUILD_DIR:$PATH
}