alpine: Some build fixes

This commit is contained in:
Fredrik Fornwall 2017-06-15 14:58:52 +02:00
parent a2bea6da61
commit 242f24c97d
2 changed files with 31 additions and 20 deletions

View File

@ -1,21 +1,29 @@
TERMUX_PKG_HOMEPAGE=http://patches.freeiz.com
TERMUX_PKG_DESCRIPTION="Fast, easy to use email client"
TERMUX_PKG_VERSION=2.21
TERMUX_PKG_SRCURL=http://patches.freeiz.com/alpine/release/src/alpine-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_DEPENDS="openssl"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--with-c-client-target=lnx --without-krb5 --without-pthread --without-tcl --without-ldap --disable-debug --with-system-pinerc=${TERMUX_PREFIX}/etc/pine.conf"
TERMUX_PKG_SRCURL=http://alpine.freeiz.com/alpine/release/src/alpine-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_DEPENDS="libcrypt, ncurses, openssl"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
--disable-debug
--with-c-client-target=lnx
--without-krb5
--without-ldap
--without-pthread
--without-tcl
--with-system-pinerc=${TERMUX_PREFIX}/etc/pine.conf
"
TERMUX_PKG_BUILD_IN_SRC=yes
TERMUX_PKG_SHA256=6030b6881b8168546756ab3a5e43628d8d564539b0476578e287775573a77438
TERMUX_PKG_PATCHURL=http://patches.freeiz.com/alpine/patches/alpine-${TERMUX_PKG_VERSION}/maildir.patch.gz
TERMUX_PKG_PATCHSHA256=1229ea9ec4e150dda1d2da866730a777148874e4667c54cd2c488101b5db8099
# requires installing autopoint default docker image doesn't have that installed as yet.
# adding huge patchsets to termux-packages repo is not optimal so we do it this way for now.
termux_step_post_extract_package() {
local filename
filename=$(basename "$TERMUX_PKG_PATCHURL")
local file="$TERMUX_PKG_CACHEDIR/$filename"
termux_download "$TERMUX_PKG_PATCHURL" "$file" "$TERMUX_PKG_PATCHSHA256"
gunzip -c $file | patch -s -p1
# requires installing autopoint default docker image doesn't have that installed as yet.
# adding huge patchsets to termux-packages repo is not optimal so we do it this way for now.
local file="$TERMUX_PKG_CACHEDIR/maildir.patch.gz"
termux_download \
http://alpine.freeiz.com/alpine/patches/alpine-${TERMUX_PKG_VERSION}/maildir.patch.gz \
"$file" \
1229ea9ec4e150dda1d2da866730a777148874e4667c54cd2c488101b5db8099
gunzip -c $file | patch -s -p1
}
termux_step_pre_configure () {
@ -23,19 +31,21 @@ termux_step_pre_configure () {
export TRANLIB=$RANLIB
export SPELLPROG=${TERMUX_PREFIX}/bin/hunspell
export alpine_SSLVERSION=old
export TPATH=$PATH
LDFLAGS+=" -lcrypt -llog"
cp $TERMUX_PKG_BUILDER_DIR/getpass.c $TERMUX_PKG_SRCDIR/include/
cp $TERMUX_PKG_BUILDER_DIR/getpass.h $TERMUX_PKG_SRCDIR/include/
cp $TERMUX_PKG_BUILDER_DIR/pine.conf $TERMUX_PREFIX/etc/pine.conf
cd $TERMUX_PKG_SRCDIR
autoreconf -if
touch $TERMUX_PKG_SRCDIR/imap/lnxok
export TPATH=$PATH
}
termux_step_post_configure() {
cd pith
$CC_FOR_BUILD help_c_gen.c -o help_c_gen
$CC_FOR_BUILD help_h_gen.c -o help_h_gen
touch -d "next hour" help_c_gen help_h_gen
}

View File

@ -1,10 +1,11 @@
--- ../cache/alpine-2.21/configure.ac 2017-02-06 00:06:22.491217965 +0000
+++ ./configure.ac 2017-04-25 12:00:31.923278306 +0000
@@ -1122,6 +1122,14 @@
])
diff -u -r ../alpine-2.21/configure ./configure
--- ../alpine-2.21/configure 2017-02-06 00:06:22.491217965 +0000
+++ ./configure 2017-06-14 23:28:28.132302332 +0000
@@ -17646,6 +17646,14 @@
fi
;;
+ *-*-*-android*)
+ *-*-*-android*)
+ alpine_SSLDIR="/data/data/com.termux/files/usr/etc/tls"
+ alpine_SSLCERTS="$alpine_SSLDIR/certs"
+ alpine_SSLKEYS="$alpine_SSLDIR/private"