Remove gnupg1 (#2691)

Remove gnupg1
This commit is contained in:
Henrik Grimler 2018-07-29 21:33:27 +02:00 committed by Fredrik Fornwall
parent 308ee3b352
commit 24d1b3edcf
13 changed files with 29 additions and 50 deletions

View File

@ -2,7 +2,7 @@ TERMUX_PKG_HOMEPAGE=https://packages.debian.org/apt
TERMUX_PKG_DESCRIPTION="Front-end for the dpkg package manager"
TERMUX_PKG_DEPENDS="libcurl, liblzma, dpkg, gpgv, libc++, termux-exec"
TERMUX_PKG_VERSION=1.4.8
TERMUX_PKG_REVISION=5
TERMUX_PKG_REVISION=6
TERMUX_PKG_SHA256=767ad7d6efb64cde52faececb7d3c0bf49800b9fe06f3a5b0132ab4c01a5b8f8
TERMUX_PKG_SRCURL=http://ftp.debian.org/debian/pool/main/a/apt/apt_${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="

View File

@ -1,16 +1,25 @@
TERMUX_PKG_HOMEPAGE=https://www.gnupg.org/
TERMUX_PKG_DESCRIPTION="OpenPGP implementation for encrypting and signing data and communication"
TERMUX_PKG_VERSION=1.4.23
TERMUX_PKG_SHA256=c9462f17e651b6507848c08c430c791287cd75491f8b5a8b50c6ed46b12678ba
TERMUX_PKG_SRCURL=ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-${TERMUX_PKG_VERSION}.tar.bz2
# disable readline since gnupg is used in bootstrap, so nice to avoid readline+ncurses dependencies.
# ac_cv_sys_symbol_underscore=no needed for i686 build to avoid "undefined reference to `mpihelp_sub_n'" errors
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--disable-endian-check --without-readline ac_cv_sys_symbol_underscore=no"
# ac_cv_header_sys_shm_h is to avoid USE_SHM_COPROCESSING getting defined due to <sys/shm.h>,
# which it does on android-21 (but shmat(2) does not exist)
TERMUX_PKG_EXTRA_CONFIGURE_ARGS+=" ac_cv_header_sys_shm_h=no"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS+=" --disable-bzip2"
TERMUX_PKG_DESCRIPTION="Implementation of the OpenPGP standard for encrypting and signing data and communication"
TERMUX_PKG_VERSION=2.2.9
TERMUX_PKG_REVISION=1
TERMUX_PKG_SHA256=6278eaabffa1ebc9fa2ceb3dc53eea9a1505ab02a668a86dd6fec06951af2164
TERMUX_PKG_SRCURL=https://www.gnupg.org/ftp/gcrypt/gnupg/gnupg-${TERMUX_PKG_VERSION}.tar.bz2
TERMUX_PKG_DEPENDS="libassuan,libbz2,libgcrypt,libksba,libsqlite,libnpth,readline,pinentry,libgpg-error"
TERMUX_PKG_CONFLICTS="gnupg2 (<< 2.2.9-1)"
TERMUX_PKG_REPLACES="gnupg2 (<< 2.2.9-1)"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
--disable-ldap
--enable-sqlite
--enable-tofu
"
# Remove non-english help files and man pages shipped with the gnupg (1) package:
TERMUX_PKG_RM_AFTER_INSTALL="share/gnupg/help.*.txt share/man/man1/gpg-zip.1 share/man/man7/gnupg.7"
termux_step_pre_configure() {
CFLAGS+=" -D__LITTLE_ENDIAN__ -fheinous-gnu-extensions"
CPPFLAGS+=" -Ddn_skipname=__dn_skipname"
}
termux_step_post_make_install() {
cd $TERMUX_PREFIX/bin
ln -sf gpg gpg2
}

View File

@ -1,3 +1,3 @@
TERMUX_SUBPKG_INCLUDE="bin/dirmngr bin/dirmngr-client share/man/man8/dirmngr.8 share/man/man1/dirmngr-client.1"
TERMUX_SUBPKG_DESCRIPTION="Server for managing certificate revocation lists"
TERMUX_SUBPKG_DEPENDS="gnupg2, libgnutls, resolv-conf"
TERMUX_SUBPKG_DEPENDS="gnupg (>= 2.2.9-1), libgnutls, resolv-conf"

View File

@ -1,3 +0,0 @@
TERMUX_SUBPKG_INCLUDE="libexec/gnupg/gpgkeys_curl libexec/gnupg/gpgkeys_hkp"
TERMUX_SUBPKG_DESCRIPTION="GnuPG keyserver helper tools built with libcurl"
TERMUX_SUBPKG_DEPENDS="gnupg, libcurl"

View File

@ -1,11 +0,0 @@
--- gnupg-1.4.20/mpi/Makefile.in 2015-12-20 08:53:15.000000000 +0100
+++ src/mpi/Makefile.in 2016-04-19 19:33:55.167315560 +0200
@@ -713,7 +713,7 @@
# cancel the default rules used by libtool which do not really
# work and add one to cpp .S files
.S.o:
- $(CPP) $(INCLUDES) $(DEFS) $< | grep -v '^#' > _$*.s
+ $(CPP) $(INCLUDES) $(DEFS) -DPIC $< | grep -v '^#' > _$*.s
$(COMPILE) $(AM_CCASFLAGS) -c _$*.s
mv -f _$*.o $*.o

View File

@ -1,18 +0,0 @@
TERMUX_PKG_HOMEPAGE=https://www.gnupg.org/
TERMUX_PKG_DESCRIPTION="Implementation of the OpenPGP standard for encrypting and signing data and communication"
TERMUX_PKG_VERSION=2.2.9
TERMUX_PKG_SHA256=6278eaabffa1ebc9fa2ceb3dc53eea9a1505ab02a668a86dd6fec06951af2164
TERMUX_PKG_SRCURL=https://www.gnupg.org/ftp/gcrypt/gnupg/gnupg-${TERMUX_PKG_VERSION}.tar.bz2
TERMUX_PKG_DEPENDS="libassuan,libbz2,libgcrypt,libksba,libsqlite,libnpth,readline,pinentry,libgpg-error"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
--disable-ldap
--enable-gpg-is-gpg2
--enable-sqlite
--enable-tofu
"
# Remove non-english help files and man pages shipped with the gnupg (1) package:
TERMUX_PKG_RM_AFTER_INSTALL="share/gnupg/help.*.txt share/man/man1/gpg-zip.1 share/man/man7/gnupg.7"
termux_step_pre_configure() {
CPPFLAGS+=" -Ddn_skipname=__dn_skipname"
}

View File

@ -1,8 +1,9 @@
TERMUX_PKG_HOMEPAGE=https://www.gnupg.org/related_software/gpgme/
TERMUX_PKG_DESCRIPTION="Library designed to make access to GnuPG easier"
TERMUX_PKG_DEPENDS="gnupg2, libassuan, libgpg-error"
TERMUX_PKG_DEPENDS="gnupg (>= 2.2.9-1), libassuan, libgpg-error"
TERMUX_PKG_DEVPACKAGE_DEPENDS="libgpg-error-dev"
TERMUX_PKG_VERSION=1.11.1
TERMUX_PKG_REVISION=1
TERMUX_PKG_SHA256=2d1b111774d2e3dd26dcd7c251819ce4ef774ec5e566251eb9308fa7542fbd6f
TERMUX_PKG_SRCURL=ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${TERMUX_PKG_VERSION}.tar.bz2
# Use "--disable-gpg-test" to avoid "No rule to make target `../../src/libgpgme-pthread.la":

View File

@ -1,12 +1,13 @@
TERMUX_PKG_HOMEPAGE=https://www.passwordstore.org/
TERMUX_PKG_DESCRIPTION="Lightweight directory-based password manager"
TERMUX_PKG_VERSION=1.7.2
TERMUX_PKG_REVISION=1
TERMUX_PKG_SHA256=4768c5e1965c4d2aeb28818681e484fb105b6f46cbd75a97608615c4ec6980ea
TERMUX_PKG_SRCURL=https://git.zx2c4.com/password-store/snapshot/password-store-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_BUILD_IN_SRC=yes
# Depend on coreutils as pass uses [:graph:] when calling tr, which
# busybox tr does not support:
TERMUX_PKG_DEPENDS="bash, gnupg2, tree, coreutils"
TERMUX_PKG_DEPENDS="bash, gnupg (>= 2.2.9-1), tree, coreutils"
TERMUX_PKG_RECOMMENDS="git"
TERMUX_PKG_SUGGESTS="pass-otp"
TERMUX_PKG_PLATFORM_INDEPENDENT=yes

View File

@ -2,10 +2,10 @@ TERMUX_PKG_HOMEPAGE=https://www.tug.org/texlive/tlmgr.html
TERMUX_PKG_DESCRIPTION="TeX Lives package manager"
TERMUX_PKG_MAINTAINER="Henrik Grimler @Grimler91"
TERMUX_PKG_VERSION=20180414
TERMUX_PKG_REVISION=1
TERMUX_PKG_REVISION=2
TERMUX_PKG_SRCURL="ftp://ftp.tug.org/texlive/historic/${TERMUX_PKG_VERSION:0:4}/install-tl-unx.tar.gz"
TERMUX_PKG_SHA256="82c13110852af162c4c5ef1579fa2f4f51c2040850ec02fb7f97497da45eb446"
TERMUX_PKG_DEPENDS="perl, wget, gnupg2, xz-utils, texlive"
TERMUX_PKG_DEPENDS="perl, wget, gnupg (>= 2.2.9-1), xz-utils, texlive"
TERMUX_PKG_CONFFILES="share/texlive/tlpkg/texlive.tlpdb"
TERMUX_PKG_CONFLICTS="texlive (<< 20180414-1)"
TERMUX_PKG_PLATFORM_INDEPENDENT=yes