frida-server: update to 15.1.12
This commit is contained in:
parent
47110757dd
commit
25288dc7ef
@ -1,27 +1,5 @@
|
||||
--- ./Makefile.linux.mk.orig 2020-12-05 10:51:28.873352898 +0100
|
||||
+++ ./Makefile.linux.mk 2020-12-05 10:58:48.332580362 +0100
|
||||
@@ -213,6 +213,10 @@
|
||||
--prefix $(FRIDA)/build/frida-android-arm \
|
||||
--libdir $(FRIDA)/build/frida-android-arm/lib \
|
||||
$(frida_core_flags) \
|
||||
+ -Dhelper32=$(FRIDA)/build/tmp-android-x86/frida-core/src/frida-helper \
|
||||
+ -Dhelper64=$(FRIDA)/build/tmp-android-x86_64/frida-core/src/frida-helper \
|
||||
+ -Dagent32=$(FRIDA)/build/tmp-android-x86/frida-core/lib/agent/frida-agent.so \
|
||||
+ -Dagent64=$(FRIDA)/build/tmp-android-x86_64/frida-core/lib/agent/frida-agent.so \
|
||||
frida-core $$builddir || exit 1; \
|
||||
fi
|
||||
@touch $@
|
||||
@@ -241,6 +245,10 @@
|
||||
--prefix $(FRIDA)/build/frida_thin-$* \
|
||||
--libdir $(FRIDA)/build/frida_thin-$*/lib \
|
||||
$(frida_core_flags) \
|
||||
+ -Dhelper32=$(FRIDA)/build/tmp-android-arm/frida-core/src/frida-helper \
|
||||
+ -Dhelper64=$(FRIDA)/build/tmp-android-arm64/frida-core/src/frida-helper \
|
||||
+ -Dagent32=$(FRIDA)/build/tmp-android-arm/frida-core/lib/agent/frida-agent.so \
|
||||
+ -Dagent64=$(FRIDA)/build/tmp-android-arm64/frida-core/lib/agent/frida-agent.so \
|
||||
frida-core $$builddir || exit 1; \
|
||||
fi
|
||||
@touch $@
|
||||
@@ -301,6 +309,10 @@
|
||||
python-linux-x86_64-thin: build/tmp_thin-linux-x86_64/frida-$(PYTHON_NAME)/.frida-stamp ##@python Build Python bindings for Linux/x86-64 without cross-arch support
|
||||
python-linux-armhf: build/tmp_thin-linux-armhf/frida-$(PYTHON_NAME)/.frida-stamp ##@python Build Python bindings for Linux/armhf
|
||||
|
@ -2,11 +2,10 @@ TERMUX_PKG_HOMEPAGE=https://www.frida.re/
|
||||
TERMUX_PKG_DESCRIPTION="Dynamic instrumentation toolkit for developers, reverse-engineers, and security researchers"
|
||||
TERMUX_PKG_LICENSE="wxWindows"
|
||||
TERMUX_PKG_MAINTAINER="Henrik Grimler @Grimler91"
|
||||
_MAJOR_VERSION=14
|
||||
_MINOR_VERSION=2
|
||||
_MICRO_VERSION=14
|
||||
_MAJOR_VERSION=15
|
||||
_MINOR_VERSION=1
|
||||
_MICRO_VERSION=12
|
||||
TERMUX_PKG_VERSION=${_MAJOR_VERSION}.${_MINOR_VERSION}.${_MICRO_VERSION}
|
||||
TERMUX_PKG_REVISION=2
|
||||
TERMUX_PKG_GIT_BRANCH=$TERMUX_PKG_VERSION
|
||||
TERMUX_PKG_SRCURL=https://github.com/frida/frida.git
|
||||
TERMUX_PKG_DEPENDS="libiconv, python"
|
||||
@ -26,10 +25,10 @@ termux_step_pre_configure () {
|
||||
}
|
||||
|
||||
termux_step_host_build () {
|
||||
local node_version=14.6.0
|
||||
local node_version=14.18.1
|
||||
termux_download https://nodejs.org/dist/v${node_version}/node-v${node_version}-linux-x64.tar.xz \
|
||||
${TERMUX_PKG_CACHEDIR}/node-v${node_version}-linux-x64.tar.xz \
|
||||
b8a39b2dac8e200e96586356c5525d20b0b43dba8bf9f7eb4e8c2d5366be2bb2
|
||||
ad1e3baa1aee8028b43206da3b2be9b8867cb598b4318bc88a0ae4518cc062a2
|
||||
tar -xf ${TERMUX_PKG_CACHEDIR}/node-v${node_version}-linux-x64.tar.xz --strip-components=1
|
||||
}
|
||||
|
||||
|
@ -1,11 +1,11 @@
|
||||
--- ./releng/setup-env.sh.orig 2021-03-21 14:30:27.958066126 +0000
|
||||
+++ ./releng/setup-env.sh 2021-03-28 13:17:51.665477424 +0000
|
||||
@@ -106,7 +106,7 @@
|
||||
--- ./releng/setup-env.sh.orig 2021-12-05 13:14:56.373457925 +0100
|
||||
+++ ./releng/setup-env.sh 2021-12-05 13:16:27.716458982 +0100
|
||||
@@ -123,7 +123,7 @@
|
||||
fi
|
||||
|
||||
if [ "$host_os" == "android" ]; then
|
||||
- ndk_required=22
|
||||
+ ndk_required=21
|
||||
- ndk_required=24
|
||||
+ ndk_required=23
|
||||
if [ -n "$ANDROID_NDK_ROOT" ]; then
|
||||
if [ -f "$ANDROID_NDK_ROOT/source.properties" ]; then
|
||||
ndk_installed_version=$(grep Pkg.Revision "$ANDROID_NDK_ROOT/source.properties" | awk '{ split($NF, v, "."); print v[1]; }')
|
||||
|
@ -1,33 +1,38 @@
|
||||
--- ./releng/setup-env.sh.orig 2021-03-21 14:30:27.958066126 +0000
|
||||
+++ ./releng/setup-env.sh 2021-03-28 13:17:51.665477424 +0000
|
||||
@@ -628,26 +628,26 @@
|
||||
host_cflags=""
|
||||
--- ./releng/setup-env.sh.orig 2021-12-05 14:17:02.109846250 +0100
|
||||
+++ ./releng/setup-env.sh 2021-12-05 14:21:05.179490094 +0100
|
||||
@@ -668,7 +668,7 @@
|
||||
host_cxxlibs="c++_static c++abi"
|
||||
case $host_arch in
|
||||
x86)
|
||||
- android_api=18
|
||||
- android_api=19
|
||||
+ android_api=24
|
||||
host_compiler_triplet="i686-linux-android"
|
||||
host_arch_flags="-march=pentium4"
|
||||
host_cflags="-mfpmath=sse -mstackrealign"
|
||||
host_ldflags="-fuse-ld=gold"
|
||||
android_abi="x86"
|
||||
android_target="i686-none-linux-android${android_api}"
|
||||
android_clang_arch="i386"
|
||||
@@ -679,7 +679,7 @@
|
||||
host_cxxlibs="$host_cxxlibs android_support"
|
||||
;;
|
||||
x86_64)
|
||||
- android_api=21
|
||||
+ android_api=24
|
||||
host_compiler_triplet="x86_64-linux-android"
|
||||
host_ldflags="-fuse-ld=gold -Wl,--icf=all"
|
||||
android_abi="x86_64"
|
||||
android_target="x86_64-none-linux-android${android_api}"
|
||||
android_clang_arch="x86_64"
|
||||
@@ -687,7 +687,7 @@
|
||||
host_ldflags=""
|
||||
;;
|
||||
arm)
|
||||
- android_api=18
|
||||
- android_api=19
|
||||
+ android_api=24
|
||||
host_compiler_triplet="armv7a-linux-androideabi"
|
||||
host_tooltriplet="arm-linux-androideabi"
|
||||
host_arch_flags="-march=armv7-a -mfloat-abi=softfp -mfpu=vfpv3-d16"
|
||||
host_ldflags="-fuse-ld=gold -Wl,--icf=all -Wl,--fix-cortex-a8"
|
||||
android_abi="armeabi-v7a"
|
||||
android_target="armv7-none-linux-androideabi${android_api}"
|
||||
android_clang_arch="arm"
|
||||
@@ -698,7 +698,7 @@
|
||||
host_cxxlibs="$host_cxxlibs android_support"
|
||||
;;
|
||||
arm64)
|
||||
- android_api=21
|
||||
+ android_api=24
|
||||
host_compiler_triplet="aarch64-linux-android"
|
||||
host_ldflags="-fuse-ld=gold -Wl,--icf=all"
|
||||
;;
|
||||
android_abi="arm64-v8a"
|
||||
android_target="aarch64-none-linux-android${android_api}"
|
||||
android_clang_arch="aarch64"
|
||||
|
Loading…
Reference in New Issue
Block a user