curseofwar: update to 1.3.0
This commit is contained in:
parent
d93272f683
commit
25371fdac1
16
packages/curseofwar/CMakeLists.txt.patch
Normal file
16
packages/curseofwar/CMakeLists.txt.patch
Normal file
@ -0,0 +1,16 @@
|
||||
Pretending that the source is c++ instead of c is apparently needed to make visual studio happy: https://github.com/a-nikolaev/curseofwar/commit/ca752d9af5a7616ef9faca6cd79c3de6f5a07aa9
|
||||
|
||||
clang gives warnings that the source is actually c though, and we get lots of:
|
||||
warning: ISO C++11 does not allow conversion from string literal to 'char *'
|
||||
--- ../CMakeLists.txt.orig 2020-08-16 19:49:42.870095140 +0200
|
||||
+++ ./CMakeLists.txt 2020-08-16 19:50:02.580234051 +0200
|
||||
@@ -32,8 +32,7 @@
|
||||
client.c
|
||||
server.c)
|
||||
|
||||
-SET (SOURCES ${SOURCE_COMMON} ${SOURCE_SDL} ${SOURCE_NCURSES} ${SOURCE_NETWORK})
|
||||
-set_source_files_properties( ${SOURCES} PROPERTIES LANGUAGE "CXX" )
|
||||
+SET (SOURCES ${SOURCE_COMMON} ${SOURCE_SDL} ${SOURCE_NCURSES} ${SOURCE_NETWORK})
|
||||
|
||||
if(WIN32)
|
||||
# Windows includes the math lib by default, no need to add them
|
@ -1,10 +1,9 @@
|
||||
TERMUX_PKG_HOMEPAGE=http://a-nikolaev.github.io/curseofwar/
|
||||
TERMUX_PKG_DESCRIPTION="Fast-paced action strategy game focusing on high-level strategic planning"
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_VERSION=1.2.0
|
||||
TERMUX_PKG_REVISION=3
|
||||
TERMUX_PKG_VERSION=1.3.0
|
||||
TERMUX_PKG_SRCURL=https://github.com/a-nikolaev/curseofwar/archive/v${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=91b7781e26341faa6b6999b6baf6e74ef532fa94303ab6a2bf9ff6d614a3f670
|
||||
TERMUX_PKG_SHA256=2a90204d95a9f29a0e5923f43e65188209dc8be9d9eb93576404e3f79b8a652b
|
||||
TERMUX_PKG_DEPENDS="libc++, ncurses"
|
||||
|
||||
termux_step_make_install () {
|
||||
|
19
packages/curseofwar/path.c.patch
Normal file
19
packages/curseofwar/path.c.patch
Normal file
@ -0,0 +1,19 @@
|
||||
--- ../path.c.orig 2020-08-16 19:40:30.098928495 +0200
|
||||
+++ ./path.c 2020-08-16 19:41:56.786161977 +0200
|
||||
@@ -77,11 +77,11 @@
|
||||
path[1] = concat(s, suffix);
|
||||
free(s);
|
||||
path[2] = concat(getenv("HOME"), "/.curseofwar/");
|
||||
- path[3] = strdup("/usr/local/share/curseofwar/");
|
||||
- path[4] = strdup("/usr/share/curseofwar/");
|
||||
- path[5] = strdup("/usr/share/curseofwar-sdl/");
|
||||
- path[6] = strdup("/usr/share/curseofwar-common/");
|
||||
- path[7] = strdup(INSTALL_DATA);
|
||||
+ path[3] = strdup("@TERMUX_PREFIX@/local/share/curseofwar/");
|
||||
+ path[4] = strdup("@TERMUX_PREFIX@/share/curseofwar/");
|
||||
+ path[5] = strdup("@TERMUX_PREFIX@/share/curseofwar-sdl/");
|
||||
+ path[6] = strdup("@TERMUX_PREFIX@/share/curseofwar-common/");
|
||||
+ path[7] = strdup("@TERMUX_PREFIX@/share/curseofwar/");
|
||||
#else
|
||||
int dirs_num = 1;
|
||||
char **path = (char**) malloc(sizeof(char*) * (dirs_num + 1));
|
Loading…
x
Reference in New Issue
Block a user