mpd: Disable building against gcrypt

This commit is contained in:
Fredrik Fornwall 2019-01-07 02:04:31 +01:00
parent 4c0686af04
commit 2825249b46
2 changed files with 10 additions and 1 deletions

View File

@ -5,7 +5,7 @@ TERMUX_PKG_REVISION=1
TERMUX_PKG_SHA256=f694b5d9b39c12c196e51fbcde82e99c62bb08bdec7a7302095251f3e4357a15
TERMUX_PKG_SRCURL=https://github.com/MusicPlayerDaemon/MPD/archive/v$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_DEPENDS="libcurl, libid3tag, libopus, libpulseaudio, libmpdclient, openal-soft, libvorbis, libsqlite, ffmpeg, libmp3lame, libbz2"
TERMUX_PKG_BUILD_DEPENDS="boost, libgcrypt"
TERMUX_PKG_BUILD_DEPENDS="boost"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-Dalsa=disabled
-Dao=disabled

View File

@ -0,0 +1,9 @@
diff -u -r ../MPD-0.21.3/src/lib/gcrypt/meson.build ./src/lib/gcrypt/meson.build
--- ../MPD-0.21.3/src/lib/gcrypt/meson.build 2018-11-16 12:27:58.000000000 +0000
+++ ./src/lib/gcrypt/meson.build 2019-01-06 23:35:51.108609898 +0000
@@ -1,4 +1,4 @@
-gcrypt_dep = c_compiler.find_library('gcrypt', required: get_option('qobuz'))
+gcrypt_dep = c_compiler.find_library('gcrypt_disabled', required: get_option('qobuz'))
if not gcrypt_dep.found()
subdir_done()
endif