grep: update to 3.7
This commit is contained in:
parent
2faeb8dde1
commit
2cf638fc7e
@ -2,8 +2,8 @@ TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/grep/
|
|||||||
TERMUX_PKG_DESCRIPTION="Command which searches one or more input files for lines containing a match to a specified pattern"
|
TERMUX_PKG_DESCRIPTION="Command which searches one or more input files for lines containing a match to a specified pattern"
|
||||||
TERMUX_PKG_LICENSE="GPL-3.0"
|
TERMUX_PKG_LICENSE="GPL-3.0"
|
||||||
TERMUX_PKG_MAINTAINER="@termux"
|
TERMUX_PKG_MAINTAINER="@termux"
|
||||||
TERMUX_PKG_VERSION=3.6
|
TERMUX_PKG_VERSION=3.7
|
||||||
TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/grep/grep-${TERMUX_PKG_VERSION}.tar.xz
|
TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/grep/grep-${TERMUX_PKG_VERSION}.tar.xz
|
||||||
TERMUX_PKG_SHA256=667e15e8afe189e93f9f21a7cd3a7b3f776202f417330b248c2ad4f997d9373e
|
TERMUX_PKG_SHA256=5c10da312460aec721984d5d83246d24520ec438dd48d7ab5a05dbc0d6d6823c
|
||||||
TERMUX_PKG_DEPENDS="libandroid-support, pcre"
|
TERMUX_PKG_DEPENDS="libandroid-support, pcre"
|
||||||
TERMUX_PKG_ESSENTIAL=true
|
TERMUX_PKG_ESSENTIAL=true
|
||||||
|
76
packages/grep/gnulib.patch
Normal file
76
packages/grep/gnulib.patch
Normal file
@ -0,0 +1,76 @@
|
|||||||
|
diff --git a/lib/Makefile.in b/lib/Makefile.in
|
||||||
|
index a39102957..b3c7e6d28 100644
|
||||||
|
--- a/lib/Makefile.in
|
||||||
|
+++ b/lib/Makefile.in
|
||||||
|
@@ -3452,6 +3452,7 @@ string.h: string.in.h $(top_builddir)/config.status $(CXXDEFS_H) $(ARG_NONNULL_H
|
||||||
|
-e 's|@''REPLACE_FFSLL''@|$(REPLACE_FFSLL)|g' \
|
||||||
|
-e 's|@''REPLACE_MEMCHR''@|$(REPLACE_MEMCHR)|g' \
|
||||||
|
-e 's|@''REPLACE_MEMMEM''@|$(REPLACE_MEMMEM)|g' \
|
||||||
|
+ -e 's|@''REPLACE_FREE''@|$(REPLACE_FREE)|g' \
|
||||||
|
-e 's|@''REPLACE_STPNCPY''@|$(REPLACE_STPNCPY)|g' \
|
||||||
|
-e 's|@''REPLACE_STRCHRNUL''@|$(REPLACE_STRCHRNUL)|g' \
|
||||||
|
-e 's|@''REPLACE_STRDUP''@|$(REPLACE_STRDUP)|g' \
|
||||||
|
@@ -3948,6 +3949,7 @@ wchar.h: wchar.in.h $(top_builddir)/config.status $(CXXDEFS_H) $(ARG_NONNULL_H)
|
||||||
|
sed -e 's|@''REPLACE_MBSTATE_T''@|$(REPLACE_MBSTATE_T)|g' \
|
||||||
|
-e 's|@''REPLACE_BTOWC''@|$(REPLACE_BTOWC)|g' \
|
||||||
|
-e 's|@''REPLACE_WCTOB''@|$(REPLACE_WCTOB)|g' \
|
||||||
|
+ -e 's|@''REPLACE_FREE''@|$(REPLACE_FREE)|g' \
|
||||||
|
-e 's|@''REPLACE_MBSINIT''@|$(REPLACE_MBSINIT)|g' \
|
||||||
|
-e 's|@''REPLACE_MBRTOWC''@|$(REPLACE_MBRTOWC)|g' \
|
||||||
|
-e 's|@''REPLACE_MBRLEN''@|$(REPLACE_MBRLEN)|g' \
|
||||||
|
diff --git a/lib/string.in.h b/lib/string.in.h
|
||||||
|
index fa2e40c25..8977153c8 100644
|
||||||
|
--- a/lib/string.in.h
|
||||||
|
+++ b/lib/string.in.h
|
||||||
|
@@ -47,9 +47,6 @@
|
||||||
|
/* NetBSD 5.0 mis-defines NULL. */
|
||||||
|
#include <stddef.h>
|
||||||
|
|
||||||
|
-/* Get free(). */
|
||||||
|
-#include <stdlib.h>
|
||||||
|
-
|
||||||
|
/* MirBSD defines mbslen as a macro. */
|
||||||
|
#if @GNULIB_MBSLEN@ && defined __MirBSD__
|
||||||
|
# include <wchar.h>
|
||||||
|
@@ -86,6 +83,13 @@
|
||||||
|
|
||||||
|
/* The definition of _GL_WARN_ON_USE is copied here. */
|
||||||
|
|
||||||
|
+/* Declare 'free' if needed for _GL_ATTRIBUTE_DEALLOC_FREE. */
|
||||||
|
+#if (@REPLACE_FREE@ && !defined free \
|
||||||
|
+ && !(defined __cplusplus && defined GNULIB_NAMESPACE))
|
||||||
|
+_GL_EXTERN_C void free (void *);
|
||||||
|
+# define free rpl_free
|
||||||
|
+#endif
|
||||||
|
+_GL_EXTERN_C void free (void *);
|
||||||
|
|
||||||
|
/* Clear a block of memory. The compiler will not delete a call to
|
||||||
|
this function, even if the block is dead after the call. */
|
||||||
|
diff --git a/lib/wchar.in.h b/lib/wchar.in.h
|
||||||
|
index be5d36c8d..acb9d4ea6 100644
|
||||||
|
--- a/lib/wchar.in.h
|
||||||
|
+++ b/lib/wchar.in.h
|
||||||
|
@@ -72,9 +72,6 @@
|
||||||
|
# include <stddef.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-/* Get free(). */
|
||||||
|
-#include <stdlib.h>
|
||||||
|
-
|
||||||
|
/* Include the original <wchar.h> if it exists.
|
||||||
|
Some builds of uClibc lack it. */
|
||||||
|
/* The include_next requires a split double-inclusion guard. */
|
||||||
|
@@ -149,6 +146,13 @@ typedef int rpl_mbstate_t;
|
||||||
|
# endif
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+/* Declare 'free' if needed for _GL_ATTRIBUTE_DEALLOC_FREE. */
|
||||||
|
+#if (@REPLACE_FREE@ && !defined free \
|
||||||
|
+ && !(defined __cplusplus && defined GNULIB_NAMESPACE))
|
||||||
|
+_GL_EXTERN_C void free (void *);
|
||||||
|
+# define free rpl_free
|
||||||
|
+#endif
|
||||||
|
+_GL_EXTERN_C void free (void *);
|
||||||
|
|
||||||
|
/* Convert a single-byte character to a wide character. */
|
||||||
|
#if @GNULIB_BTOWC@
|
Loading…
Reference in New Issue
Block a user