new package: stuntman
This commit is contained in:
parent
2d929a7117
commit
318f25c7f7
16
packages/stuntman/build.sh
Normal file
16
packages/stuntman/build.sh
Normal file
@ -0,0 +1,16 @@
|
||||
TERMUX_PKG_HOMEPAGE=http://www.stunprotocol.org/
|
||||
TERMUX_PKG_DESCRIPTION="An open source STUN server"
|
||||
TERMUX_PKG_LICENSE="Apache-2.0"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=1.2.16
|
||||
TERMUX_PKG_SRCURL=http://www.stunprotocol.org/stunserver-${TERMUX_PKG_VERSION}.tgz
|
||||
TERMUX_PKG_SHA256=4479e1ae070651dfc4836a998267c7ac2fba4f011abcfdca3b8ccd7736d4fd26
|
||||
TERMUX_PKG_DEPENDS="libc++, openssl"
|
||||
TERMUX_PKG_BUILD_DEPENDS="boost"
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
TERMUX_PKG_EXTRA_MAKE_ARGS="T=" # In case if environment variable `T` is defined
|
||||
|
||||
termux_step_make_install() {
|
||||
install -Dm700 -t $TERMUX_PREFIX/bin "$TERMUX_PKG_BUILDDIR/stunclient"
|
||||
install -Dm700 -t $TERMUX_PREFIX/bin "$TERMUX_PKG_BUILDDIR/stunserver"
|
||||
}
|
11
packages/stuntman/common-commonincludes.hpp.patch
Normal file
11
packages/stuntman/common-commonincludes.hpp.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/common/commonincludes.hpp
|
||||
+++ b/common/commonincludes.hpp
|
||||
@@ -46,7 +46,7 @@
|
||||
#include <net/if.h>
|
||||
#include <stdarg.h>
|
||||
#include <math.h>
|
||||
-#include <sys/termios.h>
|
||||
+#include <termios.h>
|
||||
|
||||
#include <boost/shared_ptr.hpp>
|
||||
#include <boost/scoped_array.hpp>
|
11
packages/stuntman/testcode-Makefile.patch
Normal file
11
packages/stuntman/testcode-Makefile.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/testcode/Makefile
|
||||
+++ b/testcode/Makefile
|
||||
@@ -5,7 +5,7 @@
|
||||
|
||||
INCLUDES := $(BOOST_INCLUDE) $(OPENSSL_INCLUDE) -I../common -I../stuncore -I../networkutils
|
||||
LIB_PATH := -L../networkutils -L../stuncore -L../common
|
||||
-LIBS := -lnetworkutils -lstuncore -lcommon -lpthread
|
||||
+LIBS := -lnetworkutils -lstuncore -lcommon
|
||||
|
||||
|
||||
all: $(PROJECT_TARGET)
|
Loading…
Reference in New Issue
Block a user