moria: update CMakeLists.txt.patch
This commit is contained in:
parent
a2385395e2
commit
329eb828a0
@ -1,6 +1,7 @@
|
||||
--- ../CMakeLists.txt.orig 2019-04-28 08:12:04.338201376 +0200
|
||||
+++ ./CMakeLists.txt 2019-04-28 08:43:34.081455683 +0200
|
||||
@@ -156,16 +156,12 @@
|
||||
diff -uNr umoria-5.7.11/CMakeLists.txt umoria-5.7.11.mod/CMakeLists.txt
|
||||
--- umoria-5.7.11/CMakeLists.txt 2020-02-26 22:59:33.000000000 +0200
|
||||
+++ umoria-5.7.11.mod/CMakeLists.txt 2020-03-20 15:49:55.823149195 +0200
|
||||
@@ -161,11 +161,10 @@
|
||||
#
|
||||
# Set up the install paths and files
|
||||
#
|
||||
@ -8,17 +9,12 @@
|
||||
+option(build_dir "Directory for build files" "umoria")
|
||||
set(data_dir "${build_dir}/data")
|
||||
|
||||
file(MAKE_DIRECTORY ${build_dir})
|
||||
file(MAKE_DIRECTORY ${data_dir})
|
||||
|
||||
-set(CMAKE_INSTALL_PREFIX ${CMAKE_BINARY_DIR})
|
||||
-set(EXECUTABLE_OUTPUT_PATH ${build_dir})
|
||||
-set(RUNTIME_OUTPUT_DIRECTORY ${build_dir})
|
||||
-
|
||||
|
||||
# Core game data files
|
||||
set(
|
||||
data_files
|
||||
@@ -241,7 +237,7 @@
|
||||
@@ -237,7 +236,7 @@
|
||||
set(resources ${data_files} ${support_files})
|
||||
|
||||
# Also add resources to the target so they are visible in the IDE
|
||||
@ -27,26 +23,13 @@
|
||||
|
||||
|
||||
# This is horrible, but needed bacause `find_package()` doesn't use the
|
||||
@@ -265,7 +261,20 @@
|
||||
@@ -262,4 +261,8 @@
|
||||
endif ()
|
||||
|
||||
include_directories(${CURSES_INCLUDE_DIR})
|
||||
-target_link_libraries(umoria ${CURSES_LIBRARIES})
|
||||
+target_link_libraries(moria ${CURSES_LIBRARIES})
|
||||
|
||||
# Build and install the umoria binary
|
||||
-install(TARGETS umoria DESTINATION ${build_dir})
|
||||
+
|
||||
+install(TARGETS moria DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
|
||||
+install(FILES docs/manual.md docs/faq.md LICENSE DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/moria/)
|
||||
+install(FILES
|
||||
+ data/death_royal.txt
|
||||
+ data/death_tomb.txt
|
||||
+ data/help.txt
|
||||
+ data/help_wizard.txt
|
||||
+ data/rl_help.txt
|
||||
+ data/rl_help_wizard.txt
|
||||
+ data/scores.dat
|
||||
+ data/splash.txt
|
||||
+ data/welcome.txt
|
||||
+ data/versions.txt
|
||||
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/games/moria/)
|
||||
+INSTALL(DIRECTORY ${build_dir}/data DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/games/moria/ FILES_MATCHING PATTERN "*.txt")
|
||||
|
Loading…
Reference in New Issue
Block a user