libgrpc: update to 1.22.0
This commit is contained in:
parent
4778a36e54
commit
3543d2ab69
@ -2,8 +2,7 @@ TERMUX_PKG_HOMEPAGE=https://grpc.io/
|
||||
TERMUX_PKG_DESCRIPTION="High performance, open source, general RPC framework that puts mobile and HTTP/2 first"
|
||||
TERMUX_PKG_LICENSE="Apache-2.0"
|
||||
TERMUX_PKG_MAINTAINER="Vishal Biswas @vishalbiswas"
|
||||
TERMUX_PKG_VERSION=1.20.1
|
||||
TERMUX_PKG_REVISION=3
|
||||
TERMUX_PKG_VERSION=1.22.0
|
||||
TERMUX_PKG_DEPENDS="libc++, openssl, protobuf, c-ares, zlib"
|
||||
TERMUX_PKG_BUILD_DEPENDS="libprotobuf"
|
||||
TERMUX_PKG_HOSTBUILD=true
|
||||
|
44
packages/libgrpc/fix-arg-list-too-long.patch.beforehostbuild
Normal file
44
packages/libgrpc/fix-arg-list-too-long.patch.beforehostbuild
Normal file
@ -0,0 +1,44 @@
|
||||
--- a/Makefile 2018-06-26 11:07:45.948160976 +0200
|
||||
+++ b/Makefile 2019-06-26 11:04:25.798966336 +0200
|
||||
@@ -2820,13 +2820,15 @@
|
||||
|
||||
install-headers_c:
|
||||
$(E) "[INSTALL] Installing public C headers"
|
||||
- $(Q) $(foreach h, $(PUBLIC_HEADERS_C), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
|
||||
- $(Q) $(foreach h, $(PUBLIC_HEADERS_C), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
|
||||
+ $(Q) for h in $(PUBLIC_HEADERS_C); do \
|
||||
+ $(INSTALL) -D $$h $(prefix)/$$h ; \
|
||||
+ done
|
||||
|
||||
install-headers_cxx:
|
||||
$(E) "[INSTALL] Installing public C++ headers"
|
||||
- $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
|
||||
- $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
|
||||
+ $(Q) for h in $(PUBLIC_HEADERS_CXX); do \
|
||||
+ $(INSTALL) -D $$h $(prefix)/$$h ; \
|
||||
+ done
|
||||
|
||||
install-static: install-static_c install-static_cxx
|
||||
|
||||
--- a/templates/Makefile.template 2019-06-26 12:38:36.777292299 +0200
|
||||
+++ b/templates/Makefile.template 2019-06-26 12:48:35.668550020 +0200
|
||||
@@ -1302,13 +1302,15 @@
|
||||
|
||||
install-headers_c:
|
||||
$(E) "[INSTALL] Installing public C headers"
|
||||
- $(Q) $(foreach h, $(PUBLIC_HEADERS_C), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
|
||||
- $(Q) $(foreach h, $(PUBLIC_HEADERS_C), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
|
||||
+ $(Q) for h in $(PUBLIC_HEADERS_C); do \
|
||||
+ $(INSTALL) -D $$h $(prefix)/$$h ; \
|
||||
+ done
|
||||
|
||||
install-headers_cxx:
|
||||
$(E) "[INSTALL] Installing public C++ headers"
|
||||
- $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
|
||||
- $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
|
||||
+ $(Q) for h in $(PUBLIC_HEADERS_CXX); do \
|
||||
+ $(INSTALL) -D $$h $(prefix)/$$h ; \
|
||||
+ done
|
||||
|
||||
install-static: install-static_c install-static_cxx
|
||||
|
Loading…
Reference in New Issue
Block a user