radare2: Update from 3.2.1 to 3.3.0

This commit is contained in:
Fredrik Fornwall 2019-03-02 00:38:47 +01:00
parent 03dd805679
commit 3580901ab7
3 changed files with 14 additions and 24 deletions

View File

@ -1,9 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://rada.re
TERMUX_PKG_DESCRIPTION="Advanced Hexadecimal Editor"
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_VERSION=3.2.1
TERMUX_PKG_REVISION=1
TERMUX_PKG_SHA256=a4d0c1b3a3dfd810749578227940b8ea77e517d2c4d284c9687e49224a272796
TERMUX_PKG_VERSION=3.3.0
TERMUX_PKG_SHA256=3c092bdf8676d7d49537926258c50557bca98d7d669babfed6113ff82c403bcb
TERMUX_PKG_SRCURL=https://github.com/radare/radare2/archive/$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_DEPENDS="libuv"
TERMUX_PKG_BUILD_IN_SRC="yes"

View File

@ -1,21 +1,23 @@
diff -u -r ../radare2-2.6.0/libr/core/cconfig.c ./libr/core/cconfig.c
--- ../radare2-2.6.0/libr/core/cconfig.c 2018-05-21 03:18:13.000000000 +0200
+++ ./libr/core/cconfig.c 2018-05-22 16:08:13.832239788 +0200
@@ -2649,12 +2649,8 @@
diff -u -r ../radare2-3.3.0/libr/core/cconfig.c ./libr/core/cconfig.c
--- ../radare2-3.3.0/libr/core/cconfig.c 2019-02-19 12:35:24.000000000 +0000
+++ ./libr/core/cconfig.c 2019-03-01 23:31:17.730684566 +0000
@@ -2961,14 +2961,10 @@
free (path);
}
SETCB ("dir.source", "", &cb_dirsrc, "Path to find source files");
- SETPREF ("dir.types", "/usr/include", "Default path to look for cparse type files");
+ SETPREF ("dir.types", "@TERMUX_PREFIX@/usr/include", "Default path to look for cparse type files");
SETCB ("dir.home", r_sys_getenv (R_SYS_HOME), &cb_dirhome, "Path for the home directory");
SETCB ("dir.tmp", r_sys_getenv (R_SYS_TMP), &cb_dirtmp, "Path of the tmp directory");
-#if __ANDROID__
- SETPREF ("dir.projects", "/data/data/org.radare.radare2installer/radare2/projects", "Default path for projects");
-#else
+ SETPREF ("dir.types", "@TERMUX_PREFIX@/include", "Default path to look for cparse type files");
SETPREF ("dir.projects", R_JOIN_2_PATHS ("~", R2_HOME_PROJECTS), "Default path for projects");
-#endif
SETCB ("dir.zigns", R_JOIN_2_PATHS ("~", R2_HOME_ZIGNS), &cb_dirzigns, "Default path for zignatures (see zo command)");
SETPREF ("stack.reg", "SP", "Which register to use as stack pointer in the visual debug");
SETPREF ("stack.bytes", "true", "Show bytes instead of words in stack");
SETPREF ("stack.anotated", "false", "Show anotated hexdump in visual debug");
@@ -2773,6 +2769,9 @@
@@ -3099,6 +3095,9 @@
#if __WINDOWS__
r_config_set (cfg, "http.browser", "start");
#else
@ -25,7 +27,7 @@ diff -u -r ../radare2-2.6.0/libr/core/cconfig.c ./libr/core/cconfig.c
if (r_file_exists ("/usr/bin/openURL")) { // iOS ericautils
r_config_set (cfg, "http.browser", "/usr/bin/openURL");
} else if (r_file_exists ("/system/bin/toolbox")) {
@@ -2785,16 +2784,13 @@
@@ -3111,16 +3110,13 @@
} else {
r_config_set (cfg, "http.browser", "firefox");
}
@ -43,3 +45,5 @@ diff -u -r ../radare2-2.6.0/libr/core/cconfig.c ./libr/core/cconfig.c
SETPREF ("http.port", "9090", "HTTP server port");
SETPREF ("http.maxport", "9999", "Last HTTP server port");
SETPREF ("http.ui", "m", "Default webui (enyo, m, p, t)");
Only in ./libr/core: cconfig.c.orig
Only in ./libr/core: cconfig.c.rej

View File

@ -1,13 +0,0 @@
--- radare2-3.2.1_2/shlr/Makefile
+++ radare2-3.2.1/shlr/Makefile
@@ -25,8 +25,8 @@
CS_URL=$(GIT_PREFIX)github.com/aquynh/capstone.git
CS_UPD=20181224
# NOTE: when you update CS_TIP or CS_BRA, also update them in shlr/meson.build
-CS_BRA=v4.1
-CS_TIP=0ff8220adef16a942697afd245afc5ab0f70cbf8
+CS_BRA=master
+CS_TIP=58a80a93f995c23a8681dcc38dccfc6bab9cd7a4
# REVERT THIS COMMIT BECAUSE ITS WRONG
CS_REV=
CS_PATCHES=1