gettext: update to 0.20.1

This commit is contained in:
Leonid Pliushch 2019-05-21 15:13:35 +03:00
parent cd9063ab5e
commit 3649225748
3 changed files with 26 additions and 25 deletions

View File

@ -1,12 +1,11 @@
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/gettext/
TERMUX_PKG_DESCRIPTION="GNU Internationalization utilities"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_VERSION=0.19.8.1
TERMUX_PKG_REVISION=4
TERMUX_PKG_SHA256=105556dbc5c3fbbc2aa0edb46d22d055748b6f5c7cd7a8d99f8e7eb84e938be4
TERMUX_PKG_VERSION=0.20.1
TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/gettext/gettext-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_BUILD_IN_SRC=yes
TERMUX_PKG_SHA256=53f02fbbec9e798b0faaf7c73272f83608e835c6288dd58be6c9bb54624a3800
TERMUX_PKG_DEPENDS="libiconv, pcre, liblzma, libxml2, libcroco, ncurses, libunistring, zlib"
TERMUX_PKG_BUILD_IN_SRC=yes
termux_step_pre_configure() {
autoreconf

View File

@ -1,15 +1,8 @@
--- ../cache/gettext-0.19.8/gettext-tools/gnulib-lib/Makefile.am 2016-01-20 02:38:26.000000000 +0000
+++ ./gettext-tools/gnulib-lib/Makefile.am 2017-02-24 21:24:59.916938343 +0000
@@ -58,7 +58,6 @@
# Rules generated and collected by gnulib-tool.
include Makefile.gnulib
-# Which classes to export from the shared library.
MOOPPFLAGS += --dllexport=styled_ostream
# OS/2 does not support a DLL name longer than 8 characters.
@@ -67,10 +66,11 @@
endif
diff -uNr gettext-0.20.1/gettext-tools/gnulib-lib/Makefile.am gettext-0.20.1.mod/gettext-tools/gnulib-lib/Makefile.am
--- gettext-0.20.1/gettext-tools/gnulib-lib/Makefile.am 2019-04-11 12:22:44.000000000 +0300
+++ gettext-0.20.1.mod/gettext-tools/gnulib-lib/Makefile.am 2019-05-21 15:02:52.740488355 +0300
@@ -73,10 +73,11 @@
RELOCATABLE_LIBRARY_PATH = $(libdir)
# Linking with C++ libraries is needed _only_ on mingw and Cygwin.
+# .. termux edit because i can't be bothered fixing it properly.

View File

@ -1,11 +1,20 @@
--- ../cache/gettext-0.19.8/gettext-tools/src/msginit.c 2016-05-30 09:12:33.000000000 +0000
+++ ./gettext-tools/src/msginit.c 2017-02-23 06:45:14.705803371 +0000
@@ -1073,7 +1073,7 @@
diff -uNr gettext-0.20.1/gettext-tools/src/msginit.c gettext-0.20.1.mod/gettext-tools/src/msginit.c
--- gettext-0.20.1/gettext-tools/src/msginit.c 2019-05-12 00:11:31.000000000 +0300
+++ gettext-0.20.1.mod/gettext-tools/src/msginit.c 2019-05-21 15:05:49.363213216 +0300
@@ -1136,6 +1136,7 @@
static const char *
get_user_fullname ()
{
+#ifndef __ANDROID__
#if HAVE_PWD_H
struct passwd *pwd;
pwd = get_user_pwd ();
-#if HAVE_PWD_H
+#ifndef __ANDROID__
if (pwd != NULL)
{
const char *fullname;
@@ -1159,7 +1160,7 @@
return result;
}
#endif
-
+#endif
return NULL;
}