gzip: update gnulib patch again

This commit is contained in:
Lucy Phipps 2021-09-08 20:20:16 +01:00
parent 0ec2cfc1a7
commit 38372f051f
No known key found for this signature in database
GPG Key ID: 8F688A3DB7869BFE
2 changed files with 10 additions and 25 deletions

View File

@ -3,7 +3,7 @@ TERMUX_PKG_DESCRIPTION="Standard GNU file compression utilities"
TERMUX_PKG_LICENSE="GPL-3.0" TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_MAINTAINER="@termux" TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.11 TERMUX_PKG_VERSION=1.11
TERMUX_PKG_REVISION=1 TERMUX_PKG_REVISION=2
TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/gzip/gzip-${TERMUX_PKG_VERSION}.tar.xz TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/gzip/gzip-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=9b9a95d68fdcb936849a4d6fada8bf8686cddf58b9b26c9c4289ed0c92a77907 TERMUX_PKG_SHA256=9b9a95d68fdcb936849a4d6fada8bf8686cddf58b9b26c9c4289ed0c92a77907
TERMUX_PKG_ESSENTIAL=true TERMUX_PKG_ESSENTIAL=true

View File

@ -1,8 +1,8 @@
diff --git a/lib/Makefile.in b/lib/Makefile.in diff --git a/lib/Makefile.in b/lib/Makefile.in
index a39102957..5ef5e7e67 100644 index a39102957..b3c7e6d28 100644
--- a/lib/Makefile.in --- a/lib/Makefile.in
+++ b/lib/Makefile.in +++ b/lib/Makefile.in
@@ -3452,6 +3454,7 @@ string.h: string.in.h $(top_builddir)/config.status $(CXXDEFS_H) $(ARG_NONNULL_H @@ -3452,6 +3452,7 @@ string.h: string.in.h $(top_builddir)/config.status $(CXXDEFS_H) $(ARG_NONNULL_H
-e 's|@''REPLACE_FFSLL''@|$(REPLACE_FFSLL)|g' \ -e 's|@''REPLACE_FFSLL''@|$(REPLACE_FFSLL)|g' \
-e 's|@''REPLACE_MEMCHR''@|$(REPLACE_MEMCHR)|g' \ -e 's|@''REPLACE_MEMCHR''@|$(REPLACE_MEMCHR)|g' \
-e 's|@''REPLACE_MEMMEM''@|$(REPLACE_MEMMEM)|g' \ -e 's|@''REPLACE_MEMMEM''@|$(REPLACE_MEMMEM)|g' \
@ -10,7 +10,7 @@ index a39102957..5ef5e7e67 100644
-e 's|@''REPLACE_STPNCPY''@|$(REPLACE_STPNCPY)|g' \ -e 's|@''REPLACE_STPNCPY''@|$(REPLACE_STPNCPY)|g' \
-e 's|@''REPLACE_STRCHRNUL''@|$(REPLACE_STRCHRNUL)|g' \ -e 's|@''REPLACE_STRCHRNUL''@|$(REPLACE_STRCHRNUL)|g' \
-e 's|@''REPLACE_STRDUP''@|$(REPLACE_STRDUP)|g' \ -e 's|@''REPLACE_STRDUP''@|$(REPLACE_STRDUP)|g' \
@@ -3948,6 +3951,7 @@ wchar.h: wchar.in.h $(top_builddir)/config.status $(CXXDEFS_H) $(ARG_NONNULL_H) @@ -3948,6 +3949,7 @@ wchar.h: wchar.in.h $(top_builddir)/config.status $(CXXDEFS_H) $(ARG_NONNULL_H)
sed -e 's|@''REPLACE_MBSTATE_T''@|$(REPLACE_MBSTATE_T)|g' \ sed -e 's|@''REPLACE_MBSTATE_T''@|$(REPLACE_MBSTATE_T)|g' \
-e 's|@''REPLACE_BTOWC''@|$(REPLACE_BTOWC)|g' \ -e 's|@''REPLACE_BTOWC''@|$(REPLACE_BTOWC)|g' \
-e 's|@''REPLACE_WCTOB''@|$(REPLACE_WCTOB)|g' \ -e 's|@''REPLACE_WCTOB''@|$(REPLACE_WCTOB)|g' \
@ -18,23 +18,6 @@ index a39102957..5ef5e7e67 100644
-e 's|@''REPLACE_MBSINIT''@|$(REPLACE_MBSINIT)|g' \ -e 's|@''REPLACE_MBSINIT''@|$(REPLACE_MBSINIT)|g' \
-e 's|@''REPLACE_MBRTOWC''@|$(REPLACE_MBRTOWC)|g' \ -e 's|@''REPLACE_MBRTOWC''@|$(REPLACE_MBRTOWC)|g' \
-e 's|@''REPLACE_MBRLEN''@|$(REPLACE_MBRLEN)|g' \ -e 's|@''REPLACE_MBRLEN''@|$(REPLACE_MBRLEN)|g' \
diff --git a/lib/free.c b/lib/free.c
index 780f03dd1..804640c2e 100644
--- a/lib/free.c
+++ b/lib/free.c
@@ -27,9 +27,11 @@
# include <errno.h>
+# undef free
+void free (void *);
+
void
rpl_free (void *p)
-# undef free
{
# if defined __GNUC__ && !defined __clang__
/* An invalid GCC optimization
diff --git a/lib/gnulib.mk b/lib/gnulib.mk diff --git a/lib/gnulib.mk b/lib/gnulib.mk
index ad20b1970..c310220ca 100644 index ad20b1970..c310220ca 100644
--- a/lib/gnulib.mk --- a/lib/gnulib.mk
@ -56,7 +39,7 @@ index ad20b1970..c310220ca 100644
-e 's|@''REPLACE_MBRTOWC''@|$(REPLACE_MBRTOWC)|g' \ -e 's|@''REPLACE_MBRTOWC''@|$(REPLACE_MBRTOWC)|g' \
-e 's|@''REPLACE_MBRLEN''@|$(REPLACE_MBRLEN)|g' \ -e 's|@''REPLACE_MBRLEN''@|$(REPLACE_MBRLEN)|g' \
diff --git a/lib/string.in.h b/lib/string.in.h diff --git a/lib/string.in.h b/lib/string.in.h
index fa2e40c25..6214b5578 100644 index fa2e40c25..8977153c8 100644
--- a/lib/string.in.h --- a/lib/string.in.h
+++ b/lib/string.in.h +++ b/lib/string.in.h
@@ -47,9 +47,6 @@ @@ -47,9 +47,6 @@
@ -69,13 +52,14 @@ index fa2e40c25..6214b5578 100644
/* MirBSD defines mbslen as a macro. */ /* MirBSD defines mbslen as a macro. */
#if @GNULIB_MBSLEN@ && defined __MirBSD__ #if @GNULIB_MBSLEN@ && defined __MirBSD__
# include <wchar.h> # include <wchar.h>
@@ -86,6 +83,12 @@ @@ -86,6 +83,13 @@
/* The definition of _GL_WARN_ON_USE is copied here. */ /* The definition of _GL_WARN_ON_USE is copied here. */
+/* Declare 'free' if needed for _GL_ATTRIBUTE_DEALLOC_FREE. */ +/* Declare 'free' if needed for _GL_ATTRIBUTE_DEALLOC_FREE. */
+#if (@REPLACE_FREE@ && !defined free \ +#if (@REPLACE_FREE@ && !defined free \
+ && !(defined __cplusplus && defined GNULIB_NAMESPACE)) + && !(defined __cplusplus && defined GNULIB_NAMESPACE))
+_GL_EXTERN_C void free (void *);
+# define free rpl_free +# define free rpl_free
+#endif +#endif
+_GL_EXTERN_C void free (void *); +_GL_EXTERN_C void free (void *);
@ -83,7 +67,7 @@ index fa2e40c25..6214b5578 100644
/* Clear a block of memory. The compiler will not delete a call to /* Clear a block of memory. The compiler will not delete a call to
this function, even if the block is dead after the call. */ this function, even if the block is dead after the call. */
diff --git a/lib/wchar.in.h b/lib/wchar.in.h diff --git a/lib/wchar.in.h b/lib/wchar.in.h
index be5d36c8d..027a14549 100644 index be5d36c8d..acb9d4ea6 100644
--- a/lib/wchar.in.h --- a/lib/wchar.in.h
+++ b/lib/wchar.in.h +++ b/lib/wchar.in.h
@@ -72,9 +72,6 @@ @@ -72,9 +72,6 @@
@ -96,13 +80,14 @@ index be5d36c8d..027a14549 100644
/* Include the original <wchar.h> if it exists. /* Include the original <wchar.h> if it exists.
Some builds of uClibc lack it. */ Some builds of uClibc lack it. */
/* The include_next requires a split double-inclusion guard. */ /* The include_next requires a split double-inclusion guard. */
@@ -149,6 +146,12 @@ typedef int rpl_mbstate_t; @@ -149,6 +146,13 @@ typedef int rpl_mbstate_t;
# endif # endif
#endif #endif
+/* Declare 'free' if needed for _GL_ATTRIBUTE_DEALLOC_FREE. */ +/* Declare 'free' if needed for _GL_ATTRIBUTE_DEALLOC_FREE. */
+#if (@REPLACE_FREE@ && !defined free \ +#if (@REPLACE_FREE@ && !defined free \
+ && !(defined __cplusplus && defined GNULIB_NAMESPACE)) + && !(defined __cplusplus && defined GNULIB_NAMESPACE))
+_GL_EXTERN_C void free (void *);
+# define free rpl_free +# define free rpl_free
+#endif +#endif
+_GL_EXTERN_C void free (void *); +_GL_EXTERN_C void free (void *);