Remove python2-using getmail package
This commit is contained in:
parent
604c5988c4
commit
3c1d0ec073
|
@ -1,17 +0,0 @@
|
||||||
TERMUX_PKG_HOMEPAGE=http://pyropus.ca/software/getmail/
|
|
||||||
TERMUX_PKG_DESCRIPTION="fetchmail replacement relatively easy to configure"
|
|
||||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
|
||||||
TERMUX_PKG_VERSION=5.14
|
|
||||||
TERMUX_PKG_SRCURL=https://fossies.org/linux/misc/getmail-${TERMUX_PKG_VERSION}.tar.gz
|
|
||||||
TERMUX_PKG_SHA256=f3a99fe74564237d12ca8d4582e113c067c9205b5ab640f72b4e8447606a99c1
|
|
||||||
TERMUX_PKG_DEPENDS="python2"
|
|
||||||
TERMUX_PKG_BUILD_IN_SRC=true
|
|
||||||
TERMUX_PKG_PLATFORM_INDEPENDENT=true
|
|
||||||
|
|
||||||
termux_step_make_install() {
|
|
||||||
python2 setup.py install --prefix=$TERMUX_PREFIX --force
|
|
||||||
}
|
|
||||||
|
|
||||||
termux_step_post_massage() {
|
|
||||||
find . -path '*.pyc' -delete
|
|
||||||
}
|
|
|
@ -1,20 +0,0 @@
|
||||||
diff -u -r ../getmail-5.1/getmailcore/utilities.py ./getmailcore/utilities.py
|
|
||||||
--- ../getmail-5.1/getmailcore/utilities.py 2017-07-16 05:26:01.000000000 +0200
|
|
||||||
+++ ./getmailcore/utilities.py 2017-07-26 13:36:30.196152312 +0200
|
|
||||||
@@ -47,6 +47,7 @@
|
|
||||||
import sys
|
|
||||||
import tempfile
|
|
||||||
import errno
|
|
||||||
+import shutil
|
|
||||||
try:
|
|
||||||
import subprocess
|
|
||||||
except ImportError, o:
|
|
||||||
@@ -340,7 +341,7 @@
|
|
||||||
|
|
||||||
# Move message file from Maildir/tmp to Maildir/new
|
|
||||||
try:
|
|
||||||
- os.link(fname_tmp, fname_new)
|
|
||||||
+ shutil.copy2(fname_tmp, fname_new)
|
|
||||||
os.unlink(fname_tmp)
|
|
||||||
|
|
||||||
except OSError:
|
|
Loading…
Reference in New Issue