nushell: update from 0.18.1 to 0.20.0, disable x86_64 because of linking issues,
and unset CFLAGS for all crates, as it was getting applied to host builds
This commit is contained in:
parent
2a51b17afd
commit
3fe4a2ab6a
@ -1,15 +1,7 @@
|
|||||||
diff -u -r ../nushell-0.18.1/Cargo.toml ./Cargo.toml
|
diff -u -r ../nushell-0.18.1/Cargo.toml ./Cargo.toml
|
||||||
--- ../nushell-0.18.1/Cargo.toml 2020-08-12 03:59:28.000000000 +0000
|
--- ../nushell-0.18.1/Cargo.toml 2020-08-12 03:59:28.000000000 +0000
|
||||||
+++ ./Cargo.toml 2020-08-13 08:02:58.145134000 +0000
|
+++ ./Cargo.toml 2020-08-13 08:02:58.145134000 +0000
|
||||||
@@ -53,7 +53,6 @@
|
@@ -64,8 +64,6 @@ toml = "0.5.6"
|
||||||
log = "0.4.8"
|
|
||||||
pretty_env_logger = "0.4.0"
|
|
||||||
quick-xml = "0.18.1"
|
|
||||||
-starship = "0.43.0"
|
|
||||||
|
|
||||||
[dev-dependencies]
|
|
||||||
nu-test-support = {version = "0.18.1", path = "./crates/nu-test-support"}
|
|
||||||
@@ -64,8 +63,6 @@
|
|
||||||
|
|
||||||
[features]
|
[features]
|
||||||
default = [
|
default = [
|
||||||
@ -18,3 +10,11 @@ diff -u -r ../nushell-0.18.1/Cargo.toml ./Cargo.toml
|
|||||||
"textview",
|
"textview",
|
||||||
"inc",
|
"inc",
|
||||||
"git-support",
|
"git-support",
|
||||||
|
@@ -79,7 +77,6 @@ default = [
|
||||||
|
"match",
|
||||||
|
"post",
|
||||||
|
"fetch",
|
||||||
|
- "rich-benchmark",
|
||||||
|
]
|
||||||
|
extra = ["default", "binaryview", "tree", "clipboard-cli", "trash-support", "start", "bson", "sqlite", "s3"]
|
||||||
|
stable = ["default"]
|
||||||
|
@ -1,8 +1,9 @@
|
|||||||
TERMUX_PKG_HOMEPAGE=https://www.nushell.sh
|
TERMUX_PKG_HOMEPAGE=https://www.nushell.sh
|
||||||
TERMUX_PKG_DESCRIPTION="A new type of shell operating on structured data"
|
TERMUX_PKG_DESCRIPTION="A new type of shell operating on structured data"
|
||||||
TERMUX_PKG_LICENSE="MIT"
|
TERMUX_PKG_LICENSE="MIT"
|
||||||
TERMUX_PKG_VERSION=0.18.1
|
TERMUX_PKG_VERSION=0.20.0
|
||||||
TERMUX_PKG_SRCURL=https://github.com/nushell/nushell/archive/$TERMUX_PKG_VERSION.tar.gz
|
TERMUX_PKG_SRCURL=https://github.com/nushell/nushell/archive/$TERMUX_PKG_VERSION.tar.gz
|
||||||
TERMUX_PKG_SHA256=68761a9145630199df16ccb39225acd58c19c8773aaa79ab5eb1674ff694ca79
|
TERMUX_PKG_SHA256=ccecbfd49d03ca45f347fe55b789b8732003ceab49a14af110390e723f2fd274
|
||||||
TERMUX_PKG_DEPENDS="zlib"
|
TERMUX_PKG_DEPENDS="openssl, zlib"
|
||||||
TERMUX_PKG_BUILD_IN_SRC=true
|
TERMUX_PKG_BUILD_IN_SRC=true
|
||||||
|
TERMUX_PKG_BLACKLISTED_ARCHES="x86_64"
|
||||||
|
@ -28,6 +28,9 @@ termux_setup_rust() {
|
|||||||
ENV_NAME=${ENV_NAME//-/_}
|
ENV_NAME=${ENV_NAME//-/_}
|
||||||
export $ENV_NAME=$CC
|
export $ENV_NAME=$CC
|
||||||
export TARGET_CFLAGS="$CFLAGS $CPPFLAGS"
|
export TARGET_CFLAGS="$CFLAGS $CPPFLAGS"
|
||||||
|
# This was getting applied for the host build of Rust macros or whatever, so
|
||||||
|
# unset it.
|
||||||
|
unset CFLAGS
|
||||||
|
|
||||||
curl https://sh.rustup.rs -sSf > $TERMUX_PKG_TMPDIR/rustup.sh
|
curl https://sh.rustup.rs -sSf > $TERMUX_PKG_TMPDIR/rustup.sh
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user