hexchat: fix detection of lua by meson script
This commit is contained in:
parent
31bee058b9
commit
412c9999f5
@ -12,7 +12,7 @@ TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
|||||||
-Dwith-libproxy=false
|
-Dwith-libproxy=false
|
||||||
-Dwith-libcanberra=false
|
-Dwith-libcanberra=false
|
||||||
-Dwith-dbus=false
|
-Dwith-dbus=false
|
||||||
-Dwith-lua=lua
|
-Dwith-lua=lua53
|
||||||
-Dwith-text=true
|
-Dwith-text=true
|
||||||
-Dwith-perl=false
|
-Dwith-perl=false
|
||||||
-Dwith-sysinfo=false
|
-Dwith-sysinfo=false
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
diff -uNr hexchat-2.14.2/plugins/lua/meson.build hexchat-2.14.2.mod/plugins/lua/meson.build
|
|
||||||
--- hexchat-2.14.2/plugins/lua/meson.build 2018-08-29 19:41:08.000000000 +0300
|
|
||||||
+++ hexchat-2.14.2.mod/plugins/lua/meson.build 2018-10-09 22:01:54.019863275 +0300
|
|
||||||
@@ -1,8 +1,4 @@
|
|
||||||
-if cc.get_id() == 'msvc'
|
|
||||||
- lua_dep = cc.find_library('lua51')
|
|
||||||
-else
|
|
||||||
- lua_dep = dependency(get_option('with-lua'))
|
|
||||||
-endif
|
|
||||||
+lua_dep = cc.find_library('lua', dirs : '@TERMUX_PREFIX@/lib')
|
|
||||||
|
|
||||||
shared_module('lua', 'lua.c',
|
|
||||||
dependencies: [libgio_dep, hexchat_plugin_dep, lua_dep],
|
|
Loading…
Reference in New Issue
Block a user