new package: xrdp

Requested in https://github.com/termux/x11-packages/issues/46.
This commit is contained in:
Leonid Pliushch 2018-12-26 19:31:27 +02:00 committed by Yaksh Bariya
parent 584f39502a
commit 44daa53a9e
No known key found for this signature in database
GPG Key ID: F7486BA7D3D27581
12 changed files with 187 additions and 0 deletions

View File

@ -0,0 +1,17 @@
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com> @xeffyr"
TERMUX_PKG_HOMEPAGE=https://github.com/neutrinolabs/xrdp
TERMUX_PKG_DESCRIPTION="An open source remote desktop protocol (RDP) server"
TERMUX_PKG_VERSION=0.9.8
TERMUX_PKG_SRCURL=https://github.com/neutrinolabs/xrdp/releases/download/v${TERMUX_PKG_VERSION}/xrdp-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=bbb2c114903d65c212cb2cca0b11bb2620e5034fa9353e0479bc8aa9290b78ee
TERMUX_PKG_DEPENDS="tigervnc, libcrypt, libxrandr, libopus"
TERMUX_PKG_BUILD_IN_SRC=true
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
--disable-pam
--enable-static
"
termux_step_pre_configure() {
export LIBS="-landroid-shmem -llog"
}

View File

@ -0,0 +1,11 @@
diff -uNr xrdp-0.9.8/Makefile.am xrdp-0.9.8.mod/Makefile.am
--- xrdp-0.9.8/Makefile.am 2018-09-11 05:58:08.000000000 +0300
+++ xrdp-0.9.8.mod/Makefile.am 2018-12-26 19:04:01.793437260 +0200
@@ -57,7 +57,6 @@
$(PAINTERDIR) \
$(RFXCODECDIR) \
xrdp \
- sesman \
keygen \
docs \
instfiles \

View File

@ -0,0 +1,20 @@
diff -uNr xrdp-0.9.8/Makefile.in xrdp-0.9.8.mod/Makefile.in
--- xrdp-0.9.8/Makefile.in 2018-09-25 09:19:19.000000000 +0300
+++ xrdp-0.9.8.mod/Makefile.in 2018-12-26 19:04:16.010272502 +0200
@@ -167,7 +167,7 @@
CTAGS = ctags
CSCOPE = cscope
DIST_SUBDIRS = common vnc xup mc neutrinordp libxrdp libpainter \
- librfxcodec xrdp sesman keygen docs instfiles genkeymap \
+ librfxcodec xrdp keygen docs instfiles genkeymap \
xrdpapi pkgconfig xrdpvr
am__DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/config_ac-h.in \
COPYING compile config.guess config.sub install-sh ltmain.sh \
@@ -400,7 +400,6 @@
$(PAINTERDIR) \
$(RFXCODECDIR) \
xrdp \
- sesman \
keygen \
docs \
instfiles \

View File

@ -0,0 +1,10 @@
diff -uNr xrdp-0.9.8/common/Makefile.am xrdp-0.9.8.mod/common/Makefile.am
--- xrdp-0.9.8/common/Makefile.am 2018-03-27 17:15:16.000000000 +0300
+++ xrdp-0.9.8.mod/common/Makefile.am 2018-12-26 18:16:40.415737116 +0200
@@ -58,6 +58,5 @@
$(PIXMAN_SOURCES)
libcommon_la_LIBADD = \
- -lpthread \
$(OPENSSL_LIBS) \
$(DLOPEN_LIBS)

View File

@ -0,0 +1,11 @@
diff -uNr xrdp-0.9.8/common/Makefile.in xrdp-0.9.8.mod/common/Makefile.in
--- xrdp-0.9.8/common/Makefile.in 2018-09-25 09:19:19.000000000 +0300
+++ xrdp-0.9.8.mod/common/Makefile.in 2018-12-26 18:16:36.582386251 +0200
@@ -417,7 +417,6 @@
$(PIXMAN_SOURCES)
libcommon_la_LIBADD = \
- -lpthread \
$(OPENSSL_LIBS) \
$(DLOPEN_LIBS)

View File

@ -0,0 +1,23 @@
diff -uNr xrdp-0.9.8/configure xrdp-0.9.8.mod/configure
--- xrdp-0.9.8/configure 2018-09-25 09:19:18.000000000 +0300
+++ xrdp-0.9.8.mod/configure 2018-12-26 19:25:55.293206203 +0200
@@ -14388,18 +14388,7 @@
moduledir='${libdir}/xrdp'
-# Check whether --enable-strict-locations was given.
-if test "${enable_strict_locations+set}" = set; then :
- enableval=$enable_strict_locations;
-else
- enable_strict_locations=no
-fi
-
-
-if test "x$enable_strict_locations" != "xyes"; then
- sysconfdir="/etc";
- localstatedir="/var";
-fi
+enable_strict_locations=no

View File

@ -0,0 +1,23 @@
diff -uNr xrdp-0.9.8/keygen/Makefile.am xrdp-0.9.8.mod/keygen/Makefile.am
--- xrdp-0.9.8/keygen/Makefile.am 2018-03-26 09:14:14.000000000 +0300
+++ xrdp-0.9.8.mod/keygen/Makefile.am 2018-12-26 19:28:46.744764873 +0200
@@ -17,19 +17,6 @@
xrdpsysconfdir = $(sysconfdir)/xrdp
-install-data-hook:
- umask 077 && \
- if [ ! -f $(DESTDIR)$(xrdpsysconfdir)/rsakeys.ini ]; then \
- ./xrdp-keygen xrdp $(DESTDIR)$(xrdpsysconfdir)/rsakeys.ini; \
- fi && \
- if [ ! -f $(DESTDIR)$(xrdpsysconfdir)/cert.pem ]; then \
- $(OPENSSL) req -x509 -newkey rsa:2048 -sha256 -nodes \
- -keyout $(DESTDIR)$(xrdpsysconfdir)/key.pem -out \
- $(DESTDIR)$(xrdpsysconfdir)/cert.pem -days 365 \
- -subj /C=US/ST=CA/L=Sunnyvale/O=xrdp/CN=www.xrdp.org \
- -config $(srcdir)/openssl.conf; \
- fi
-
uninstall-hook:
rm -f $(DESTDIR)$(xrdpsysconfdir)/rsakeys.ini
rm -f $(DESTDIR)$(xrdpsysconfdir)/cert.pem

View File

@ -0,0 +1,23 @@
diff -uNr xrdp-0.9.8/keygen/Makefile.in xrdp-0.9.8.mod/keygen/Makefile.in
--- xrdp-0.9.8/keygen/Makefile.in 2018-09-25 09:19:20.000000000 +0300
+++ xrdp-0.9.8.mod/keygen/Makefile.in 2018-12-26 19:29:05.848271211 +0200
@@ -679,19 +679,6 @@
.PRECIOUS: Makefile
-install-data-hook:
- umask 077 && \
- if [ ! -f $(DESTDIR)$(xrdpsysconfdir)/rsakeys.ini ]; then \
- ./xrdp-keygen xrdp $(DESTDIR)$(xrdpsysconfdir)/rsakeys.ini; \
- fi && \
- if [ ! -f $(DESTDIR)$(xrdpsysconfdir)/cert.pem ]; then \
- $(OPENSSL) req -x509 -newkey rsa:2048 -sha256 -nodes \
- -keyout $(DESTDIR)$(xrdpsysconfdir)/key.pem -out \
- $(DESTDIR)$(xrdpsysconfdir)/cert.pem -days 365 \
- -subj /C=US/ST=CA/L=Sunnyvale/O=xrdp/CN=www.xrdp.org \
- -config $(srcdir)/openssl.conf; \
- fi
-
uninstall-hook:
rm -f $(DESTDIR)$(xrdpsysconfdir)/rsakeys.ini
rm -f $(DESTDIR)$(xrdpsysconfdir)/cert.pem

View File

@ -0,0 +1,13 @@
diff -uNr xrdp-0.9.8/sesman/Makefile.am xrdp-0.9.8.mod/sesman/Makefile.am
--- xrdp-0.9.8/sesman/Makefile.am 2018-09-18 07:21:13.000000000 +0300
+++ xrdp-0.9.8.mod/sesman/Makefile.am 2018-12-26 18:16:46.679099072 +0200
@@ -70,8 +70,7 @@
xrdp_sesman_LDADD = \
$(top_builddir)/common/libcommon.la \
$(top_builddir)/sesman/libscp/libscp.la \
- $(AUTH_LIB) \
- -lpthread
+ $(AUTH_LIB)
sesmansysconfdir=$(sysconfdir)/xrdp

View File

@ -0,0 +1,13 @@
diff -uNr xrdp-0.9.8/sesman/Makefile.in xrdp-0.9.8.mod/sesman/Makefile.in
--- xrdp-0.9.8/sesman/Makefile.in 2018-09-25 09:19:20.000000000 +0300
+++ xrdp-0.9.8.mod/sesman/Makefile.in 2018-12-26 18:16:52.382458449 +0200
@@ -474,8 +474,7 @@
xrdp_sesman_LDADD = \
$(top_builddir)/common/libcommon.la \
$(top_builddir)/sesman/libscp/libscp.la \
- $(AUTH_LIB) \
- -lpthread
+ $(AUTH_LIB)
sesmansysconfdir = $(sysconfdir)/xrdp
SUBST_VARS = sed \

View File

@ -0,0 +1,10 @@
diff -uNr xrdp-0.9.8/sesman/libscp/Makefile.am xrdp-0.9.8.mod/sesman/libscp/Makefile.am
--- xrdp-0.9.8/sesman/libscp/Makefile.am 2018-03-26 09:14:14.000000000 +0300
+++ xrdp-0.9.8.mod/sesman/libscp/Makefile.am 2018-12-26 18:16:57.529148602 +0200
@@ -42,5 +42,4 @@
libscp_vX.h
libscp_la_LIBADD = \
- $(top_builddir)/common/libcommon.la \
- -lpthread
+ $(top_builddir)/common/libcommon.la

View File

@ -0,0 +1,13 @@
diff -uNr xrdp-0.9.8/sesman/libscp/Makefile.in xrdp-0.9.8.mod/sesman/libscp/Makefile.in
--- xrdp-0.9.8/sesman/libscp/Makefile.in 2018-09-25 09:19:20.000000000 +0300
+++ xrdp-0.9.8.mod/sesman/libscp/Makefile.in 2018-12-26 18:17:03.132507481 +0200
@@ -397,8 +397,7 @@
libscp_vX.h
libscp_la_LIBADD = \
- $(top_builddir)/common/libcommon.la \
- -lpthread
+ $(top_builddir)/common/libcommon.la
all: all-am