vifm window manager with vim bindings (#1612)
This commit is contained in:
parent
c3cfd39d19
commit
44e4d3d582
9
packages/vifm/build.sh
Normal file
9
packages/vifm/build.sh
Normal file
@ -0,0 +1,9 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://vifm.info/
|
||||
TERMUX_PKG_DESCRIPTION="Vifm is an ncurses based file manager with vi like keybindings/modes/options/commands/configuration"
|
||||
TERMUX_PKG_VERSION=0.9
|
||||
TERMUX_PKG_SRCURL=https://github.com/vifm/vifm/archive/v0.9.tar.gz
|
||||
TERMUX_PKG_SHA256=837337935627dafaff90da300dea0e35dd9ad1eb932294274ababee814f91649
|
||||
TERMUX_PKG_DEPENDS="ncurses, file"
|
||||
termux_step_pre_configure() {
|
||||
autoreconf -if
|
||||
}
|
35
packages/vifm/cmd_completion.c.patch
Normal file
35
packages/vifm/cmd_completion.c.patch
Normal file
@ -0,0 +1,35 @@
|
||||
--- ../cache/vifm-0.9/src/cmd_completion.c 2017-06-18 14:31:25.000000000 +0000
|
||||
+++ ./src/cmd_completion.c 2017-10-04 00:00:24.535121432 +0000
|
||||
@@ -1046,6 +1044,7 @@
|
||||
size_t len;
|
||||
|
||||
len = strlen(str);
|
||||
+#ifndef __ANDROID__
|
||||
setpwent();
|
||||
while((pw = getpwent()) != NULL)
|
||||
{
|
||||
@@ -1054,6 +1053,7 @@
|
||||
vle_compl_add_match(pw->pw_name, "");
|
||||
}
|
||||
}
|
||||
+#endif
|
||||
vle_compl_finish_group();
|
||||
vle_compl_add_last_match(str);
|
||||
}
|
||||
@@ -1063,7 +1063,7 @@
|
||||
{
|
||||
struct group *gr;
|
||||
size_t len = strlen(str);
|
||||
-
|
||||
+#ifndef __ANDROID__
|
||||
setgrent();
|
||||
while((gr = getgrent()) != NULL)
|
||||
{
|
||||
@@ -1072,6 +1072,7 @@
|
||||
vle_compl_add_match(gr->gr_name, "");
|
||||
}
|
||||
}
|
||||
+#endif
|
||||
vle_compl_finish_group();
|
||||
vle_compl_add_last_match(str);
|
||||
}
|
47
packages/vifm/configure.ac.patch
Normal file
47
packages/vifm/configure.ac.patch
Normal file
@ -0,0 +1,47 @@
|
||||
--- ../cache/vifm-0.9/configure.ac 2017-06-18 14:31:25.000000000 +0000
|
||||
+++ ./configure.ac 2017-10-03 23:29:41.348507964 +0000
|
||||
@@ -145,18 +145,11 @@
|
||||
AC_CHECK_FUNC([getcwd], [], [AC_MSG_ERROR([getcwd() function not found.])])
|
||||
AC_CHECK_FUNC([getenv], [], [AC_MSG_ERROR([getenv() function not found.])])
|
||||
AC_CHECK_FUNC([geteuid], [], [AC_MSG_ERROR([geteuid() function not found.])])
|
||||
-AC_CHECK_FUNC([getgrent], [], [AC_MSG_ERROR([getgrent() function not found.])])
|
||||
-AC_CHECK_FUNC([getgrgid], [], [AC_MSG_ERROR([getgrgid() function not found.])])
|
||||
-AC_CHECK_FUNC([getgrgid_r], [], [AC_MSG_ERROR([getgrgid_r() function not found.])])
|
||||
-AC_CHECK_FUNC([getgrnam], [], [AC_MSG_ERROR([getgrnam() function not found.])])
|
||||
if test -n "$HAVE_MNTENT_H" ; then
|
||||
AC_CHECK_FUNC([getmntent], [], [AC_MSG_ERROR([getmntent() function not found.])])
|
||||
fi
|
||||
AC_CHECK_FUNC([getpid], [], [AC_MSG_ERROR([getpid() function not found.])])
|
||||
AC_CHECK_FUNC([getppid], [], [AC_MSG_ERROR([getppid() function not found.])])
|
||||
-AC_CHECK_FUNC([getpwent], [], [AC_MSG_ERROR([getpwent() function not found.])])
|
||||
-AC_CHECK_FUNC([getpwnam], [], [AC_MSG_ERROR([getpwnam() function not found.])])
|
||||
-AC_CHECK_FUNC([getpwuid], [], [AC_MSG_ERROR([getpwuid() function not found.])])
|
||||
AC_CHECK_FUNC([getpwuid_r], [], [AC_MSG_ERROR([getpwuid_r() function not found.])])
|
||||
AC_CHECK_FUNC([ioctl], [], [AC_MSG_ERROR([ioctl() function not found.])])
|
||||
AC_CHECK_FUNC([iswalnum], [], [AC_MSG_ERROR([iswalnum() function not found.])])
|
||||
@@ -192,13 +185,11 @@
|
||||
AC_CHECK_FUNC([rmdir], [], [AC_MSG_ERROR([rmdir() function not found.])])
|
||||
AC_CHECK_FUNC([select], [], [AC_MSG_ERROR([select() function not found.])])
|
||||
AC_CHECK_FUNC([setenv], [], [AC_MSG_ERROR([setenv() function not found.])])
|
||||
-AC_CHECK_FUNC([setgrent], [], [AC_MSG_ERROR([setgrent() function not found.])])
|
||||
AC_CHECK_FUNC([setlocale], [], [AC_MSG_ERROR([setlocale() function not found.])])
|
||||
if test -n "$HAVE_MNTENT_H" ; then
|
||||
AC_CHECK_FUNC([setmntent], [], [AC_MSG_ERROR([setmntent() function not found.])])
|
||||
fi
|
||||
AC_CHECK_FUNC([setpgid], [], [AC_MSG_ERROR([setpgid() function not found.])])
|
||||
-AC_CHECK_FUNC([setpwent], [], [AC_MSG_ERROR([setpwent() function not found.])])
|
||||
AC_CHECK_FUNC([setsid], [], [AC_MSG_ERROR([setsid() function not found.])])
|
||||
AC_CHECK_FUNC([setvbuf], [], [AC_MSG_ERROR([setvbuf() function not found.])])
|
||||
AC_CHECK_FUNC([sigaction], [], [AC_MSG_ERROR([sigaction() function not found.])])
|
||||
@@ -371,11 +362,6 @@
|
||||
AC_CHECK_LIB(m, pow, [LIBS="$LIBS -lm"])
|
||||
|
||||
dnl Use pthread library
|
||||
-AC_CHECK_LIB(pthread, pthread_create,
|
||||
- [LIBS="$LIBS -lpthread"
|
||||
- AC_CHECK_HEADER([pthread.h], [], [AC_MSG_ERROR([pthread.h header not found.])])
|
||||
- ],
|
||||
- [AC_MSG_ERROR([libpthread not found])])
|
||||
|
||||
dnl Check for all required elements in pthread.h.
|
||||
AC_CHECK_FUNC([pthread_create], [], [AC_MSG_ERROR([pthread_create() function not found.])])
|
11
packages/vifm/file_info.c.patch
Normal file
11
packages/vifm/file_info.c.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ../cache/vifm-0.9/src/modes/file_info.c 2017-06-18 14:31:25.000000000 +0000
|
||||
+++ ./src/modes/file_info.c 2017-10-03 23:51:20.005137148 +0000
|
||||
@@ -31,7 +31,7 @@
|
||||
#include <stdlib.h> /* free() */
|
||||
#include <string.h> /* strlen() */
|
||||
#include <time.h> /* tm localtime() strftime() */
|
||||
-
|
||||
+#include <sys/sysmacros.h>
|
||||
#include "../cfg/config.h"
|
||||
#include "../compat/fs_limits.h"
|
||||
#include "../compat/os.h"
|
11
packages/vifm/pthread.c.patch
Normal file
11
packages/vifm/pthread.c.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ../cache/vifm-0.9/src/compat/pthread.c 2017-06-18 14:31:25.000000000 +0000
|
||||
+++ ./src/compat/pthread.c 2017-10-03 23:43:21.948484280 +0000
|
||||
@@ -18,7 +18,7 @@
|
||||
|
||||
#include "pthread.h"
|
||||
|
||||
-#ifdef __APPLE__
|
||||
+#ifdef __ANDROID__
|
||||
|
||||
#include <assert.h> /* assert() */
|
||||
#include <errno.h> /* EBUSY */
|
11
packages/vifm/pthread.h.patch
Normal file
11
packages/vifm/pthread.h.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ../cache/vifm-0.9/src/compat/pthread.h 2017-06-18 14:31:25.000000000 +0000
|
||||
+++ ./src/compat/pthread.h 2017-10-03 23:46:10.528479414 +0000
|
||||
@@ -21,7 +21,7 @@
|
||||
|
||||
#include <pthread.h>
|
||||
|
||||
-#ifdef __APPLE__
|
||||
+#ifdef __ANDROID__
|
||||
|
||||
typedef int pthread_spinlock_t;
|
||||
|
Loading…
Reference in New Issue
Block a user