solidity: Do not use bundled jsoncpp
to avoid build issue when jsoncpp package is installed.
This commit is contained in:
parent
110435cc0f
commit
462978bdb3
12
packages/solidity/CMakeLists.txt.patch
Normal file
12
packages/solidity/CMakeLists.txt.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -42,9 +42,7 @@
|
||||||
|
# Let's find our dependencies
|
||||||
|
include(EthDependencies)
|
||||||
|
include(fmtlib)
|
||||||
|
-include(jsoncpp)
|
||||||
|
include(range-v3)
|
||||||
|
-include_directories(SYSTEM ${JSONCPP_INCLUDE_DIR})
|
||||||
|
|
||||||
|
find_package(Threads)
|
||||||
|
|
@ -3,10 +3,11 @@ TERMUX_PKG_DESCRIPTION="An Ethereum smart contract-oriented language."
|
|||||||
TERMUX_PKG_LICENSE="GPL-3.0"
|
TERMUX_PKG_LICENSE="GPL-3.0"
|
||||||
TERMUX_PKG_MAINTAINER="@termux"
|
TERMUX_PKG_MAINTAINER="@termux"
|
||||||
TERMUX_PKG_VERSION=0.8.11
|
TERMUX_PKG_VERSION=0.8.11
|
||||||
|
TERMUX_PKG_REVISION=1
|
||||||
TERMUX_PKG_SRCURL=https://github.com/ethereum/solidity/releases/download/v${TERMUX_PKG_VERSION}/solidity_${TERMUX_PKG_VERSION}.tar.gz
|
TERMUX_PKG_SRCURL=https://github.com/ethereum/solidity/releases/download/v${TERMUX_PKG_VERSION}/solidity_${TERMUX_PKG_VERSION}.tar.gz
|
||||||
TERMUX_PKG_SHA256=b67df542cc19f4181a07050950e235f60a6dcc8018529335701384e632947b5a
|
TERMUX_PKG_SHA256=b67df542cc19f4181a07050950e235f60a6dcc8018529335701384e632947b5a
|
||||||
TERMUX_PKG_AUTO_UPDATE=true
|
TERMUX_PKG_AUTO_UPDATE=true
|
||||||
TERMUX_PKG_DEPENDS="boost"
|
TERMUX_PKG_DEPENDS="boost, jsoncpp"
|
||||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||||
-DUSE_Z3=OFF
|
-DUSE_Z3=OFF
|
||||||
-DUSE_CVC4=OFF
|
-DUSE_CVC4=OFF
|
||||||
@ -14,3 +15,7 @@ TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
|||||||
-DBoost_USE_STATIC_LIBS=OFF
|
-DBoost_USE_STATIC_LIBS=OFF
|
||||||
"
|
"
|
||||||
TERMUX_CMAKE_BUILD="Unix Makefiles"
|
TERMUX_CMAKE_BUILD="Unix Makefiles"
|
||||||
|
|
||||||
|
termux_step_pre_configure() {
|
||||||
|
LDFLAGS+=" -ljsoncpp"
|
||||||
|
}
|
||||||
|
14
packages/solidity/libsolutil-JSON.cpp.patch
Normal file
14
packages/solidity/libsolutil-JSON.cpp.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
--- a/libsolutil/JSON.cpp
|
||||||
|
+++ b/libsolutil/JSON.cpp
|
||||||
|
@@ -32,11 +32,6 @@
|
||||||
|
|
||||||
|
using namespace std;
|
||||||
|
|
||||||
|
-static_assert(
|
||||||
|
- (JSONCPP_VERSION_MAJOR == 1) && (JSONCPP_VERSION_MINOR == 9) && (JSONCPP_VERSION_PATCH == 3),
|
||||||
|
- "Unexpected jsoncpp version: " JSONCPP_VERSION_STRING ". Expecting 1.9.3."
|
||||||
|
-);
|
||||||
|
-
|
||||||
|
namespace solidity::util
|
||||||
|
{
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user