nodejs: Update from 13.0.0 to 13.13.0 (#4762)
Co-authored-by: Henrik Grimler <henrik@grimler.se>
This commit is contained in:
parent
1fa297a587
commit
4846be6f8d
@ -1,10 +1,9 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://nodejs.org/
|
||||
TERMUX_PKG_DESCRIPTION="Platform built on Chrome's JavaScript runtime for easily building fast, scalable network applications"
|
||||
TERMUX_PKG_LICENSE="MIT"
|
||||
TERMUX_PKG_VERSION=13.0.0
|
||||
TERMUX_PKG_REVISION=3
|
||||
TERMUX_PKG_VERSION=13.13.0
|
||||
TERMUX_PKG_SRCURL=https://nodejs.org/dist/v${TERMUX_PKG_VERSION}/node-v${TERMUX_PKG_VERSION}.tar.xz
|
||||
TERMUX_PKG_SHA256=45ff3b40afc3fc93fd62e31c0f5dfa046f307f0b33d0f32e09019f306bc74767
|
||||
TERMUX_PKG_SHA256=6711730dfaae2423c8f74f4b5f389bb3f3f0d770eac271287fa9444a9568c773
|
||||
# Note that we do not use a shared libuv to avoid an issue with the Android
|
||||
# linker, which does not use symbols of linked shared libraries when resolving
|
||||
# symbols on dlopen(). See https://github.com/termux/termux-packages/issues/462.
|
||||
@ -16,6 +15,18 @@ TERMUX_PKG_SUGGESTS="clang, make, pkg-config, python"
|
||||
TERMUX_PKG_RM_AFTER_INSTALL="lib/node_modules/npm/html lib/node_modules/npm/make.bat share/systemtap lib/dtrace"
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
TERMUX_PKG_HOSTBUILD=true
|
||||
# Build fails on x86_64 with:
|
||||
# g++ -rdynamic -m64 -pthread -m64 -fPIC -o /home/builder/.termux-build/nodejs/src/out/Release/mksnapshot ...
|
||||
# /usr/bin/ld: /home/builder/.termux-build/nodejs/src/out/Release/obj.host/v8_base_without_compiler/deps/v8/src/api/api.o:
|
||||
# in function `v8::TryHandleWebAssemblyTrapPosix(int, siginfo_t*, void*)':
|
||||
# api.cc:(.text._ZN2v829TryHandleWebAssemblyTrapPosixEiP9siginfo_tPv+0x5):
|
||||
# undefined reference to `v8::internal::trap_handler::TryHandleSignal(int, siginfo_t*, void*)'
|
||||
# /usr/bin/ld: /home/builder/.termux-build/nodejs/src/out/Release/obj.host/v8_base_without_compiler/deps/v8/src/trap-handler/handler-outside.o:
|
||||
# in function `v8::internal::trap_handler::EnableTrapHandler(bool)':
|
||||
# handler-outside.cc:(.text._ZN2v88internal12trap_handler17EnableTrapHandlerEb+0x25):
|
||||
# undefined reference to `v8::internal::trap_handler::RegisterDefaultTrapHandler()'
|
||||
# collect2: error: ld returned 1 exit status
|
||||
TERMUX_PKG_BLACKLISTED_ARCHES="x86_64"
|
||||
|
||||
termux_step_post_extract_package() {
|
||||
# Prevent caching of host build:
|
||||
@ -73,12 +84,11 @@ termux_step_configure() {
|
||||
--shared-openssl \
|
||||
--shared-zlib \
|
||||
--with-intl=system-icu \
|
||||
--without-snapshot \
|
||||
--without-node-snapshot \
|
||||
--cross-compiling
|
||||
|
||||
export LD_LIBRARY_PATH=$TERMUX_PKG_HOSTBUILD_DIR/icu-installed/lib
|
||||
perl -p -i -e "s@LIBS := \\$\\(LIBS\\)@LIBS := -L$TERMUX_PKG_HOSTBUILD_DIR/icu-installed/lib -lpthread -licui18n -licuuc -licudata@" \
|
||||
$TERMUX_PKG_SRCDIR/out/tools/v8_gypfiles/mksnapshot.host.mk \
|
||||
$TERMUX_PKG_SRCDIR/out/tools/v8_gypfiles/torque.host.mk \
|
||||
$TERMUX_PKG_SRCDIR/out/tools/v8_gypfiles/bytecode_builtins_list_generator.host.mk \
|
||||
$TERMUX_PKG_SRCDIR/out/tools/v8_gypfiles/v8_libbase.host.mk \
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -u -r ../node-v12.1.0/configure.py ./configure.py
|
||||
--- ../node-v12.1.0/configure.py 2019-04-29 12:57:51.000000000 +0000
|
||||
+++ ./configure.py 2019-05-05 21:21:04.289245037 +0000
|
||||
@@ -931,7 +931,7 @@
|
||||
else target_arch != host_arch)
|
||||
want_snapshots = not options.without_snapshot
|
||||
o['variables']['want_separate_host_toolset'] = int(
|
||||
- cross_compiling and want_snapshots)
|
||||
+ cross_compiling)
|
||||
|
||||
if options.with_node_snapshot:
|
||||
o['variables']['node_use_node_snapshot'] = 'true'
|
@ -1,7 +1,7 @@
|
||||
diff -u -r ../node-v12.9.0/node.gyp ./node.gyp
|
||||
--- ../node-v12.9.0/node.gyp 2019-08-20 17:14:52.000000000 +0000
|
||||
+++ ./node.gyp 2019-08-24 20:21:21.471982543 +0000
|
||||
@@ -1062,107 +1062,6 @@
|
||||
diff -u -r ../node-v13.13.0/node.gyp ./node.gyp
|
||||
--- ../node-v13.13.0/node.gyp 2020-04-14 16:40:37.000000000 +0000
|
||||
+++ ./node.gyp 2020-04-19 20:09:14.831393000 +0000
|
||||
@@ -1095,101 +1095,6 @@
|
||||
} ],
|
||||
]
|
||||
}, # specialize_node_d
|
||||
@ -12,6 +12,7 @@ diff -u -r ../node-v12.9.0/node.gyp ./node.gyp
|
||||
- 'dependencies': [
|
||||
- '<(node_lib_target_name)',
|
||||
- 'deps/histogram/histogram.gyp:histogram',
|
||||
- 'deps/uvwasi/uvwasi.gyp:uvwasi',
|
||||
- 'node_dtrace_header',
|
||||
- 'node_dtrace_ustack',
|
||||
- 'node_dtrace_provider',
|
||||
@ -27,10 +28,15 @@ diff -u -r ../node-v12.9.0/node.gyp ./node.gyp
|
||||
- 'deps/v8/include',
|
||||
- 'deps/cares/include',
|
||||
- 'deps/uv/include',
|
||||
- 'deps/uvwasi/include',
|
||||
- 'test/cctest',
|
||||
- ],
|
||||
-
|
||||
- 'defines': [ 'NODE_WANT_INTERNALS=1' ],
|
||||
- 'defines': [
|
||||
- 'NODE_ARCH="<(target_arch)"',
|
||||
- 'NODE_PLATFORM="<(OS)"',
|
||||
- 'NODE_WANT_INTERNALS=1',
|
||||
- ],
|
||||
-
|
||||
- 'sources': [
|
||||
- 'src/node_snapshot_stub.cc',
|
||||
@ -41,11 +47,14 @@ diff -u -r ../node-v12.9.0/node.gyp ./node.gyp
|
||||
- 'test/cctest/node_test_fixture.h',
|
||||
- 'test/cctest/test_aliased_buffer.cc',
|
||||
- 'test/cctest/test_base64.cc',
|
||||
- 'test/cctest/test_base_object_ptr.cc',
|
||||
- 'test/cctest/test_node_postmortem_metadata.cc',
|
||||
- 'test/cctest/test_environment.cc',
|
||||
- 'test/cctest/test_linked_binding.cc',
|
||||
- 'test/cctest/test_per_process.cc',
|
||||
- 'test/cctest/test_platform.cc',
|
||||
- 'test/cctest/test_json_utils.cc',
|
||||
- 'test/cctest/test_sockaddr.cc',
|
||||
- 'test/cctest/test_traced_value.cc',
|
||||
- 'test/cctest/test_util.cc',
|
||||
- 'test/cctest/test_url.cc',
|
||||
@ -82,21 +91,6 @@ diff -u -r ../node-v12.9.0/node.gyp ./node.gyp
|
||||
- 'OTHER_LDFLAGS': [ '-Wl,-rpath,@loader_path', ],
|
||||
- },
|
||||
- }],
|
||||
- [ 'node_report=="true"', {
|
||||
- 'sources': [
|
||||
- 'test/cctest/test_report_util.cc',
|
||||
- ],
|
||||
- 'defines': [
|
||||
- 'NODE_REPORT',
|
||||
- 'NODE_ARCH="<(target_arch)"',
|
||||
- 'NODE_PLATFORM="<(OS)"',
|
||||
- ],
|
||||
- 'conditions': [
|
||||
- ['OS=="win"', {
|
||||
- 'libraries': [ 'Ws2_32' ],
|
||||
- }],
|
||||
- ],
|
||||
- }],
|
||||
- ['OS=="win"', {
|
||||
- 'libraries': [
|
||||
- 'Dbghelp.lib',
|
||||
|
Loading…
Reference in New Issue
Block a user