moria: rename binary umoria->moria, install more (needed) files
This commit is contained in:
parent
78f707805c
commit
48fb470c68
@ -1,5 +1,5 @@
|
|||||||
--- ../CMakeLists.txt.orig 2019-04-20 20:35:53.547906398 +0000
|
--- ../CMakeLists.txt.orig 2019-04-28 08:12:04.338201376 +0200
|
||||||
+++ ./CMakeLists.txt 2019-04-20 21:47:17.644443892 +0000
|
+++ ./CMakeLists.txt 2019-04-28 08:43:34.081455683 +0200
|
||||||
@@ -156,16 +156,12 @@
|
@@ -156,16 +156,12 @@
|
||||||
#
|
#
|
||||||
# Set up the install paths and files
|
# Set up the install paths and files
|
||||||
@ -18,9 +18,35 @@
|
|||||||
# Core game data files
|
# Core game data files
|
||||||
set(
|
set(
|
||||||
data_files
|
data_files
|
||||||
@@ -268,4 +264,4 @@
|
@@ -241,7 +237,7 @@
|
||||||
target_link_libraries(umoria ${CURSES_LIBRARIES})
|
set(resources ${data_files} ${support_files})
|
||||||
|
|
||||||
|
# Also add resources to the target so they are visible in the IDE
|
||||||
|
-add_executable(umoria ${source_files} ${resources})
|
||||||
|
+add_executable(moria ${source_files} ${resources})
|
||||||
|
|
||||||
|
|
||||||
|
# This is horrible, but needed bacause `find_package()` doesn't use the
|
||||||
|
@@ -265,7 +261,20 @@
|
||||||
|
endif ()
|
||||||
|
|
||||||
|
include_directories(${CURSES_INCLUDE_DIR})
|
||||||
|
-target_link_libraries(umoria ${CURSES_LIBRARIES})
|
||||||
|
+target_link_libraries(moria ${CURSES_LIBRARIES})
|
||||||
|
|
||||||
# Build and install the umoria binary
|
# Build and install the umoria binary
|
||||||
-install(TARGETS umoria DESTINATION ${build_dir})
|
-install(TARGETS umoria DESTINATION ${build_dir})
|
||||||
+install(TARGETS umoria DESTINATION ${CMAKE_INSTALL_PREFIX}/bin/)
|
+install(TARGETS moria DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
|
||||||
|
+install(FILES docs/manual.md docs/faq.md LICENSE DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/moria/)
|
||||||
|
+install(FILES
|
||||||
|
+ data/death_royal.txt
|
||||||
|
+ data/death_tomb.txt
|
||||||
|
+ data/help.txt
|
||||||
|
+ data/help_wizard.txt
|
||||||
|
+ data/rl_help.txt
|
||||||
|
+ data/rl_help_wizard.txt
|
||||||
|
+ data/scores.dat
|
||||||
|
+ data/splash.txt
|
||||||
|
+ data/welcome.txt
|
||||||
|
+ data/versions.txt
|
||||||
|
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/games/moria/)
|
||||||
|
Loading…
x
Reference in New Issue
Block a user