Bump luajit to commit 787736990ac3b7d5ceaba2697c7d0f58f77bb782

This commit is contained in:
shadmansaleh 2021-07-05 19:14:30 +06:00 committed by Henrik Grimler
parent 51e6737165
commit 4ac21a30e9
3 changed files with 21 additions and 9 deletions

View File

@ -0,0 +1,11 @@
--- LuaJIT-old/Makefile 2021-03-11 01:19:04.000000000 +0600
+++ LuaJIT-new/Makefile 2021-07-05 09:41:36.271253147 +0600
@@ -25,7 +25,7 @@
# Change the installation path as needed. This automatically adjusts
# the paths in src/luaconf.h, too. Note: PREFIX must be an absolute path!
#
-export PREFIX= /usr/local
+export PREFIX?= /usr/local
export MULTILIB= lib
##############################################################################

View File

@ -3,8 +3,10 @@ TERMUX_PKG_DESCRIPTION="Just-In-Time Compiler for Lua"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1:2.1.0-beta3
TERMUX_PKG_SRCURL=https://github.com/LuaJIT/LuaJIT/archive/v${TERMUX_PKG_VERSION:2}.tar.gz
TERMUX_PKG_SHA256=409f7fe570d3c16558e594421c47bdd130238323c9d6fd6c83dedd2aaeb082a8
TERMUX_PKG_REVISION=1
_COMMIT="787736990ac3b7d5ceaba2697c7d0f58f77bb782"
TERMUX_PKG_SRCURL=https://github.com/LuaJIT/LuaJIT/archive/${_COMMIT}.tar.gz
TERMUX_PKG_SHA256=2e3f74bc279f46cc463abfc67b36e69faaf0366237004771f4cac4bf2a9f5efb
TERMUX_PKG_BREAKS="libluajit-dev"
TERMUX_PKG_REPLACES="libluajit-dev"
TERMUX_PKG_EXTRA_MAKE_ARGS="amalg PREFIX=$TERMUX_PREFIX"

View File

@ -1,6 +1,5 @@
diff -uNr LuaJIT-2.1.0-beta3/src/Makefile LuaJIT-2.1.0-beta3.mod/src/Makefile
--- LuaJIT-2.1.0-beta3/src/Makefile 2017-05-01 22:03:01.000000000 +0300
+++ LuaJIT-2.1.0-beta3.mod/src/Makefile 2019-07-01 21:33:38.426284669 +0300
--- LuaJIT-old/src/Makefile 2021-03-11 01:19:04.000000000 +0600
+++ LuaJIT-new/src/Makefile 2021-07-05 09:46:42.681252928 +0600
@@ -27,7 +27,7 @@
DEFAULT_CC = gcc
#
@ -27,16 +26,16 @@ diff -uNr LuaJIT-2.1.0-beta3/src/Makefile LuaJIT-2.1.0-beta3.mod/src/Makefile
#
##############################################################################
@@ -190,7 +190,7 @@
@@ -192,7 +192,7 @@
CCOPTIONS= $(CCDEBUG) $(ASOPTIONS)
LDOPTIONS= $(CCDEBUG) $(LDFLAGS)
-HOST_CC= $(CC)
+HOST_CC?= $(CC)
HOST_RM= rm -f
HOST_RM?= rm -f
# If left blank, minilua is built and used. You can supply an installed
# copy of (plain) Lua 5.1 or 5.2, plus Lua BitOp. E.g. with: HOST_LUA=lua
@@ -203,17 +203,17 @@
@@ -205,17 +205,17 @@
HOST_ALDFLAGS= $(LDOPTIONS) $(HOST_XLDFLAGS) $(HOST_LDFLAGS)
HOST_ALIBS= $(HOST_XLIBS) $(LIBS) $(HOST_LIBS)
@ -60,7 +59,7 @@ diff -uNr LuaJIT-2.1.0-beta3/src/Makefile LuaJIT-2.1.0-beta3.mod/src/Makefile
TARGET_DYLIBNAME= libluajit-$(ABIVER).$(MAJVER).dylib
TARGET_DYLIBPATH= $(TARGET_LIBPATH)/$(TARGET_DYLIBNAME)
TARGET_DLLNAME= lua$(NODOTABIVER).dll
@@ -585,7 +585,7 @@
@@ -589,7 +589,7 @@
endif
endif