gnuski: add package
This commit is contained in:
parent
e21adaf331
commit
4c6b82cf5d
19
packages/gnuski/Makefile.patch
Normal file
19
packages/gnuski/Makefile.patch
Normal file
@ -0,0 +1,19 @@
|
||||
--- ../Makefile.orig 2020-05-09 17:15:03.947271379 +0200
|
||||
+++ ./Makefile 2020-05-09 17:16:08.437076432 +0200
|
||||
@@ -1,10 +1,12 @@
|
||||
-CC=gcc
|
||||
-FLAGS=-O2 -o gnuski
|
||||
-LIBS=-lncurses
|
||||
+CC ?= gcc
|
||||
+LIBS = -lncurses
|
||||
FILES=main.c objects.c
|
||||
|
||||
all:
|
||||
- $(CC) $(FLAGS) $(FILES) $(LIBS)
|
||||
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $(FILES) $(LIBS) -o gnuski
|
||||
|
||||
clean:
|
||||
rm *~ gnuski
|
||||
+
|
||||
+install:
|
||||
+ install -Dm700 gnuski $(PREFIX)/bin/
|
9
packages/gnuski/build.sh
Normal file
9
packages/gnuski/build.sh
Normal file
@ -0,0 +1,9 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://sourceforge.net/projects/gnuski
|
||||
TERMUX_PKG_DESCRIPTION="Open source clone of Skifree, the old Windows game"
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_MAINTAINER="Henrik Grimler @Grimler91"
|
||||
TERMUX_PKG_VERSION=0.3
|
||||
TERMUX_PKG_SRCURL=https://sourceforge.net/projects/gnuski/files/gnuski/gnuski-${TERMUX_PKG_VERSION}/gnuski-${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=1b629bd29dd6ad362b56055ccdb4c7ad462ff39d7a0deb915753c2096f5f959d
|
||||
TERMUX_PKG_DEPENDS="ncurses"
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
10
packages/gnuski/objects.h.patch
Normal file
10
packages/gnuski/objects.h.patch
Normal file
@ -0,0 +1,10 @@
|
||||
This patch just silences a warning about implicit declaration of setupColors
|
||||
--- ../objects.h.orig 2020-05-09 17:21:04.179875753 +0200
|
||||
+++ ./objects.h 2020-05-09 17:20:45.526561303 +0200
|
||||
@@ -49,4 +49,6 @@
|
||||
/* Checks for collision between a player object and a target */
|
||||
int collision (struct Object player, struct Object target);
|
||||
|
||||
+void setupColors ();
|
||||
+
|
||||
#endif
|
Loading…
Reference in New Issue
Block a user