libjasper: fix linking with libm for on-device builds

This commit is contained in:
Leonid Pliushch 2019-08-16 21:51:47 +03:00
parent 2cb2b7405f
commit 4d3c26d56e
2 changed files with 12 additions and 3 deletions

View File

@ -0,0 +1,12 @@
diff -uNr jasper-version-2.0.16/CMakeLists.txt jasper-version-2.0.16.mod/CMakeLists.txt
--- jasper-version-2.0.16/CMakeLists.txt 2019-03-12 20:04:35.000000000 +0200
+++ jasper-version-2.0.16.mod/CMakeLists.txt 2019-08-16 21:46:51.751881755 +0300
@@ -323,7 +323,7 @@
find_library(MATH_LIBRARY m)
if (NOT MATH_LIBRARY)
- set(MATH_LIBRARY "")
+ set(MATH_LIBRARY "-lm")
endif()
################################################################################

View File

@ -12,6 +12,3 @@ TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-H$TERMUX_PKG_SRCDIR
-B$TERMUX_PKG_BUILDDIR
"
termux_step_pre_configure() {
LDFLAGS+=" -lm"
}