Adding xf86-video-fbdev, xf86-input-evdev, xf86-input mtev and their dependencies libmtdev, libevdev Fixing https://github.com/termux/x11-packages/pull/30#issuecomment-440803079
This commit is contained in:
parent
66690fcaef
commit
547a956ddf
6
x11-packages/libevdev/build.sh
Normal file
6
x11-packages/libevdev/build.sh
Normal file
@ -0,0 +1,6 @@
|
||||
TERMUX_PKG_HOMEPAGE=http://x.org
|
||||
TERMUX_PKG_DESCRIPTION="Kernel evdev device wrapper library"
|
||||
TERMUX_PKG_VERSION=1.5.9
|
||||
TERMUX_PKG_SRCURL=https://www.freedesktop.org/software/libevdev/libevdev-$TERMUX_PKG_VERSION.tar.xz
|
||||
TERMUX_PKG_SHA256=e1663751443bed9d3e76a4fe2caf6fa866a79705d91cacad815c04e706198a75
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--disable-test-run"
|
11
x11-packages/libevdev/tools-Makefile.am.patch
Normal file
11
x11-packages/libevdev/tools-Makefile.am.patch
Normal file
@ -0,0 +1,11 @@
|
||||
+++ ./tools/Makefile.am 2018-06-15 15:24:28.611793003 +0300
|
||||
@@ -1,9 +1,3 @@
|
||||
-noinst_PROGRAMS = libevdev-events
|
||||
-bin_PROGRAMS = \
|
||||
- touchpad-edge-detector \
|
||||
- mouse-dpi-tool \
|
||||
- libevdev-tweak-device
|
||||
-
|
||||
AM_CPPFLAGS = $(GCC_CFLAGS) -I$(top_srcdir) -I$(top_srcdir)/include -I$(top_srcdir)/libevdev
|
||||
libevdev_ldadd = $(top_builddir)/libevdev/libevdev.la
|
||||
|
5
x11-packages/libmtdev/build.sh
Normal file
5
x11-packages/libmtdev/build.sh
Normal file
@ -0,0 +1,5 @@
|
||||
TERMUX_PKG_HOMEPAGE=http://bitmath.org/code/mtdev/
|
||||
TERMUX_PKG_DESCRIPTION="Multitouch Protocol Translation Library"
|
||||
TERMUX_PKG_VERSION=1.1.5
|
||||
TERMUX_PKG_SRCURL=http://bitmath.org/code/mtdev/mtdev-$TERMUX_PKG_VERSION.tar.gz
|
||||
TERMUX_PKG_SHA256=a662924dd09cf538c8df66514da345e40c3cbfa880cc7262bc3b55ee46d0c1f4
|
13
x11-packages/xf86-input-evdev/build.sh
Normal file
13
x11-packages/xf86-input-evdev/build.sh
Normal file
@ -0,0 +1,13 @@
|
||||
TERMUX_PKG_HOMEPAGE=http://x.org/
|
||||
TERMUX_PKG_DESCRIPTION="Kernel evdev device driver"
|
||||
TERMUX_PKG_VERSION=2.10.6
|
||||
TERMUX_PKG_SRCURL=https://www.x.org/archive/individual/driver/xf86-input-evdev-$TERMUX_PKG_VERSION.tar.bz2
|
||||
TERMUX_PKG_SHA256=8726073e81861bc7b2321e76272cbdbd33c7e1a121535a9827977265b9033ec0
|
||||
TERMUX_PKG_BUILD_IN_SRC=yes
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS=""
|
||||
#TERMUX_PKG_HOSTBUILD=true
|
||||
TERMUX_PKG_DEPENDS="xorg-server, libevdev, libmtdev"
|
||||
termux_step_pre_configure() {
|
||||
autoreconf -if
|
||||
export LDFLAGS="$LDFLAGS -lXFree86"
|
||||
}
|
58
x11-packages/xf86-input-evdev/noudev.patch
Normal file
58
x11-packages/xf86-input-evdev/noudev.patch
Normal file
@ -0,0 +1,58 @@
|
||||
+++ xf86-input-evdev/configure.ac 2018-01-14 00:09:05.376956797 +0200
|
||||
@@ -45,7 +45,7 @@
|
||||
|
||||
# Obtain compiler/linker options from server and required extensions
|
||||
PKG_CHECK_MODULES(XORG, [xorg-server >= 1.12] xproto [inputproto >= 2.1.99.3])
|
||||
-PKG_CHECK_MODULES(UDEV, libudev)
|
||||
+#PKG_CHECK_MODULES(UDEV, libudev)
|
||||
|
||||
PKG_CHECK_MODULES(LIBEVDEV, [libevdev >= 0.4])
|
||||
PKG_CHECK_MODULES(MTDEV, mtdev)
|
||||
|
||||
+++ xf86-input-evdev/src/evdev.c 2018-01-14 00:33:56.889011703 +0200
|
||||
@@ -40,7 +40,11 @@
|
||||
|
||||
#include <linux/version.h>
|
||||
#include <sys/stat.h>
|
||||
+
|
||||
+#if 0
|
||||
#include <libudev.h>
|
||||
+#endif
|
||||
+
|
||||
#include <unistd.h>
|
||||
#include <errno.h>
|
||||
#include <fcntl.h>
|
||||
@@ -223,6 +227,7 @@
|
||||
return FALSE;
|
||||
}
|
||||
|
||||
+#if 0
|
||||
static BOOL
|
||||
EvdevDeviceIsVirtual(const char* devicenode)
|
||||
{
|
||||
@@ -257,7 +262,7 @@
|
||||
udev_unref(udev);
|
||||
return rc;
|
||||
}
|
||||
-
|
||||
+#endif
|
||||
|
||||
static EventQueuePtr
|
||||
EvdevNextInQueue(InputInfoPtr pInfo)
|
||||
@@ -2855,6 +2860,7 @@
|
||||
if (rc != Success)
|
||||
return;
|
||||
|
||||
+#if 0
|
||||
if (EvdevDeviceIsVirtual(pEvdev->device))
|
||||
{
|
||||
BOOL virtual = 1;
|
||||
@@ -2867,7 +2873,7 @@
|
||||
|
||||
XISetDevicePropertyDeletable(dev, prop_virtual, FALSE);
|
||||
}
|
||||
-
|
||||
+#endif
|
||||
|
||||
XISetDevicePropertyDeletable(dev, prop_device, FALSE);
|
||||
|
18
x11-packages/xf86-input-mtev/build.sh
Normal file
18
x11-packages/xf86-input-mtev/build.sh
Normal file
@ -0,0 +1,18 @@
|
||||
TERMUX_PKG_HOMEPAGE=http://x.org/
|
||||
TERMUX_PKG_DESCRIPTION="X.org mtev driver"
|
||||
TERMUX_PKG_VERSION=1.0
|
||||
TERMUX_PKG_SRCURL=https://github.com/twaik/xorg-input-mtev/archive/$TERMUX_PKG_VERSION.tar.gz
|
||||
TERMUX_PKG_SHA256=faecee79322b82c56b35422be3077f7c85a6d16d5ed8e3b3be809b7e765dd4ae
|
||||
TERMUX_PKG_BUILD_IN_SRC=yes
|
||||
TERMUX_PKG_CLANG=no
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS=""
|
||||
TERMUX_PKG_DEPENDS="libmtdev, xorg-server"
|
||||
|
||||
termux_step_make() {
|
||||
${CC} -o mtev_drv.so -shared -Wl,-soname -Wl,mtev_drv.so -lXFree86 `pkg-config --libs mtdev` -I$TERMUX_PREFIX/include/xorg -I$TERMUX_PREFIX/include/pixman-1 `pkg-config --cflags mtdev` ${CFLAGS} ${LDFLAGS} src/caps.c src/hw.c src/mtouch.c src/multitouch.c
|
||||
}
|
||||
|
||||
termux_step_make_install() {
|
||||
install -d "$TERMUX_PREFIX/lib/xorg/modules/input"
|
||||
install -m 755 mtev_drv.so "$TERMUX_PREFIX/lib/xorg/modules/input/mtev_drv.so"
|
||||
}
|
9
x11-packages/xf86-video-fbdev/build.sh
Normal file
9
x11-packages/xf86-video-fbdev/build.sh
Normal file
@ -0,0 +1,9 @@
|
||||
TERMUX_PKG_VERSION=0.5.0
|
||||
TERMUX_PKG_SRCURL=https://www.x.org/archive/individual/driver/xf86-video-fbdev-$TERMUX_PKG_VERSION.tar.bz2
|
||||
TERMUX_PKG_SHA256=dcc3d85f378022180e437a9ec00a59b6cb7680ff79c40394d695060af2374699
|
||||
TERMUX_PKG_BUILD_IN_SRC=yes
|
||||
TERMUX_PKG_DEPENDS="xorg-server"
|
||||
|
||||
termux_step_pre_configure() {
|
||||
export LDFLAGS="$LDFLAGS -lXFree86"
|
||||
}
|
26
x11-packages/xf86-video-fbdev/fbdev.c.patch
Normal file
26
x11-packages/xf86-video-fbdev/fbdev.c.patch
Normal file
@ -0,0 +1,26 @@
|
||||
+++ ./src/fbdev.c 2018-06-15 14:47:31.812112392 +0300
|
||||
@@ -443,7 +443,7 @@
|
||||
|
||||
fPtr->pEnt = xf86GetEntityInfo(pScrn->entityList[0]);
|
||||
|
||||
-#ifndef XSERVER_LIBPCIACCESS
|
||||
+#if 0
|
||||
pScrn->racMemFlags = RAC_FB | RAC_COLORMAP | RAC_CURSOR | RAC_VIEWPORT;
|
||||
/* XXX Is this right? Can probably remove RAC_FB */
|
||||
pScrn->racIoFlags = RAC_FB | RAC_COLORMAP | RAC_CURSOR | RAC_VIEWPORT;
|
||||
@@ -658,6 +658,7 @@
|
||||
"unrecognised fbdev hardware type (%d)\n", type);
|
||||
return FALSE;
|
||||
}
|
||||
+ #ifndef __ANDROID__
|
||||
if (xf86LoadSubModule(pScrn, "fb") == NULL) {
|
||||
FBDevFreeRec(pScrn);
|
||||
return FALSE;
|
||||
@@ -672,6 +673,7 @@
|
||||
return FALSE;
|
||||
}
|
||||
}
|
||||
+ #endif // __ANDROID__
|
||||
|
||||
TRACE_EXIT("PreInit");
|
||||
return TRUE;
|
@ -58,7 +58,7 @@ TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||
LIBS=-landroid-shmem"
|
||||
|
||||
termux_step_pre_configure () {
|
||||
CFLAGS+=" -DFNDELAY=O_NDELAY"
|
||||
CFLAGS+=" -DFNDELAY=O_NDELAY -Wint-to-pointer-cast"
|
||||
CPPFLAGS+=" -I${TERMUX_PREFIX}/include/libdrm"
|
||||
|
||||
if [ -n "${TERMUX_DEBUG}" ]; then
|
||||
|
10
x11-packages/xorg-server/linux_noop.patch
Normal file
10
x11-packages/xorg-server/linux_noop.patch
Normal file
@ -0,0 +1,10 @@
|
||||
+++ ./hw/xfree86/os-support/linux/Makefile.am 2018-11-21 22:50:02.949575248 +0200
|
||||
@@ -18,7 +18,7 @@
|
||||
XORG_CFLAGS += $(DBUS_CFLAGS)
|
||||
endif
|
||||
|
||||
-liblinux_la_SOURCES = linux.h lnx_init.c lnx_video.c \
|
||||
+liblinux_la_SOURCES = linux.h lnx_init.c $(srcdir)/../shared/ioperm_noop.c \
|
||||
lnx_agp.c lnx_kmod.c lnx_bell.c lnx_platform.c \
|
||||
$(srcdir)/../shared/VTsw_usl.c \
|
||||
$(srcdir)/../shared/posix_tty.c \
|
Loading…
Reference in New Issue
Block a user