tsocks: do not link `saveme` statically

Fixes on-device builds.
This commit is contained in:
Leonid Pliushch 2019-08-16 03:40:10 +03:00
parent ee60f2ab30
commit 5501dac138
2 changed files with 13 additions and 1 deletions

View File

@ -2,7 +2,7 @@ TERMUX_PKG_HOMEPAGE=http://tsocks.sf.net
TERMUX_PKG_DESCRIPTION="transparent network access through a SOCKS 4 or 5 proxy"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_VERSION=1.8beta5
TERMUX_PKG_REVISION=2
TERMUX_PKG_REVISION=3
TERMUX_PKG_MAINTAINER="Oliver Schmidhauser @Neo-Oli"
TERMUX_PKG_SRCURL=https://downloads.sourceforge.net/project/tsocks/tsocks/1.8%20beta%205/tsocks-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=849d7ef5af80d03e76cc05ed9fb8fa2bcc2b724b51ebfd1b6be11c7863f5b347

View File

@ -0,0 +1,12 @@
diff -uNr tsocks-1.8/Makefile.in tsocks-1.8.mod/Makefile.in
--- tsocks-1.8/Makefile.in 2002-03-16 12:12:40.000000000 +0200
+++ tsocks-1.8.mod/Makefile.in 2019-08-16 03:39:24.865614750 +0300
@@ -47,7 +47,7 @@
${SHCC} ${CFLAGS} ${INCLUDES} -o ${INSPECT} ${INSPECT}.c ${COMMON}.o ${LIBS}
${SAVE}: ${SAVE}.c
- ${SHCC} ${CFLAGS} ${INCLUDES} -static -o ${SAVE} ${SAVE}.c
+ ${SHCC} ${CFLAGS} ${INCLUDES} -o ${SAVE} ${SAVE}.c
${SHLIB}: ${OBJS} ${COMMON}.o ${PARSER}.o
${SHCC} ${CFLAGS} ${INCLUDES} -nostdlib -shared -o ${SHLIB} ${OBJS} ${COMMON}.o ${PARSER}.o ${DYNLIB_FLAGS} ${SPECIALLIBS} ${LIBS}