openjpeg: remove unnecessary patches after update

This commit is contained in:
Tom Yan 2019-04-06 00:20:11 +08:00 committed by Leonid Pliushch
parent 1db41f23a6
commit 55c8d8fef7
2 changed files with 0 additions and 39 deletions

View File

@ -1,13 +0,0 @@
diff --git a/cmake/OpenJPEGConfig.cmake.in b/cmake/OpenJPEGConfig.cmake.in
index b20294ca..6a2f4baf 100644
--- a/cmake/OpenJPEGConfig.cmake.in
+++ b/cmake/OpenJPEGConfig.cmake.in
@@ -26,7 +26,7 @@ get_filename_component(SELF_DIR "${CMAKE_CURRENT_LIST_FILE}" PATH)
if(EXISTS ${SELF_DIR}/OpenJPEGTargets.cmake)
# This is an install tree
include(${SELF_DIR}/OpenJPEGTargets.cmake)
- get_filename_component(OPENJPEG_INCLUDE_ROOT "${SELF_DIR}/../../@OPENJPEG_INSTALL_INCLUDE_DIR@" ABSOLUTE)
+ get_filename_component(OPENJPEG_INCLUDE_ROOT "${SELF_DIR}/../../../@OPENJPEG_INSTALL_INCLUDE_DIR@" ABSOLUTE)
set(OPENJPEG_INCLUDE_DIRS ${OPENJPEG_INCLUDE_ROOT})
else()

View File

@ -1,26 +0,0 @@
From 66297f07a43d2770a97c8456d20202f3d051d980 Mon Sep 17 00:00:00 2001
From: Even Rouault <even.rouault@spatialys.com>
Date: Mon, 9 Oct 2017 11:40:43 +0200
Subject: [PATCH] Unix build: fix regression of 2.3.0 where a shared-only or
static-only build lacks the installation target for the library (#1019, fixes
regression introduced by 3dfc6ca2bcf06fd1adb6b6b4cecc6c092f08ba0b)
---
src/lib/openjp2/CMakeLists.txt | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/lib/openjp2/CMakeLists.txt b/src/lib/openjp2/CMakeLists.txt
index 0b452038..f8990ccf 100644
--- a/src/lib/openjp2/CMakeLists.txt
+++ b/src/lib/openjp2/CMakeLists.txt
@@ -99,6 +99,7 @@ else()
set(INSTALL_LIBS ${OPENJPEG_LIBRARY_NAME} openjp2_static)
else()
add_library(${OPENJPEG_LIBRARY_NAME} ${OPENJPEG_SRCS})
+ set(INSTALL_LIBS ${OPENJPEG_LIBRARY_NAME})
endif()
endif()
--
2.21.0