new package: fact++

This commit is contained in:
Tee KOBAYASHI 2022-04-05 10:50:09 +09:00 committed by Henrik Grimler
parent ffa1ed6051
commit 562dafc7ca
No known key found for this signature in database
GPG Key ID: B0076E490B71616B
5 changed files with 50 additions and 0 deletions

13
packages/fact++/build.sh Normal file
View File

@ -0,0 +1,13 @@
TERMUX_PKG_HOMEPAGE=https://bitbucket.org/dtsarkov/factplusplus
TERMUX_PKG_DESCRIPTION="Re-implementation of the well-known FaCT Description Logic (DL) Reasoner"
TERMUX_PKG_LICENSE="LGPL-2.1"
TERMUX_PKG_LICENSE_FILE="licensing/FaCT++.license.txt, licensing/lgpl-2.1.txt"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.6.5
TERMUX_PKG_SRCURL=https://bitbucket.org/dtsarkov/factplusplus/downloads/FaCTpp-src-v${TERMUX_PKG_VERSION}.zip
TERMUX_PKG_SHA256=d76ce04073ad6523eeb3fc761c012b20e3062ff78406f9da3fd2076828264e4e
TERMUX_PKG_DEPENDS="libc++"
termux_step_pre_configure() {
TERMUX_PKG_SRCDIR+="/src"
}

View File

@ -0,0 +1,7 @@
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -10,4 +10,3 @@
add_subdirectory(Kernel)
add_subdirectory(FaCT++)
add_subdirectory(FaCT++.C)
-add_subdirectory(FaCT++.JNI)

View File

@ -0,0 +1,10 @@
--- a/src/FaCT++/CMakeLists.txt
+++ b/src/FaCT++/CMakeLists.txt
@@ -14,4 +14,6 @@
# Executable
add_executable(FaCT++ ${SOURCE_FILES})
-target_link_libraries(FaCT++ LINK_PUBLIC Kernel)
+target_link_libraries(FaCT++ LINK_PUBLIC fact)
+
+install(TARGETS FaCT++ DESTINATION bin)

View File

@ -0,0 +1,9 @@
--- a/src/FaCT++.C/CMakeLists.txt
+++ b/src/FaCT++.C/CMakeLists.txt
@@ -13,3 +13,6 @@
# allow library users to find headers
target_include_directories(fact PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})
+
+install(TARGETS fact DESTINATION lib)
+install(FILES fact.h DESTINATION include)

View File

@ -0,0 +1,11 @@
--- a/src/Kernel/AtomicDecomposer.cpp
+++ b/src/Kernel/AtomicDecomposer.cpp
@@ -17,6 +17,8 @@
Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
*/
+#include <ostream>
+
#include "AtomicDecomposer.h"
#include "logging.h"
#include "ProgressIndicatorInterface.h"