coreutils: Update from 8.28 to 8.29
This commit is contained in:
parent
b070288dcd
commit
5868bd11c5
@ -1,38 +0,0 @@
|
||||
diff -u -r ../coreutils-8.26/Makefile.in ./Makefile.in
|
||||
--- ../coreutils-8.26/Makefile.in 2016-11-30 13:34:55.000000000 -0500
|
||||
+++ ./Makefile.in 2016-11-30 19:10:09.902334174 -0500
|
||||
@@ -14622,32 +14624,8 @@
|
||||
@SINGLE_BINARY_FALSE@man/yes.1: src/yes$(EXEEXT)
|
||||
|
||||
.x.1:
|
||||
- $(AM_V_GEN)name=`echo $@ | sed 's|.*/||; s|\.1$$||'` || exit 1; \
|
||||
- case $$name in \
|
||||
- install) prog='ginstall'; argv=$$name;; \
|
||||
- test) prog='['; argv='[';; \
|
||||
- *) prog=$$name; argv=$$prog;; \
|
||||
- esac; \
|
||||
- rm -f $@ $@-t \
|
||||
- && t=$*.td \
|
||||
- && rm -rf $$t \
|
||||
- && $(MKDIR_P) $$t \
|
||||
- && (cd $$t && $(LN_S) '$(abs_top_builddir)/src/'$$prog$(EXEEXT) \
|
||||
- $$argv$(EXEEXT)) \
|
||||
- && : $${SOURCE_DATE_EPOCH=`cat $(srcdir)/.timestamp 2>/dev/null || :`} \
|
||||
- && export SOURCE_DATE_EPOCH && $(run_help2man) \
|
||||
- --source='$(PACKAGE_STRING)' \
|
||||
- --include=$(srcdir)/man/$$name.x \
|
||||
- --output=$$t/$$name.1 \
|
||||
- --info-page='\(aq(coreutils) '$$name' invocation\(aq' \
|
||||
- $$t/$$argv$(EXEEXT) \
|
||||
- && sed \
|
||||
- -e 's|$*\.td/||g' \
|
||||
- -e '/For complete documentation/d' \
|
||||
- $$t/$$name.1 > $@-t \
|
||||
- && rm -rf $$t \
|
||||
- && chmod a-w $@-t \
|
||||
- && mv $@-t $@
|
||||
+ # Use man pages generated by help2man in the host build.
|
||||
+ cp $(top_srcdir)/../host-build/$@ $@
|
||||
.PHONY: check-root
|
||||
check-root:
|
||||
$(MAKE) check TESTS='$(root_tests)' SUBDIRS=.
|
@ -1,7 +1,7 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/coreutils/
|
||||
TERMUX_PKG_DESCRIPTION="Basic file, shell and text manipulation utilities from the GNU project"
|
||||
TERMUX_PKG_VERSION=8.28
|
||||
TERMUX_PKG_SHA256=1117b1a16039ddd84d51a9923948307cfa28c2cea03d1a2438742253df0a0c65
|
||||
TERMUX_PKG_VERSION=8.29
|
||||
TERMUX_PKG_SHA256=92d0fa1c311cacefa89853bdb53c62f4110cdfda3820346b59cbd098f40f955e
|
||||
TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/coreutils/coreutils-${TERMUX_PKG_VERSION}.tar.xz
|
||||
# pinky has no usage on Android.
|
||||
# df does not work either, let system binary prevail.
|
||||
@ -14,12 +14,10 @@ gl_cv_host_operating_system=Android
|
||||
--enable-single-binary=symlinks
|
||||
--without-gmp
|
||||
"
|
||||
TERMUX_PKG_EXTRA_HOSTBUILD_CONFIGURE_ARGS="$TERMUX_PKG_EXTRA_CONFIGURE_ARGS"
|
||||
TERMUX_PKG_BUILD_IN_SRC=yes
|
||||
# Host build for man pages generated by help2man, see makefile.patch:
|
||||
TERMUX_PKG_HOSTBUILD=yes
|
||||
|
||||
termux_step_pre_configure() {
|
||||
CPPFLAGS+=" -DDEFAULT_TMPDIR=\\\"$TERMUX_PREFIX/tmp\\\""
|
||||
|
||||
# Handle issue with too deep folder under Docker:
|
||||
# https://github.com/moby/moby/issues/13451
|
||||
# https://bugzilla.yoctoproject.org/show_bug.cgi?id=7338
|
||||
|
@ -1,15 +0,0 @@
|
||||
diff -u -r ../coreutils-8.22/src/dd.c ./src/dd.c
|
||||
--- ../coreutils-8.22/src/dd.c 2013-12-04 15:48:30.000000000 +0100
|
||||
+++ ./src/dd.c 2014-02-07 01:21:03.000000000 +0100
|
||||
@@ -1551,7 +1551,11 @@
|
||||
|
||||
#ifdef __linux__
|
||||
|
||||
+#ifdef __ANDROID__
|
||||
+# include <linux/mtio.h>
|
||||
+#else
|
||||
# include <sys/mtio.h>
|
||||
+#endif
|
||||
|
||||
# define MT_SAME_POSITION(P, Q) \
|
||||
((P).mt_resid == (Q).mt_resid \
|
@ -1,19 +0,0 @@
|
||||
diff -u -r ../coreutils-8.26/lib/stat-size.h ./lib/stat-size.h
|
||||
--- ../coreutils-8.26/lib/stat-size.h 2016-07-15 15:47:39.000000000 -0400
|
||||
+++ ./lib/stat-size.h 2017-01-09 16:49:31.758957157 -0500
|
||||
@@ -71,9 +71,13 @@
|
||||
suffice, since "cat" sometimes multiplies the result by 4.) If
|
||||
anyone knows of a system for which this limit is too small, please
|
||||
report it as a bug in this code. */
|
||||
-# define ST_BLKSIZE(statbuf) ((0 < (statbuf).st_blksize \
|
||||
+/* Termux patch: Cast to long since on 32-bit Android this otherwise
|
||||
+ results in an unsigned long, which breaks comparison with e.g.
|
||||
+ signed off_t in tail.c, see:
|
||||
+ https://github.com/termux/termux-app/issues/233 */
|
||||
+# define ST_BLKSIZE(statbuf) ((long) ((0 < (statbuf).st_blksize \
|
||||
&& (statbuf).st_blksize <= ((size_t)-1) / 8 + 1) \
|
||||
- ? (statbuf).st_blksize : DEV_BSIZE)
|
||||
+ ? (statbuf).st_blksize : DEV_BSIZE))
|
||||
# if defined hpux || defined __hpux__ || defined __hpux
|
||||
/* HP-UX counts st_blocks in 1024-byte units.
|
||||
This loses when mixing HP-UX and BSD file systems with NFS. */
|
@ -1,35 +0,0 @@
|
||||
diff -u -r ../coreutils-8.22/src/pinky.c ./src/pinky.c
|
||||
--- ../coreutils-8.22/src/pinky.c 2013-12-04 15:48:30.000000000 +0100
|
||||
+++ ./src/pinky.c 2014-02-07 01:18:15.000000000 +0100
|
||||
@@ -242,13 +242,13 @@
|
||||
printf (" %19s", _(" ???"));
|
||||
else
|
||||
{
|
||||
- char *const comma = strchr (pw->pw_gecos, ',');
|
||||
+ char *const comma = strchr ("", ',');
|
||||
char *result;
|
||||
|
||||
if (comma)
|
||||
*comma = '\0';
|
||||
|
||||
- result = create_fullname (pw->pw_gecos, pw->pw_name);
|
||||
+ result = create_fullname ("", pw->pw_name);
|
||||
printf (" %-19.19s", result);
|
||||
free (result);
|
||||
}
|
||||
@@ -323,13 +323,13 @@
|
||||
}
|
||||
else
|
||||
{
|
||||
- char *const comma = strchr (pw->pw_gecos, ',');
|
||||
+ char *const comma = strchr ("", ',');
|
||||
char *result;
|
||||
|
||||
if (comma)
|
||||
*comma = '\0';
|
||||
|
||||
- result = create_fullname (pw->pw_gecos, pw->pw_name);
|
||||
+ result = create_fullname ("", pw->pw_name);
|
||||
printf (" %s", result);
|
||||
free (result);
|
||||
}
|
@ -1,21 +0,0 @@
|
||||
diff -u -r ../coreutils-8.23/src/shred.c ./src/shred.c
|
||||
--- ../coreutils-8.23/src/shred.c 2014-07-11 13:00:07.000000000 +0200
|
||||
+++ ./src/shred.c 2014-07-29 15:26:23.000000000 +0200
|
||||
@@ -80,7 +80,7 @@
|
||||
#include <assert.h>
|
||||
#include <setjmp.h>
|
||||
#include <sys/types.h>
|
||||
-#ifdef __linux__
|
||||
+#if defined(__linux__) && !defined(__ANDROID__)
|
||||
# include <sys/mtio.h>
|
||||
#endif
|
||||
|
||||
@@ -388,7 +388,7 @@
|
||||
{
|
||||
if (S_ISCHR (st->st_mode))
|
||||
{
|
||||
-#ifdef __linux__
|
||||
+#if defined(__linux__) && !defined(__ANDROID__)
|
||||
/* In the Linux kernel, lseek does not work on tape devices; it
|
||||
returns a randomish value instead. Try the low-level tape
|
||||
rewind operation first. */
|
@ -1,13 +0,0 @@
|
||||
diff -u -r ../coreutils-8.27/src/hostid.c ./src/hostid.c
|
||||
--- ../coreutils-8.27/src/hostid.c 2017-01-01 23:34:24.000000000 +0100
|
||||
+++ ./src/hostid.c 2017-07-07 00:28:59.202840547 +0200
|
||||
@@ -75,7 +75,9 @@
|
||||
usage (EXIT_FAILURE);
|
||||
}
|
||||
|
||||
+#ifndef __ANDROID__
|
||||
id = gethostid ();
|
||||
+#endif
|
||||
|
||||
/* POSIX says gethostid returns a "32-bit identifier" but is silent
|
||||
whether it's sign-extended. Turn off any sign-extension. This
|
@ -1,12 +0,0 @@
|
||||
diff -u -r ../coreutils-8.27/src/sort.c ./src/sort.c
|
||||
--- ../coreutils-8.27/src/sort.c 2017-01-01 23:34:24.000000000 +0100
|
||||
+++ ./src/sort.c 2017-07-02 23:32:35.261252848 +0200
|
||||
@@ -101,7 +101,7 @@
|
||||
#endif
|
||||
|
||||
#ifndef DEFAULT_TMPDIR
|
||||
-# define DEFAULT_TMPDIR "/tmp"
|
||||
+# define DEFAULT_TMPDIR "@TERMUX_PREFIX@/tmp"
|
||||
#endif
|
||||
|
||||
/* Maximum number of lines to merge every time a NODE is taken from
|
@ -1,12 +0,0 @@
|
||||
diff -u -r ../coreutils-8.27/src/tac.c ./src/tac.c
|
||||
--- ../coreutils-8.27/src/tac.c 2017-02-18 04:18:29.000000000 +0100
|
||||
+++ ./src/tac.c 2017-07-02 23:32:45.765137258 +0200
|
||||
@@ -67,7 +67,7 @@
|
||||
|
||||
|
||||
#ifndef DEFAULT_TMPDIR
|
||||
-# define DEFAULT_TMPDIR "/tmp"
|
||||
+# define DEFAULT_TMPDIR "@TERMUX_PREFIX@/tmp"
|
||||
#endif
|
||||
|
||||
/* The number of bytes per atomic read. */
|
Loading…
Reference in New Issue
Block a user