frotz: update to 2.50, switch upstream url
This commit is contained in:
parent
b7323afbbc
commit
5e341a2c19
11
packages/frotz/Makefile.patch
Normal file
11
packages/frotz/Makefile.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ../Makefile.orig 2019-12-21 16:18:41.380353060 +0100
|
||||
+++ ./Makefile 2019-12-21 16:42:45.894677981 +0100
|
||||
@@ -297,7 +300,7 @@
|
||||
$(NAME)src/doc/*.6 $(NAME)src/doc/frotz.conf* \
|
||||
$(NAME)src/doc/Xresources > /dev/null
|
||||
else
|
||||
- @echo "Not in a git repository or git command not found. Cannot make a tarball."
|
||||
+ @echo "Not in a git repository or git command not found. Cannot make a tarball."
|
||||
endif
|
||||
|
||||
all: $(FROTZ_BIN) $(DFROTZ_BIN) $(SFROTZ_BIN)
|
@ -1,23 +1,19 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://github.com/DavidGriffith/frotz
|
||||
TERMUX_PKG_HOMEPAGE=https://gitlab.com/DavidGriffith/frotz
|
||||
TERMUX_PKG_DESCRIPTION="Interpreter for Infocom and other Z-machine interactive fiction (IF) games"
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
# frotz does not depend on dialog or curl, but the zgames script we bundle below in termux_step_make_install() do.
|
||||
TERMUX_PKG_VERSION=2.50
|
||||
TERMUX_PKG_SRCURL=https://gitlab.com/DavidGriffith/frotz/-/archive/${TERMUX_PKG_VERSION}/frotz-${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=0352dfc458fb5cc7a932c568bd86aabdde943bee25ea0cce58c46f8c893f554f
|
||||
TERMUX_PKG_DEPENDS="ncurses, dialog, curl"
|
||||
TERMUX_PKG_VERSION=2.44
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_SRCURL=https://github.com/DavidGriffith/frotz/archive/${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=dbb5eb3bc95275dcb984c4bdbaea58bc1f1b085b20092ce6e86d9f0bf3ba858f
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
|
||||
termux_step_pre_configure () {
|
||||
CFLAGS+=" -Drindex=strrchr"
|
||||
export CURSES_CFLAGS="-I$TERMUX_PREFIX/include"
|
||||
export SYSCONFDIR="$TERMUX_PREFIX/include"
|
||||
export SOUND_TYPE="none"
|
||||
}
|
||||
|
||||
termux_step_make () {
|
||||
CC="$CC $CFLAGS $CPPFLAGS $LDFLAGS" PREFIX=$TERMUX_PREFIX make -j $TERMUX_MAKE_PROCESSES install
|
||||
}
|
||||
|
||||
termux_step_make_install () {
|
||||
cp $TERMUX_PKG_BUILDER_DIR/zgames $TERMUX_PREFIX/bin/zgames
|
||||
chmod +x $TERMUX_PREFIX/bin/zgames
|
||||
termux_step_post_make_install () {
|
||||
install -m755 $TERMUX_PKG_BUILDER_DIR/zgames $TERMUX_PREFIX/bin/zgames
|
||||
}
|
||||
|
@ -1,99 +0,0 @@
|
||||
diff -u -r ../frotz-2.43d/Makefile ./Makefile
|
||||
--- ../frotz-2.43d/Makefile 2012-01-03 09:32:58.000000000 +0100
|
||||
+++ ./Makefile 2014-03-06 22:50:06.580642826 +0100
|
||||
@@ -1,22 +1,22 @@
|
||||
# Define your C compiler. I recommend gcc if you have it.
|
||||
# MacOS users should use "cc" even though it's really "gcc".
|
||||
#
|
||||
-CC = gcc
|
||||
+#CC = gcc
|
||||
#CC = cc
|
||||
|
||||
# Define your optimization flags. Most compilers understand -O and -O2,
|
||||
# Standard (note: Solaris on UltraSparc using gcc 2.8.x might not like this.)
|
||||
#
|
||||
-OPTS = -O2
|
||||
+OPTS = -Os
|
||||
|
||||
# Pentium with gcc 2.7.0 or better
|
||||
#OPTS = -O2 -fomit-frame-pointer -malign-functions=2 -malign-loops=2 \
|
||||
#-malign-jumps=2
|
||||
|
||||
# Define where you want Frotz installed. Usually this is /usr/local
|
||||
-PREFIX = /usr/local
|
||||
+#PREFIX = /usr/local
|
||||
|
||||
-MAN_PREFIX = $(PREFIX)
|
||||
+MAN_PREFIX = $(PREFIX)/share
|
||||
#MAN_PREFIX = /usr/local/share
|
||||
|
||||
CONFIG_DIR = $(PREFIX)/etc
|
||||
@@ -24,7 +24,7 @@
|
||||
|
||||
# Define where you want Frotz to look for frotz.conf.
|
||||
#
|
||||
-CONFIG_DIR = /usr/local/etc
|
||||
+#CONFIG_DIR = /usr/local/etc
|
||||
#CONFIG_DIR = /etc
|
||||
#CONFIG_DIR = /usr/pkg/etc
|
||||
#CONFIG_DIR =
|
||||
@@ -73,8 +73,8 @@
|
||||
# curses library won't work, comment out the first option and uncomment
|
||||
# the second.
|
||||
#
|
||||
-CURSES = -lcurses
|
||||
-#CURSES = -lncurses
|
||||
+#CURSES = -lcurses
|
||||
+CURSES = -lncurses
|
||||
|
||||
# Uncomment this if your need to use ncurses instead of the
|
||||
# vendor-supplied curses library. This just tells the compile process
|
||||
@@ -187,24 +187,24 @@
|
||||
$(COMMON_TARGET): $(COMMON_OBJECT)
|
||||
@echo
|
||||
@echo "Archiving common code..."
|
||||
- ar rc $(COMMON_TARGET) $(COMMON_OBJECT)
|
||||
- ranlib $(COMMON_TARGET)
|
||||
+ $(AR) rc $(COMMON_TARGET) $(COMMON_OBJECT)
|
||||
+ $(RANLIB) $(COMMON_TARGET)
|
||||
@echo
|
||||
|
||||
curses_lib: config_curses $(CURSES_TARGET)
|
||||
$(CURSES_TARGET): $(CURSES_OBJECT)
|
||||
@echo
|
||||
@echo "Archiving curses interface code..."
|
||||
- ar rc $(CURSES_TARGET) $(CURSES_OBJECT)
|
||||
- ranlib $(CURSES_TARGET)
|
||||
+ $(AR) rc $(CURSES_TARGET) $(CURSES_OBJECT)
|
||||
+ $(RANLIB) $(CURSES_TARGET)
|
||||
@echo
|
||||
|
||||
dumb_lib: $(DUMB_TARGET)
|
||||
$(DUMB_TARGET): $(DUMB_OBJECT)
|
||||
@echo
|
||||
@echo "Archiving dumb interface code..."
|
||||
- ar rc $(DUMB_TARGET) $(DUMB_OBJECT)
|
||||
- ranlib $(DUMB_TARGET)
|
||||
+ $(AR) rc $(DUMB_TARGET) $(DUMB_OBJECT)
|
||||
+ $(RANLIB) $(DUMB_TARGET)
|
||||
@echo
|
||||
|
||||
soundcard.h:
|
||||
@@ -213,7 +213,7 @@
|
||||
fi
|
||||
|
||||
install: $(NAME)
|
||||
- strip $(BINNAME)$(EXTENSION)
|
||||
+ $(STRIP) $(BINNAME)$(EXTENSION)
|
||||
install -d $(PREFIX)/bin
|
||||
install -d $(MAN_PREFIX)/man/man6
|
||||
install -c -m 755 $(BINNAME)$(EXTENSION) $(PREFIX)/bin
|
||||
@@ -226,7 +226,7 @@
|
||||
deinstall: uninstall
|
||||
|
||||
install_dumb: d$(NAME)
|
||||
- strip d$(BINNAME)$(EXTENSION)
|
||||
+ $(STRIP) d$(BINNAME)$(EXTENSION)
|
||||
install -d $(PREFIX)/bin
|
||||
install -d $(MAN_PREFIX)/man/man6
|
||||
install -c -m 755 d$(BINNAME)$(EXTENSION) $(PREFIX)/bin
|
11
packages/frotz/ux_frotz.h.patch
Normal file
11
packages/frotz/ux_frotz.h.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ../ux_frotz.h.orig 2019-12-21 18:00:15.498402287 +0100
|
||||
+++ ./src/curses/ux_frotz.h 2019-12-21 18:00:32.478537779 +0100
|
||||
@@ -40,7 +40,7 @@
|
||||
#define ERR_REPORT_DEF ERR_REPORT_ONCE
|
||||
#define QUETZAL_DEF 1
|
||||
#define SAVEDIR_DEF "if-saves"
|
||||
-#define ZCODEPATH_DEF "/usr/games/zcode:/usr/local/games/zcode"
|
||||
+#define ZCODEPATH_DEF "@TERMUX_PREFIX@/usr/games/zcode:@TERMUX_PREFIX@/usr/local/games/zcode"
|
||||
|
||||
|
||||
#define LINELEN 256 /* for getconfig() */
|
Loading…
Reference in New Issue
Block a user