Polybar:Updated to v3.6.1

Signed-off-by: NoNameMan1231 <87801676+NoNameMan1231@users.noreply.github.com>
This commit is contained in:
NoNameMan1231 2022-04-01 11:31:26 +08:00 committed by Yaksh Bariya
parent c8f78f1472
commit 5fe300628f
No known key found for this signature in database
GPG Key ID: F7486BA7D3D27581
3 changed files with 34 additions and 28 deletions

View File

@ -2,11 +2,10 @@ TERMUX_PKG_HOMEPAGE=https://polybar.github.io
TERMUX_PKG_DESCRIPTION="A fast and easy-to-use status bar"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_MAINTAINER="Tristan Ross <spaceboyross@yandex.com>"
TERMUX_PKG_VERSION=3.5.6
TERMUX_PKG_REVISION=2
TERMUX_PKG_VERSION=3.6.1
TERMUX_PKG_SRCURL="https://github.com/polybar/polybar/releases/download/${TERMUX_PKG_VERSION}/polybar-${TERMUX_PKG_VERSION}.tar.gz"
TERMUX_PKG_SHA256=dfe602fc6ac96eac2ae0f5deb2f87e0dd1f81ea5d0f04ad3b3bfd71efd5cc038
TERMUX_PKG_DEPENDS="jsoncpp, pulseaudio, fontconfig, freetype, libandroid-glob, libandroid-shmem, libc++, libcairo, libcurl, libxcb, xcb-util-cursor, xcb-util-image, xcb-util-xrm, xcb-util-wm"
TERMUX_PKG_SHA256=a898ba8c847895be41efe5a31bb1b839da2c10b130b8411d5016982fbaadff7b
TERMUX_PKG_DEPENDS="jsoncpp, pulseaudio, fontconfig, freetype, libandroid-glob, libandroid-shmem, libc++, libcairo, libcurl, libuv, libxcb, xcb-util-cursor, xcb-util-image, xcb-util-xrm, xcb-util-wm"
TERMUX_PKG_BUILD_IN_SRC=true
termux_step_pre_configure() {

View File

@ -0,0 +1,31 @@
--- polybar-3.6.1/CMakeLists.txt 2022-03-05 21:29:15.000000000 +0800
+++ polybar-3.6.1.mod/CMakeLists.txt 2022-03-30 19:20:54.933488932 +0800
@@ -63,7 +63,7 @@
if(BUILD_CONFIG)
install(FILES ${CMAKE_SOURCE_DIR}/doc/config.ini
- DESTINATION /etc/${PROJECT_NAME}
+ DESTINATION @TERMUX_PREFIX@/etc/${PROJECT_NAME}
COMPONENT config)
endif()
--- polybar-3.6.1/cmake/02-opts.cmake 2022-03-05 21:29:15.000000000 +0800
+++ polybar-3.6.1.mod/cmake/02-opts.cmake 2022-03-30 19:21:52.283488910 +0800
@@ -1,6 +1,6 @@
set(SETTING_ALSA_SOUNDCARD "default"
CACHE STRING "Name of the ALSA soundcard driver")
-set(SETTING_BSPWM_SOCKET_PATH "/tmp/bspwm_0_0-socket"
+set(SETTING_BSPWM_SOCKET_PATH "@TERMUX_PREFIX@/tmp/bspwm_0_0-socket"
CACHE STRING "Path to bspwm socket")
set(SETTING_BSPWM_STATUS_PREFIX "W"
CACHE STRING "Prefix prepended to the bspwm status line")
@@ -16,7 +16,7 @@
CACHE STRING "Path to file containing cpu info")
set(SETTING_PATH_MEMORY_INFO "/proc/meminfo"
CACHE STRING "Path to file containing memory info")
-set(SETTING_PATH_MESSAGING_FIFO "/tmp/polybar_mqueue.%pid%"
+set(SETTING_PATH_MESSAGING_FIFO "@TERMUX_PREFIX@/tmp/polybar_mqueue.%pid%"
CACHE STRING "Path to file containing the current temperature")
set(SETTING_PATH_TEMPERATURE_INFO "/sys/class/thermal/thermal_zone%zone%/temp"
CACHE STRING "Path to file containing the current temperature")

View File

@ -1,24 +0,0 @@
diff -uNr polybar/src/ipc.cpp polybar.mod/src/ipc.cpp
--- polybar/src/ipc.cpp 2019-04-03 08:32:20.000000000 +0300
+++ polybar.mod/src/ipc.cpp 2019-07-10 22:14:11.763825428 +0300
@@ -12,7 +12,7 @@
using namespace std;
#ifndef IPC_CHANNEL_PREFIX
-#define IPC_CHANNEL_PREFIX "/tmp/polybar_mqueue."
+#define IPC_CHANNEL_PREFIX "@TERMUX_PREFIX@/tmp/polybar_mqueue."
#endif
void log(const string& msg) {
diff -uNr polybar/src/utils/bspwm.cpp polybar.mod/src/utils/bspwm.cpp
--- polybar/src/utils/bspwm.cpp 2019-04-03 08:32:20.000000000 +0300
+++ polybar.mod/src/utils/bspwm.cpp 2019-07-10 22:14:35.983493128 +0300
@@ -85,7 +85,7 @@
return BSPWM_SOCKET_PATH;
}
- snprintf(sa.sun_path, sizeof(sa.sun_path), "/tmp/bspwm%s_%i_%i-socket", host, dsp, scr);
+ snprintf(sa.sun_path, sizeof(sa.sun_path), "@TERMUX_PREFIX@/tmp/bspwm%s_%i_%i-socket", host, dsp, scr);
free(host);
return sa.sun_path;